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1 Getting Started
Introduction
10
The noise figure measurement personality, available on the Agilent Technologies 
N8201A Option 219 performance downconverter synthetic instrument module, provides 
a suite of noise figure and gain measurements including system calibration.

A key measurement in the development of devices and systems is its noise figure. The 
overall noise figure of a system is one of the limiting factors in its performance. Making 
noise figure measurements can be a tedious manual process. But with Agilent’s noise 
figure measurement systems, these measurements can be fast and easy with accurate 
results. Meet many of your measurement needs with a one-analyzer solution from 
Agilent. 

• Perform system calibration easily and quickly.

• Analyze the device noise figure in several different formats.

• Characterize the noise figure of frequency conversion devices.

• Easily calculate measurement uncertainty.

The Agilent N8201A Option 219 offers high performance spectrum analysis up to  
26.5 GHz with powerful one-button measurements, a versatile feature set, and a 
leading-edge combination of flexibility, speed, accuracy and dynamic range. 

The noise figure measurements personality provides noise figure and gain measurements 
over the frequency range of the N8201A with specified measurements over the 10 MHz 
to 3 GHz range. 

Noise figure measurements:

• entering ENR values

• calibration

• noise figure and gain

• using display features

• measurement uncertainty calculator

• mixer as the DUT

• mixer as part of system

You need the following equipment to use the Noise Figure Measurement personality:

• Noise Figure Measurement Personality Option 219

• Option 1DS Internal Preamp (100 kHz to 3 GHz)

• Option 110 Internal Preamp (100 kHz to 50 GHz)

Agilent Technologies recommends that you install either Option 1DS (Internal 
100 kHz - 3 GHz Preamp) or Option 110 (Internal 100 kHz - 50 GHz Preamp), 
depending on your measurement needs. Option 1DS gives best performance in the 
100 kHz to 3 GHz range. Option 110 enables you to perform measurements above 
N8201A Noise Figure Measurement Personality Guide
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N8201A Noise Figure
3 GHz up to the frequency limits of your N8201A. If you ever have to measure above 
3 GHz, then choose Option 110. The preamp is required for specified performance at all 
frequencies.
Specifications
Performance specifications can be found in the N8201A Data Sheet.
Available Measurement Personality Options
Table 1 Measurement Personality Options

Available Personality Options Option 
Number 

Noise Figure measurement personality 219

Phase noise measurement personality 226
 Measurement Personality Guide 11



1 Getting Started
Overview of the N8201A Option H02 Spectrum Analyzer GUI

File Menu
12
The File menu allows you to specify a N8201A performance downconverter to monitor 
with the Spectrum Analyzer GUI (Graphical User Interface).

Connect

Enter the IP (Internet Protocol) or VISA address of the instrument you wish to control 
with the Spectrum Analyzer GUI.

Disconnect

Terminates the connection between the Spectrum Analyzer GUI and the spectrum 
analyzer.

Exit

Closes the Spectrum Analyzer GUI application.
Help Menu
Provides information about the current version of the Spectrum Analyzer GUI.
N8201A Noise Figure Measurement Personality Guide
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Left Pane
N8201A Noise Figure
Display Area

Replicates the actual hardware spectrum analyzer display. 

Update Display

When clicked, the GUI display is updated with the current view of the hardware’s 
spectrum analyzer display.

Refresh Data Automatically

When selected, automatically updates the GUI display to match the hardware’s spectrum 
analyzer display several times per second. Note that using this function slows down the 
response time of the GUI.
Center Pane
Displays the menu keys for the currently selected front panel key. For example, clicking 
Mode in the right pane, identifies “Mode” in the title area of the center pane and the 
Mode menu keys under the title.
Right Pane
Front Panel Keys

Displays the front panel keys. Once a front panel key has been clicked, the associated 
menu keys are displayed in the center pane.

Marker Control

Provides control over the four markers.

Adjust Specifies one of the four markers for adjustment.

Specified In Spectrum Analysis mode, you display the position indicator as points or 
trace units.

Position Displays the current position of the selected marker. You can also type in a 
desired value for the marker position.

Position Slider Allows movement of the selected marker. Click and drag the slider bar 
to move the marker, or for fine tuning use the left and right arrow keys.
 Measurement Personality Guide 13
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1 Getting Started
Interactive SCPI Tab

Command Allows you to enter a SCPI programming command to control the 
instrument. Some functions do not have a menu key and are only available by entering a 
SCPI command. 

Send Writes what you have entered in the Command text box to the I/O buffer.

Read Reads the response that the instrument places on the I/O buffer.

Send & Read Writes to the I/O buffer and then reads the response from the I/O buffer.

Instrument Session History Displays a listing of recent activity.

Clear Clears the information in the Instrument Session History area.

Hide Controls

Conceals the right pane of the GUI allowing full screen display of the graph area.

Show Controls

Displays the front panel keys (right pane) along with the graph area. This key is only 
available when Hide Controls is the active function.
N8201A Noise Figure Measurement Personality Guide
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Starting the Noise Figure Personality
N8201A Noise Figure
1 Connect the N8201A to the PC using Agilent Synthetic Instrument Finder or Agilent 
Synthetic Instrument GUI. Refer to the N8201A Performance Downconverter User’s 
Guide for more information.

2 Click Start > Programs > Agilent SI Tools > N8201A Option H02 Spectrum 
Analyzer GUI to open the N8201A Option H02 Spectrum Analyzer GUI.

3 Click File > Connect and enter the VISA address for the N8201, and then click OK.

4 Click MODE > Noise Figure to start the Noise Figure measurement personality.

5 Click Measure > Monitor Spectrum, Log Plot, or Spot Frequency to choose the 
applicable measurement type.
 Measurement Personality Guide 15



1 Getting Started
Saving the Instrument State
16
Saving an instrument state when in Noise Figure mode will save the entire measurement 
mode and measurement setup with the exception of trace and limit lines. This means that 
when you save the state and all of the current settings, including:

• ENR data

• Frequency Lists

• Loss Compensation Lists

• Resolution Bandwidth settings

• Calibration data

To Save the Instrument State:

1 Click File > Save.

2 Click Type > State.

3 Select the Destination of the Device Instrument or PC.

4 Specify the File Name

5 Click Save Now

Loading a state that has been saved at any time from the Noise Figure mode will force 
the N8201A to switch to Noise Figure mode, and will overwrite any existing settings 
with those that were valid when the state was last saved.
NOTE Limit lines and trace data are not saved in the instrument state. They must be explicitly 
saved using the File and Save keys, and setting Type to the appropriate setting
Table 2 Saving the Instrument State

Table / Parameter Saved in 
State*

* Settings saved in a Save State operation can be recalled by pressing the File, Load and Type keys. They 
can also be recalled using a Power On Last or a User Preset operation.

Saved 
as a file

Survives 
Preset

Survives 
Mode Switch

Survives 
Power Cycle

ENR Tables Yes Yes Yes Yes Yes

Freq List Yes Yes No Yes No

Loss Comp Table Yes Yes No Yes No

Limit Lines No Yes Yes Yes Yes

Correction data 
(Calibration)

Yes No Yes Yes No
N8201A Noise Figure Measurement Personality Guide
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2
Making Basic Measurements

This chapter describes how to make basic noise figure measurements with the N8201 
Option 219 Noise Figure Measurement application. It also covers the most common 
measurement related tasks.
What You will Find in this Chapter
“Tips for Using the Measurement Examples" on page 18

“Entering Excess Noise Ratio (ENR) Data" on page 19

“Setting the Measurement Frequencies" on page 24

“Setting the Bandwidth and Averaging" on page 27

“Calibrating the N8201A" on page 29

“Displaying the Measurement Results" on page 34

“Indicating an Invalid Result" on page 46

“Example of a Basic Amplifier Measurement" on page 47
17Agilent Technologies



2 Making Basic Measurements
Tips for Using the Measurement Examples
18
• Setup diagrams through out the Measurement chapters show a PSA series spectrum 
analyzer as the measuring device. The N8201A performance downconverter can be 
used as the measuring device as well. Notice that the Noise Source Drive Out +28 V 
is located on the front panel of the N8201A.

• All front panel key presses are indicated in bold text.

• All sub menu key presses are indicated in italic text.

• Make sure that you have selected the Noise Figure measurement personality. 

• Click Mode > Noise Figure

• Click Measure > Noise Figure.

• You can choose to maximize the N8201 Option H02 Spectrum Analyzer GUI display. 
The advantage of doing this is that most of the sub menu keys are available on one 
page. Also, the display area will be much larger.

• If you choose to leave the Spectrum Analyzer GUI window at its default size, you 
may have to click More 1 of .... to get to the desired function.

• While going through the measurement examples, you may want to select Refresh 
Display Automatically. This way you can see changes as you apply them. This 
selection can slow down the processing time of the instrument, therefore; during 
normal testing you may choose to have this feature turned off.

• All sub menu keys that contain number or text values, for example Start Frequency, 
are editable. CliN8201A Noise Figure Measurement Personality Guideck on the 
numeric entry to change the value. Use the PC’s keyboard to enter the desired value 
and then type in the first letter of the units designator.
G giga 109

M mega 106

k kilo 103

Enter key 100

m mil 10-3

u micro 10-6

n nano 10-9
N8201A Noise Figure Measurement Personality Guide



Making Basic Measurements 2
Entering Excess Noise Ratio (ENR) Data
N8201A Noise Figure
You can enter ENR data for the noise source you are using as a table of values or as a 
single spot value. The values held in the table can be used for measurements at a range of 
frequencies as well as at a fixed frequency. 

The single spot value is used either for measurements at a single frequency, or for 
measurements across a range of frequencies that is narrow enough such that the ENR 
value does not change significantly across that range.

There are two types of noise source. The first type, for example, an Agilent 346B, is a 
normal noise source that is powered by a pulsed +28 V supply. These need their ENR 
data to be entered manually, either by using the ENR data previously stored (such as that 
supplied with Agilent noise sources) or by using the keyboard to enter values into the 
ENR table.
Selecting a Common ENR Table
You can use the same, Common, ENR table both for calibration and for making 
measurements, or you can use separate Measurement ENR and Calibration ENR tables. 
You need separate measurement and calibration tables when separate noise sources are 
used for DUT measurements and for calibration. An example of this is when you are 
using frequency converters, and the calibration range is different than the measurement 
range.
NOTE ENR tables can contain up to 401 frequency points.
To use the same ENR table for calibration and measurement:

1 Click Meas Setup > ENR > Common Table to select On. This configures the 
downconverter to use a common ENR table both for measurements and for 
calibration.

The default setting for Common Table is On. In this mode the Cal Table... is not 
accessible.

To use different ENR tables for calibration and measurement, click Common Table to 
select Off.

When Common Table is set to Off, the Cal Table... key is accessible. Cal Table... gives 
you access to the ENR table of the noise source used to calibrate the N8201A.

When Common Table is set to Off, the Meas & Cal Table... function is also accessible. 
This gives you access to the ENR data table for the noise source used to make 
measurements.
 Measurement Personality Guide 19
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2 Making Basic Measurements
When Common Table is set to On, the Meas Table... is used as the Common Table, and 
is used for both calibration and measurement. The Spectrum Analyzer GUI sub menu 
keys will then refer to the Meas & Cal Table... instead of the Meas Table....
Entering ENR Table Data for Noise Sources
You can manually enter ENR data in the form of an ENR table in three other ways:

• You can load the ENR data diskette, supplied with every Agilent noise source, onto 
your PC then load the ENR table into the Spectrum Analyzer GUI. 

• You can load the ENR data from the internal memory, where the data has been 
previously stored.

• You can manually input the required frequencies and corresponding ENR values.

Normal noise sources from Agilent Technologies have the ENR values printed on the 
body of the device. These ENR values are also provided in the form of a calibration 
report, and on a diskette which is supplied with every Agilent noise source. Load this 
diskette onto your PC and then load it into the Spectrum Analyzer GUI. The values 
printed on the noise source itself are only shown to two decimal places. The values 
stored on a diskette are correct to three decimal places.

To load ENR data from diskette or from memory

If the noise source you are using has its ENR data supplied or previously stored on a 
diskette or internal memory, you can load this ENR data into the Spectrum Analyzer 
GUI as follows.

1 If the ENR file is on diskette, insert the diskette into the floppy drive of the PC. 

2 Click File > Load to access the file system.

3 Click Type to select the type of file you wish to load, either the ENR Meas Common 
Table or the ENR Cal Table.

4 Click Source Device PC.

5 Click File Path to locate the ENR data file. 

6 Once you have highlighted the correct file, click Load Now.

To enter ENR table data manually

1 Click Meas Setup > ENR > Meas & Cal Table... > Table.

An ENR table appears on the display. Select a current row for editing, or add data for a 
new row. You can also delete an entry by selecting the entry and pressing the 
keyboard’s Delete key. (see Figure 1). 
N8201A Noise Figure Measurement Personality Guide
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N8201A Noise Figure
Figure 1 An ENR Table

• Optional Step

Click Serial # and enter the noise source serial number using the keyboard.

• Optional Step

Click Model ID, and enter the noise source model number using the keyboard.

2 After completing the ENR table, click OK > Back to return to the ENR menu.
Saving an ENR Table
You can save an ENR table either to the downconverter’s internal memory or to the PC 
as follows:

1 Click File > Save.

2 Select the type of file you wish to save by clicking Type and then either ENR Meas 
Common Table or ENR Cal Table.

3 Click Destination Drive Instrument/PC to select where you wish to save the ENR 

4 Click File Name and choose an applicable file name.

Although the file extension is shown in the default filename, you must not include the 
file extension when specifying your own filename. The file extension is determined 
by the type of file you are saving and is added automatically to the filename you 
specify.

5 Click Save Now to save the file.
Entering a Spot ENR Value
A Spot ENR value can be applied across the whole measurement frequency range, or 
when making a measurement in fixed frequency mode, you can enter a specific spot 
ENR value corresponding to the fixed frequency. 
 Measurement Personality Guide 21
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2 Making Basic Measurements
To enter a Spot ENR value:

1 Click Meas Setup > ENR > Spot > Spot ENR.

2 Enter an ENR value using the keyboard. The default value is 15.20 dB.

3 Press the keyboard’s Enter key to terminate.

If you are using a noise source with a calibrated ENR list and the frequency you want to 
measure is not a listed ENR value, then you need to interpolate the ENR list to an 
appropriate value.

To Enable Spot ENR Mode

1 Click Meas Setup > ENR > Mode Table/Spot with Spot underlined.
Entering a Spot Thot Value
When making a manual measurement you can enter a specific Spot T hot value. The Spot 
T hot value is applied across the whole measurement frequency range

To enter a Spot Thot value:

1 Click Meas Setup > ENR > Spot > Spot T hot.

2 Enter a Thot value and units terminator using the keyboard. The default value is 
9892.80 K

3 Press Enter on the keyboard to terminate.

You can enter Thot temperatures in degrees centigrade (C), in degrees Fahrenheit (F), or 
in Kelvin (K). Whatever units you use when entering the Thot temperature, the 
temperature will be converted automatically and displayed in K. For example, if you 
enter 100 C, the displayed value will be converted to 373.15 K.

To Enable Spot Thot Mode

1 Click Meas Setup > ENR > Mode Table/Spot with Spot underlined.

2 Click Spot > Spot State ENR/Thot with Thot underlined.
Setting the Tcold value
When making measurements in different ambient temperature conditions you can 
change the Tcold value manually. 

The default temperature value is set at 296.50 K (23.25° C or 73.85° F). The T cold key 
is set to Default to confirm this default temperature. 
N8201A Noise Figure Measurement Personality Guide
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N8201A Noise Figure
Changing the User Tcold value manually 

To change the User Tcold value:

1 Click Meas Setup > ENR > T cold Default/User so that User is underlined.

2 Enter the Tcold temperature and units terminator using the keyboard. 

3 Press Enter on the keyboard to terminate.

You can enter Tcold temperatures in degrees centigrade (C), in degrees Fahrenheit (F), or 
in Kelvin (K). Whatever units you use when entering the Tcold temperature, the 
temperature will be converted automatically and displayed in K.
 Measurement Personality Guide 23



2 Making Basic Measurements
Setting the Measurement Frequencies
24
Before you set the frequencies you want to measure, you need to select a frequency 
mode. Three frequency modes are available:

• Sweep — the measurement frequencies are obtained from the start and stop (or 
equivalent center and span) frequencies and the number of measurement points.

• List — the measurement frequencies are obtained from the frequency list entries.

• Fixed — the measurement frequency is taken at a single fixed frequency.
Using Sweep Frequency Mode
In sweep frequency mode you set the start and stop frequencies (or equivalent center and 
span frequencies) over which the sweep is made. You also need to set the number of 
measurement points. These measurement points are equally spaced over the frequency 
span. The maximum number of points is 401 and the default number of points is 11.
CAUTION If you change the span after a calibration, and the calibration has been made over a 
narrower frequency range, the calibration is invalid.
To make a measurement over a specific frequency range:

1 Click Frequency/Channel > Freq Mode > Sweep.

2 Set the frequency range by using the keyboard to enter the Start Freq and Stop Freq 
frequencies with the units terminator. For example, G for Gigahertz, M for 
Megahertz, and so on. 

3 Press Enter on the keyboard to terminate.

4 Click Points and type in the number of measurement points and then press Enter to 
terminate.

The time required to make a measurement or to calibrate is proportional to the number of 
measurement points that you specify.
Using List Frequency Mode
List frequency mode allows you to enter the frequency points where measurements are 
made. This allows you to specify measurement points, for example, in areas of interest 
that would otherwise have less coverage in the sweep mode. List Frequency mode can 
also be used to avoid making measurements at frequencies where spurs are known to 
exist.

Frequency lists are limited to 401 entries. 
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To set the downconverter to use the data in the frequency list table:

1 Click Frequency/Channel > Freq Mode > List.

You can create a frequency list in the following ways:

• Manually, by specifying each individual point.

• Loading a list from the instrument’s internal memory or from the PC where the 
data has been previously stored. 

To Create a Frequency List Manually

1 Click Frequency/Channel > Freq Mode > List > Frequency List. 

A Frequency List table appears on the display.

Figure 2 An Empty Frequency List

You do not need to enter the frequency values in ascending order, as the Spectrum 
Analyzer GUI continually sorts the values into ascending order.

2 Select a current row for editing, or add data for a new row. 

Once data is entered for a frequency point the next frequency point in the table is 
automatically highlighted.

3 Save the Frequency List to the instrument’s internal memory or to the PC using the 
File key. Refer to “Saving an ENR Table" on page 21 for more information.
Using Fixed Frequency Mode
The fixed frequency mode is used when you want to make a measurement at a single 
frequency.

If you have not entered the noise source ENR data which you intend using for the fixed 
frequency mode measurement, you may specify a spot ENR value and set the ENR mode 
to Spot.
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To set a fixed frequency:

1 Click Frequency/Channel > Freq Mode > Fixed.

2 Click Fixed Freq and enter the frequency value with the first letter of the units 
terminator. For example, “G” for Gigahertz.
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Setting the Bandwidth and Averaging

Effect of Bandwidth and Averaging on Speed, Jitter, and Measurement 
Accuracy
N8201A Noise Figure
Jitter is a natural occurrence when measuring noise. To reduce jitter you must increase 
the number of averages or increase the measurement bandwidth.

If the bandwidth is reduced, you need to increase the number of averages to maintain the 
same uncertainty.

The greater the number of averages chosen, the more accurate the measurement, as this 
reduces jitter on the measurement. However, this has to be considered against how long 
it takes to complete the measurement.

There is therefore a trade off between speed and the accuracy/uncertainty of a 
measurement.
Selecting the Resolution Bandwidth Value 
When the Res BW is set to Auto, the bandwidth is set automatically, and is dependent on 
measurement frequency.

At measurement frequencies of 3 MHz or above, the resolution bandwidth is set 
automatically to 1 MHz.

At measurement frequencies less than 3 MHz, the resolution bandwidth is set 
automatically to 10% of the measurement frequency.

When the Res BW is set to Man, you can manually specify the resolution bandwidth 
from a minimum of 1 Hz to a maximum of 8 MHz. The lower the resolution bandwidth 
setting, the longer the measurement will take. With a Res BW setting of 1 Hz, each 
measurement point may take up to 6000 seconds.
Setting Averaging
Increased averaging reduces jitter and provides more accurate measurement results. 
However, the measurement speed is sacrificed. The maximum number of averages 
allowed is 1000, and the default value is 10. The default setting, however, is Off.

Enabling averaging

Averaging can be enabled by setting the Averaging to On. To disable averaging set 
Averaging to Off.
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Setting the Number of Averages

To set the number of averages you want:

1 Click Meas Setup > Avg Number to On.

2 Click on the numeric entry field and enter the desired number of averages.

3 Press Enter to accept the new value.

Selecting the Averaging Mode

Averaging Mode is permanently set to Repeat. No other form of averaging is available.

With Repeat averaging, each point in a sweep is measured an Avg Number of times and 
the average figure evaluated, before moving on to the next point in the sweep.
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Calibrating the N8201A
N8201A Noise Figure
To compensate for the noise contribution of the N8201A and associated cabling in the 
measurement path, a calibration is necessary. The calibration measures the N8201A’s 
noise contribution with no DUT (device under test) in place. This correction is often 
referred to as the second stage calibration. The correction is then applied to the 
measurement with the DUT in place.

To perform a calibration you need to enter the ENR values and set up the frequency 
range, number of measurement points, the bandwidth, the averaging, and measurement 
mode to be used during the measurement.

If you alter the frequency range after you have calibrated the N8201A, it changes the 
calibration status to either the uncorrected or the interpolated corrected state. Before you 
can make another measurement to the specified accuracy, you will need to either 
recalibrate the N8201A, or recall a previously saved state file in which the calibration 
data has been saved.
Corrected Measurements
You can make corrected measurements only at frequencies which are covered by the 
current calibration. Attempting to make corrected measurements at frequencies less than 
the lowest calibration frequency or greater than the highest calibration frequency will 
generate an error and invalidate the calibration.

To proceed you must either:

• perform a calibration over the desired measurement frequency range

• change the measurement frequency to one covered by the existing calibration

• perform uncorrected measurements. Uncorrected measurements actually measure the 
noise figure of the N8201A and any associated components in the input path. This 
can be useful if you wish to use the Uncertainty Calculator.

If you perform a measurement outside the calibrated range of the N8201A, Noise Figure 
Correction is automatically set to Off and a message is displayed stating User Cal 
invalidated, freq outside cal range. If you then change your measurement frequency back 
to a frequency within the calibrated range, the previous error message will be replaced 
by a message stating User Cal valid. Noise Figure Correction, however, will still be set 
to Off. You will need to switch it On again to make a corrected measurement.
When to Perform a Calibration
To make corrected measurements, you must calibrate the N8201A whenever:

• You cycle the power of the N8201A.

• You Preset the N8201A.

• You select a measurement frequency or frequency range outside the currently 
calibrated range.
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• You change the RBW setting across the 1.5 MHz boundary. That is, if you change 
from an RBW value less than or equal to 1.5 MHz to one that is greater, or from an 
RBW value greater than 1.5 MHz to one that is at 1.5 MHz or lower.

• There is a large temperature variation since the last calibration.

• The input signal level can no longer be measured using one of the calibrated input 
attenuator ranges.

• When an invalid result is detected and the condition is indicated by a “xx”. See 
“Indicating an Invalid Result" on page 46 for an explanation of these conditions.
Interpolated Results
When the location of measurement points is changed without exceeding the range of 
frequencies being measured, interpolation between calibration points is used and a new 
calibration is not required. Similarly, when the RBW is changed without crossing the 
1.5 MHz boundary, the power at each calibration point is re-estimated, and a new 
calibration is not required. Interpolation, however, is not perfect; it is therefore always 
better to perform a new calibration. 

The locations of the measurement points, that is, the frequencies at which measurements 
are made, change whenever the start frequency, the stop frequency, or the number of 
points is changed.
Calibration Indicator
Whenever anything within the N8201A changes to invalidate the current calibration, the 
message UnCorr is displayed in red at the top left-hand corner of the display. If the 
N8201A has been successfully calibrated for the current frequency and measurement 
settings, the message Corr is displayed in green text at the top right-hand corner of the 
display.
Interpolated Calibration 
Whenever anything within the N8201A changes to force the current calibration to 
interpolate the calibration data, the green Corr message at the top right-hand corner of the 
display switches to a yellow ~Corr message at the top center of the display. This would 
happen, for example, if you change the RBW after calibrating but before measuring.
To Perform a Calibration
1 Verify that the correct ENR table is loaded in the Spectrum Analyzer GUI, or input 
the ENR values of the noise source into the Common or Calibration Table.

See “Entering ENR Table Data for Noise Sources" on page 20 for more details.

2 Click Meas Setup > ENR > Common Table Off > Cal Table.... The calibration table 
will now be displayed. 
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3 Configure the measurement parameters (frequency range, number of points, 
bandwidth, averages, and measurement mode) you want to use for the measurement.

4 Connect the noise source between the N8201A Noise Source Drive Out +28 V 
(Pulsed) and the RF input put.

Figure 3 Calibration Setup

You may need to use connector adaptors to connect the noise source output to the 
N8201A RF input during calibration. The connectors you use need to be included in 
the measurement. If you remove these connectors for the measurement, you need to 
apply Loss Compensation to compensate for any loss caused by the connectors’ 
removal. 

5 If required select an input attenuator range,

• Click Input/Output > Noise Figure Corrections On > Input Cal and set the Min 
Atten and Max Atten input attenuation.

See “Selecting the Input Attenuation Range" on page 32 for mode details on input 
attenuation.

6 Click Meas Setup > Calibrate to initiate the calibration.

When the calibration is finished the calibration indicator changes from a red UnCorr 
display to a green Corr display. Also the Noise Figure Corrections key (Input/Output 
Noise Figure Corrections > NF Corrections On/OFF) allows you to make corrected or 
uncorrected measurements by switching between On and Off respectively.

Measurement performance above 3 GHz is not specified. If you do not have either 
Option 110 high band preamplifier or an external preamp, and you are calibrating above 
3 GHz, the calibration data will vary significantly. Measurements made with this 
calibration data might be valid, but only if the device you are testing has a high gain. If 

NOISE SOURCE DRIVE 
OUT +28 V (PULSED)

NOISE SOURCE
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this is not the case, the measurement accuracy will be poor. See the N8201A 
Performance Downconverter Specifications Guide for more detail on operating above 
3 GHz.

When using external preamplifiers or high-gain DUTs, ensure that neither the external 
pre-amp (or the high-gain DUT) nor the internal pre-amp go into compression as this 
will affect the accuracy of your measurements. If you suspect that one or other of the 
pre-amps is going into compression, use attenuation prior to that pre-amp to prevent 
compression. Note that the N8201A’s internal attenuator will only affect compression 
occurring in the internal pre-amp. It will not have any effect on any compression 
occurring in the external pre-amp.
Selecting the Input Attenuation Range
The Noise Figure Measurement Personality, Option 219, has a default input attenuation 
calibration range of 0 dB to 8 dB, and a step size of 4 dB. 

In the Option 219 Noise Figure application, the attenuators cannot autorange. There is 
therefore a risk of overdriving the N8201A. If the signal power level is greater than –35 
dBm the preamp will go into compression and the accuracy of your results will be 
adversely affected. In most cases, 0 dB attenuation is adequate. A guide to the input 
powers that can be handled by the N8201A at each frequency range is shown in Table 3 
on page 33.

To check for overdriving of the N8201A, that is, compression occurring at the preamp 
stage, set the attenuation to 0 dB and note the noise figure of your DUT. Now increase 
the attenuation by one step. If your noise figure changes by more than 0.5 dB, 
attenuation is required. Repeat this process until you have found the lowest level of 
attenuation that gives you a stable noise figure result, and use this attenuation level for 
your measurements.
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To select the input attenuation calibration range:

1 Click Input/Output > Noise Figure Corrections >Input Cal.

2 Set the attenuator range using Min  Atten and Max  Atten, and enter the required 
attenuation calibration range. Use Table 3 on page 33 as a guide to what range you 
require.

Table 3 Power Detection and Ranging *

* The figures given in the table (above) for 200 kHz to 3 GHz assume a 5 dB ENR noise source and that the 
preamp is On. The figures for 3 GHz to 50.0 GHz assume a 15 dB ENR noise source.

Frequency Attenuation 
Setting

Maximum Input 
Power for High 
Accuracy

Approximate DUT 
Characteristics

200 kHz to 
3 GHz†

† If the DUT has a narrower bandwidth than the 200 kHz to 3 GHz specified here, the DUT characteristics can be 
increased accordingly. For example, if the DUT has a bandwidth of 100 MHz, the DUT characteristics can be 
increased by a factor of 10 x log(3 x 109 / 100 x 106), that is, by 15 dB. In this example with an attenuation 
setting of 0 dB, the Gain of a DUT with a 15 dB Noise Figure can be increased from 29 dB to 44 dB.

0 dB –35 dBm Over the full bandwidth, a DUT 
with NF = 5 dB and Gain = 36 dB, 
or a DUT with NF = 15 dB and Gain 
= 29 dB

200 kHz to 
3 GHzb

4 dB –39 dBm Over the full bandwidth, a DUT 
with NF = 5 dB and Gain = 40 dB, 
or a DUT with NF = 15 dB and Gain 
= 33 dB

200 kHz to 
3 GHzb

8 dB –43 dBm Over the full bandwidth, a DUT 
with NF = 5 dB and Gain = 44 dB, 
or a DUT with NF = 15 dB and Gain 
= 37 dB

200 kHz to 
3 GHzb

12 dB –47 dBm Over the full bandwidth, a DUT 
with NF = 5 dB and Gain = 48 dB, 
or a DUT with NF = 15 dB and Gain 
= 41 dB
Setting the Input Attenuation after a Calibration
The attenuators cannot autorange. Hence, when making a measurement you must 
manually set the input attenuation to avoid overdriving the N8201A. To set the input 
attenuation:

1 Click Input/Output >Attenuation and enter the desired measurement attenuation. 
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The Spectrum Analyzer GUI features a color display and a comprehensive set of display 
features to allow you to analyze the measurement results in detail, or to quickly obtain 
pass/fail indication.

The following display format features are available:

• Graph, Table or Meter mode display

• Single or dual-graph display allowing any two available result types to be displayed 
simultaneously

• Combine option to display two result types on the same graph

• Markers for analyzing a trace, and for displaying point data more accurately than can 
be done with a trace alone

• Save the current active trace data to memory

• Switch the graticule on or off

• Switch display annotation on or off
Selecting the Display Format
You can display the measurement results in either:

• Graph format

• Table format

• Meter format

The default display provides a display of noise figure and gain on the dual-graph display. 
The upper graph is noise figure and the lower graph is gain.

In all formats you can choose two result parameters you want to display.

To set the display format:

1 Click Trace/View > View > Graph, Table or Meter to select the display mode you 
want.
Navigating Around the Display
Active Graph

The active graph is highlighted by a green border. Noise Figure is the active graph by 
default.
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Figure 4 Dual-graph display

Changing the Active Graph

To change the active graph, click Trace/View > Display > A Only or B Only. This allows 
you to set the upper or lower graph as the active graph.

Viewing the Full Screen

You can fill the entire display and remove the menu keys from the display. 

1 At the bottom right pane of the window, click Hide Controls.

2 To return to a normal display, click Show Controls on the right side of the window.
Selecting Result Types to Display
You can choose to display any pair of measurement results in all of the display format 
modes. 

The measurement result types are as follows, with their units in parentheses:

• Noise Figure (dB)

• Noise Factor (linear power, measured in watts)

• Gain (dB)

• Y Factor (dB)

• T effective (Kelvin, K)

• P hot (dB)

• P cold (dB)
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To specify which measurement results are displayed

1 Click Trace/View > Result A and select the result type that you want to display. 
These results will be displayed in the left portion of the display window when Meas 
View is set to Graph, and in the upper portion of the display when Meas View is set to 
Table.

2 Click Result B and select the result type that you want to display. These results will be 
displayed in the left portion of the display window when Meas View is set to Graph, 
and in the upper portion when Meas View is set to Table.

If you click Amplitude/Y Scale while Meas View is set to Graph, the scale menu 
keys for the active measurement are shown.
Graphical Features
Viewing a single graph

While in graph format mode, you can Trace/View > Display > A Only or B Only so that 
the active graph fills the display as a single graph, as shown in Figure 5. 

Figure 5 Displaying a single graph
NOTE When in single graph mode, click Trace/View > Display > A Only or B Only to display 
the other single graph.
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Combining two traces on the same graph

You can combine the upper and lower graphs from a dual-graph display into a single 
combined display. By default, the Combined setting is Off and the graphs are not 
combined.

When combining two graphs, the Y-scale result limits are not re-scaled. Both graphs 
have their own Y-scale result limits which are indicated in different colors. These colors 
correspond to the colors of the traces in the combined graph.

To combine the two graphs:

1 Click Trace/View > View and ensure Graph is selected.

2 Click Combined On/Off to the On setting to combine the two currently displayed 
graphs on the same graph.

Figure 6 Typical display with two traces combined on the same graph

Turning the Graticule On and Off

When Graticule On/Off is set to On, the graticule divisions are displayed on the screen. 
This is the default setting. When Graticule is set to Off, the graticule lines are not 
displayed on the screen.
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To turn the graticule on or off:

1 Click Display >Preferences > Graticule On/Off.

Figure 7 Typical Graph with Graticule Switched Off

Turning the Display Annotation On or Off

When Annotation On/Off is set to On, the annotation is displayed on the screen. This is 
the default setting. When Annotation is set to Off, the annotation is not displayed on the 
screen.
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To turn the annotation on or off:

1 Click Display > Preferences > Annotation Off or On as required.

Figure 8 Typical Graph with Annotation Switched Off

Setting the Scaling

You can set the result’s scale parameters in the active graph. 

1 Click Amplitude/Y Scale to set the scale.

2 To change the active graph, click Trace/View > Display and select the desired graph 
view.
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Figure 9 Typical Noise Figure Displayed on a Graph

3 Click Amplitude/Y Scale. 

4 You can set the scale for the measurement display manually, or click Auto Scale.

Selecting Auto Scale selects the optimum values for Ref Value and Scale/Div.

Note that if limit line Display is set to On, and Autoscale is pressed or the scale is 
changed, the limit lines may no longer appear in the display.

Setting Noise Figure Scale

The following procedure can also be applied to other result types.

To make Noise Figure the active screen and set up the noise figure parameters, use the 
following procedure.

5 Click Trace/View > Display > Result A or Result B depending on whether you want 
the Noise Figure results displayed in the upper (Result A) or lower (Result B) graph.

6 Click Noise Figure or Noise Factor. 

If you select the Noise Factor function, the graph will display Noise Factor instead of 
Noise Figure results. Noise Factor results are displayed on a power (watts) scale.

7 Click Amplitude/Y Scale > Scale/Div and change the scale per division value. 

8 Type in the values with the keyboard and then press Enter to accept the changes.

Instead of setting the Scale/Div manually, you can let the N8201A choose a suitable 
value that will cause the measurement trace to be displayed over the full height of the 
display window. 

To do this, click Auto Scale.
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Setting the Reference Value

1 Click Ref Value and change the reference value using keyboard. Values that are 
entered are automatically converted to dB.
Working with Markers
The marker functions only apply when you are working in graph format.

Marker functions measure the frequency and measurement results by placing a 
diamond-shaped marker at a point on the trace. The measurement results displayed 
depend on the result type selected.

The Spectrum Analyzer GUI has four markers. The markers are coupled to both the 
lower graph trace and upper graph trace.

Each marker can be enabled as a normal or delta marker. The active marker’s frequency 
is displayed in the active function area, and at the bottom of the screen. The enabled 
marker’s results are displayed under the Markers tab bar at the bottom of the display. 

Selecting Markers

To select a marker:

1 Click Marker > Select Marker to select the desired marker: 1, 2, 3, or 4.

The active marker is identified by being underlined in the Marker key label. 

2 Click Marker > Mode > Normal or Delta to select your type of marker(s).

Figure 10 A Normal State Marker
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A marker is now placed on each trace. Use the Marker Position entry box or slider to 
move the marker. The marker frequency and marker result are displayed under the 
Marker tab bar which is below the graph display. Their frequency values are also 
displayed in the active function area.

A marker can only be placed on a point where a measurement has been made. It is not 
possible to place a marker at an interpolated position on the graphs.

To turn an active marker off

• To turn an active marker off, click Marker > Mode > Off. 

• To turn off all markers, click Marker > Markers All Off. This also removes the 
marker annotation from the marker tab at the bottom of the screen, and the marker 
frequency from the active function area.

To change the active marker

The default active marker setting is Marker(1). 

1 To change the active marker, click Marker > Select Marker. This moves the active 
marker from Marker(1) to Marker(2). Click it again and it moves the active marker 
from Marker(2) to Marker(3). This process is repeated until it returns to the 
Marker(1).

Figure 11 Four Normal State Markers
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To use Delta Markers

The Delta key places a reference marker at the current position of the active marker. The 
delta markers enable you to measure the difference between the reference marker and the 
delta marker position on the trace. Use the Marker Control positioned to place the delta 
marker to the point on the trace you want to measure. The position of the reference 
marker remains fixed. The delta marker has its frequency and measurement result value 
differences annotated relative to the reference marker on the marker tab at the bottom of 
the screen. The delta marker has its actual frequency value is displayed in the active 
function area. See Figure 12.

Figure 12 The Delta Marker State enabled

To activate a Delta marker:

1 Click Marker > Select Marker to select the marker of interest.

2 Click Mode > Delta. 

3 Use the Marker Position text box or slide bar to move the Delta marker from the 
reference marker. The annotation on the marker tab at the bottom of the screen 
displays the difference between the reference marker and the delta marker. The 
frequency of the delta marker is displayed in the active function area at the top of the 
display.
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The Peak Search key accesses a further menu which allows you to place an active 
marker on the minimum or maximum points of a trace when using a Normal marker. 
When using Delta markers, you can search for the Minimum Peak to Maximum Peak on 
the trace. 

It should be noted that the Search function operates on the active trace. The active trace 
is always indicated by underlining of the name of the measurement. When two 
measurements are shown in two separate windows on the display, that is, when 
Combined is set to Off, the active trace is also indicated by a green border surrounding 
the graph. 

The marker on the second trace, that is, the marker on the inactive trace, is positioned at 
the same frequency position as the marker on the active trace.

Searching for Min or Max Point

You need to have activated a Normal marker to perform a minimum or maximum search.

Figure 13 Typical Trace showing Maximum Point Found

To search for the maximum point:

1 Click Peak Search.

2 Click Search Type > Maximum.

3 Click Continuous On if you want the marker to constantly move to the maximum 
peak.

The marker is now placed at the maximum point of the active trace.
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Searching for Peak to Peak Points

Figure 14 Peak to Peak Found

1 Click Peak Search.

2 Click Search Type >Pk-Pk.

The markers are now on the maximum and minimum points of the trace. The annotation 
displays the difference between the two points.

3 If you want to continuously find the maximum and minimum points on the trace, set 
Continuous to On.
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When an invalid result is detected while in graph display format, the graph is drawn at 
the top of the screen for the current measurement point and a special marker indicator is 
displayed. Also in table and meter formats the same special indicators are used to display 
an invalid result.

Several invalid result conditions may exist simultaneously. These conditions are ranked 
in order of severity and only the most severe condition present is displayed.

The ranking order is:

Table 4 Ranking Order of Invalid Result Conditions

The ranked order 2 only occurs if a corrected measurement is requested and either:

• The input range used at this measurement point is not calibrated.

• The input range is calibrated, but the calibration data is invalid at this point.

Ranking Order Invalid Result Condition Marker Indicator

1 Hot power ≤ cold power “==”

2 Corrected calculation not possible “xx”

3 Measurement result calculation invalid “--”
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Noise figure measurements are made by measuring the output power of the DUT for two 
different input noise power levels. The high and low power inputs come from a 
calibrated noise source. The noise source is switched on and off in rapid succession. 
High power input to the N8201A uses the noise power generated when the noise source 
is switched on, and low power input uses the noise power generated at ambient 
temperature with the noise source switched off. 

This section uses a DUT to show how a basic noise figure measurement and various 
basic operations are performed. The DUT used is a low noise amplifier with a usable 
frequency range of 20 MHz to 3.0 GHz. The specifications of interest to the example are 
listed in Table 5.

Table 5 The Example DUT Specifications

The example sets a frequency range of interest of 1.0 GHz to 2.0 GHz. The purpose of 
the measurement is to verify the specified table results are as stated over the frequency 
range of interest.

When you are making measurements, follow the procedure and change the values to 
meet your needs.

For these basic measurements confirm the Mode Setup > Dut Setup is in the default 
setting. This status is displayed above the graphs as follows:

• DUT: Amplifier

• Sys Downconv: Off

Frequency Range Typical Gain Minimum Gain Typical Noise 
Figure

20 MHz to 3 GHz 20 dB 14 dB 4.8 dB
Calibrating the Noise Figure Downconverter
The first step is to calibrate the N8201A.

1 Turn the N8201A on and wait for the power-up process to complete.
NOTE To obtain greater accuracy, it is recommended the N8201A warm up for at least one hour 
with Alignment, Auto Align set to On.
2 Click System > Power On/Preset > Preset Type > Mode.

3 Click Preset to return the N8201A to its factory-default state. 

4 Click Mode > Noise Figure to set the measurement mode to Noise Figure.
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5 Click Measure > Noise Figure to set the measurement to Noise Figure.

6 Click Meas Setup > ENR > Mode Table/Spot to Table.

7 On the same menu, click Common Table On/Off to On.

8 Again on the same menu, click Meas & Cal Table... > Table to enter the ENR values 
of the noise source. See Table 6.

In this example, a 346B noise source is used which has the following Frequency/ENR 
pairs up to 2 GHz (covering the required frequency range of 1.0 GHz to 2.0 GHz):

9 Click Frequency/Channel to set the frequency parameters of the measurement:

• Freq Mode — Sweep

• Start Freq — 1.0 GHz

• Stop Freq — 2.0 GHz

• Points — 15

10 Click Meas Setup to set the averaging you want.

• Averaging — On

• Averages — 5

11 Click BW/Avg > RBW Auto and enter 1 MHz.

12 Click Input/Output > Noise Figure Corrections > Input Cal > to change the Min 
Atten and Max Atten, if required.

This example uses the default minimum input attenuation of 0 dB, and the default 
maximum input attenuation of 8 dB.

13 Connect the noise source input to the Noise Source Drive Out +28 V Pulsed port on 
the front panel of the N8201A using the appropriate cable. Connect the noise source 
output to the RF Input as shown in Figure 15.

Table 6 Example Noise Source ENR/Frequency values

Frequency
(GHz)

ENR
dB

.01 15.13

.10 15.39

1.0 15.21

2.0 15.02
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Figure 15 Calibration Setup with Normal Noise Source

14 Click Meas Setup > Calibrate to calibrate the N8201A.

A graph similar to Figure 16 is now displayed. 

With calibration completed and no device under test inserted, both gain and noise figure 
with Corrected set to On are near 0 dB. This shows that the N8201A has removed the 
noise contribution from the measurement system. Since the input is noise, which is 
random in its nature, there is some variation above and below zero.

Measurement performance above 3 GHz is not specified. If you do not have either 
Option 110 High Band Preamp or an external preamp, and you are calibrating above  
3 GHz, the calibration data will vary significantly. Measurements made with this 
calibration data might be valid, but only if the device you are testing has a high enough 
gain and noise figure, such that the sum of these is about 35 dB or more. Otherwise, the 
measurement accuracy will be poor.

NOISE SOURCE DRIVE 
OUT +28 V (PULSED)

NOISE SOURCE
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2 Making Basic Measurements
Figure 16 Typical Graph after calibration is complete

15 Click Trace/View > View > Table. 

A result similar toFigure 19 is now displayed. The expectation is approximately 0 dB 
of noise figure and gain. It may be better to view these results using table format 
mode.

Figure 17 Typical Tabulated Results after Calibration
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Making Measurements
N8201A Noise Figure
To make noise figure measurements once calibration is complete:

1 Disconnect the noise source from the RF input of the N8201A

2 Connect the DUT to the N8201A RF input.

3 Connect the noise source output to the DUT input as shown in Figure 18.

Figure 18 Connecting the DUT to make a measurement

After the DUT and noise source are connected, the measurement result appears on the 
Spectrum Analyzer GUI display. If it does not, click Restart. If you want to get a 
continuous update, ensure Sweep is set to Cont. This is located under the Sweep key 
menu. 

A result similar to Figure 19 is now displayed.

NORMAL NOISE SOURCE

DUT

NOISE SOURCE DRIVE 
OUT +28 V (PULSED)
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2 Making Basic Measurements
Figure 19 Typical Tabulated Results after Measurement

4 Click Trace/View > View > Graph. A graphical result similar to Figure 20 is now 
displayed.

Figure 20 Typical Graphical Results after Measurement

The results shown in Figure 19 and Figure 20 shows the DUT has an average noise 
figure of 4.8 dB, an average gain of 23 dB and a minimum gain of 14.4389 dB. The 
device under test therefore meets its manufacturer’s specification over the frequency 
range of interest.
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Further Information on Noise Figure Measurements
N8201A Noise Figure
Agilent Technologies produces three application notes about noise figures and their 
measurement. These are:

• Application Note 57-1 

Fundamentals of RF and Microwave Noise Figure Measurements

• Application Note 57-2

Noise Figure Measurement Accuracy - the Y-Factor Method

• Application Note 57-3 

10 Hints for Making Successful Noise Figure Measurements

All three application notes are available from the Agilent website at: 

http://www.agilent.com/find/psa
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Agilent N8201A  Performance Downconverter
Noise Figure Measurement Personality Guide
3
Advanced Features

This chapter describes how to use the Limit Lines and Loss Compensation features with 
the Noise Figure Measurement personality.
What You will Find in this Chapter
“Tips for Using the Measurement Examples" on page 56

“Setting up Limit Lines" on page 57

“Limit Line Connections Displayed" on page 60

“Noise Figure Uncertainty Calculator" on page 63
55Agilent Technologies
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Tips for Using the Measurement Examples
56
• Setup diagrams through out the Measurement chapters show a PSA series spectrum 
analyzer as the measuring device. The N8201A performance downconverter can be 
used as the measuring device as well. Notice that the Noise Source Drive Out +28 V 
is located on the front panel of the N8201A.

• All front panel key presses are indicated in bold text.

• All sub menu key presses are indicated in italic text.

• Make sure that you have selected the Noise Figure measurement personality. 

• Click Mode > Noise Figure

• Click Measure > Noise Figure.

• You can choose to maximize the Spectrum Analyzer GUI display. The advantage of 
doing this is that most of the sub menu keys are available on one page. Also, the 
display area will be much larger.

• If you choose to leave the Spectrum Analyzer GUI window at its default size, you 
may have to click More 1 of .... to get to the desired function.

• While going through the measurement examples, you may want to select Refresh 
Display Automatically. This way you can see changes as you apply them. This 
selection can slow down the processing time of the instrument, therefore; during 
normal testing you may choose to have this feature turned off.

• All sub menu keys that contain frequency units, for example Start Frequency, are 
editable. Click on the numeric entry to change the value. Use the PC’s keyboard to 
enter the desired value and then type in the first letter of the units designator. For 
example, G for gigahertz. 
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Setting up Limit Lines
N8201A Noise Figure
Limit lines can be set to mark lower or upper boundaries of the active traces and they can 
also be set to notify you of a failure when a trace exceeds a limit line. Two limit lines can 
be applied to a single trace, for example, allowing an upper and lower boundary limit to 
be specified.

The Noise Figure application (Option 219) features four independent Limit Lines. 
Limit Line 1:A and Limit Line 2A are applied to the upper graph, and Limit Line 3B and 
Limit Line 4B are associated with the lower graph.
Selecting a Limit Line
1 Click Display > Limits > Limit Line 1A, 2A, 3B, 4B. 

Each time Limit Line 1A, 2A, 3B, 4B is clicked, the selected limit line moves the 
active indicator from Limit Line 1A to Limit Line 2A

2 Click Limit Line 1A, 2A, 3B, 4B again and the active indicator moves from Limit Line 
2A to Limit Line 3B. This process is repeated until it returns to the Limit Line 1A.
Setting the Type of Limit Line
You can set the Limit Line to be an upper limit or lower limit and test the trace against 
this limit line setting.

To set the limit line type, 

1 Click Display > Limits> Limit Line 1A, 2A, 3B, 4B to select the desired limit line. 

2 Click Type Upper/Lower.

Select Upper if you want it to be above the trace or Lower if you want it to be below the 
trace. Each of the four limit line needs to be set up separately.
Enabling Testing Against a Limit Line
You can set the Limit Line to test against the trace. If a result fails testing, it is reported 
in the upper right hand corner of the display. In table mode you also see the reported 
result failure.

To set the testing of the trace against the limit line, 

1 Click Display > Limits> Limit Line 1A, 2A, 3B, 4B to select the desired limit line. 

2 Click Test On/Off.

Each of the four limit lines needs to be set up separately.

After a failure the LIMITS FAIL: indicator remains displayed until:

• a complete sweep has been performed with the Limit Line test passing at every 
point
 Measurement Personality Guide 57



58

3 Advanced Features
• you switch Test to Off

• you change the limit line type

• you click Restart
Displaying a Limit Line
1 Click Display > Limits> Limit Line 1A, 2A, 3B, 4B to select the desired limit line. 

2 Set Display On/Off to On to display the limit line on the graph. 

Each of the four limit lines needs to be set up separately.
Switching all the Limit Lines Off
To switch all the Limit Lines off, 

1 Click Display > Limits > Limit Line 1A, 2A, 3B, 4B to select the desired limit line. 

2 Click Disable All Limits. 

This simultaneously switches off all Limit Lines, regardless of what graph or trace 
they are associated with. Both Test and Display settings remain unaffected.

When a limit line is switched off the limit line data is not affected.
Creating a Limit Line
To set up limit lines, you need to specify the frequencies, the Y-axis value and whether or 
not it is to be connected to the previous limit line point. The limit line consists of a table 
of entries, each of which is a frequency-limit-connected group. 

The Limit or Y-axis value is a dimensionless unit, hence you need to know what Y-axis 
scale you are working in before you set this. 

When you change the result parameter, the Limit or Y-axis values are not converted. This 
is due to the value being dimensionless.

To create a limit line:

1 Click Display > Limits > Limit Line 1A, 2A, 3B, 4B to select the desired limit line. 

2 Set the Display to On to display the limit line.

3 Click Edit....

You are presented with a Limit Line table.

4 Click on the first Frequency value (or to the first empty frequency field if you wish to 
keep the existing frequency values) and enter the frequency using the keyboard. 
Finish by entering the first letter of the units terminator. For example, “M” for 
megahertz.
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N8201A Noise Figure
5 Enter the Limit or Y-axis unit value and terminator corresponding the frequency you 
just entered. 

A limit line unit value to be useful is derived from the scale values you are using to 
display the trace.

6 Set Connected to Yes or No. 

When Connected is set to Yes it connects that point to the previous point to form a 
continuous line. To disconnect a point, set Connected to No, this disconnects it from 
the previous point. Figure 21 the connections and Figure 22 shows the graphical 
result with limit line Display set to On.

When the Limit Line Test is set to On, and a trace crosses over the limit line, the test 
is only performed between connected points. Also, if you are making a fixed 
frequency measurement, you only need to specify that frequency value. The limit line 
will be tested on that single point.

7 Repeat this process until the limit line is defined. Limit line tables can have a 
maximum of 101 entries.

8 Click OK to return to the limit line menu. 

9 To save a limit line, click File > Save > Type State > Limit > Source > 

10 Select the applicable limit line for saving (for example, Limit 1A) 

11 Click Destination Drive PC/Instrument.

12 Click File Name and enter a file name for the limit line. The file name extension 
(.LIM) will automatically be applied to the limit line file.

13 Click Save Now.

You can load a previously saved Limit Line table. However, you need to specify 
which limit line number you want loaded. 
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Figure 21 Typical Limit Line Connections in Table
Trace

Connected Limit Line

Limit Line Not Connected to Previous point

Connected Limit Line
Figure 22 Limit Line Connections Displayed
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Using Loss Compensation
N8201A Noise Figure
You can configure the Noise Figure application (Option 219) to compensate for losses 
due to cabling and connectors, and those due to temperature effects that occur in the 
measurement setup. These can be between the Noise Source and the DUT 
(Before DUT), or between the DUT and the N8201A RF input (After DUT), or both. 
Loss compensation can be set either by specifying a single, fixed loss value which gets 
applied at all frequencies, or using various loss values, specified in a table, applied 
across the frequency span. In the table mode, linearly interpolated values are used 
between each table entry.

Any device that causes loss will also generate excess noise, and this excess noise is 
proportional to the absolute temperature of the device causing the loss. You can 
compensate for this extra noise by specifying the temperature of the device causing the 
loss. This temperature dependent compensation is applied at all frequencies.
Examples where Loss Compensation is applied
This is important in cases such as:

• Amplifiers with waveguide input, where a lossy waveguide-to-coax adapter is 
needed. 

• Transistors, where input and output tuners are required.

• Non-50Ω converters (such as TV tuners and amplifiers) where matching pads or 
transformers are required. 

• Compensation for fixed attenuators used to improve SWR.

• Double sideband measurement modification (of receivers and mixers) to approximate 
single sideband results. 
Configuring Fixed Loss Compensation
To configure fixed loss compensation follow the example below:

1 Click Input/Output > Loss Comp > Setup > Loss Comp Before DUT (or the 
applicable function) > Fixed.

A fixed loss compensation value cannot be entered or changed if the Before DUT 
field or the After DUT field is not set to Fixed. It is selected by highlighting the Fixed 
key.

2 To set the loss compensation value before the DUT, click Loss Comp Before Fixed 
Val and input the required value (in dB) for the loss occurring before the DUT.

The lower limit is –100.000 dB, the upper limit is 100.000 dB, and the default is 
0.000 dB.

3 Click Loss Comp Before Temp to enter the temperature of the device (in Kelvins) 
where the loss is occurring. This will normally be room temperature, which is 
296.5 K.
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Configuring Table Loss Compensation

NOTE It is important that you enter the correct temperature. Leaving the Temperature set to the 
default value of 0.00K will result in incorrect noise figure measurements.
62
To configure table loss compensation proceed as follows.

1 Click Input/Output > Loss Comp > Loss Comp Before DUT (or appropriate function) 
> Table 

2 Click Back > Before DUT Table to access the compensation table.

3 Use the keyboard to enter the frequency and loss values, and then click OK to close 
the table. 

The frequency value requires the first letter of the units terminator, for example, “G” 
for Gigahertz. The loss value will be defaulted to dB.

Loss Compensation tables can have a maximum of 401 entries. 

4 Click Back > Setup > Loss Comp Before Temp to enter the temperature of the 
devices which are causing the loss. Room temperature requires a value of 296.5 K.

It is important that you enter the correct temperature. Leaving the Temperature set to 
the default value of 0.00K will result in incorrect noise figure measurements.

You can load a previously saved Loss Compensation table. 

1 Click File > Load > Type > Loss Comp Before DUT > Source Device PC/Instrument.

2 Click File Name and locate the desired file, then click OK.

3 Click Load Now.
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Noise Figure Uncertainty Calculator
N8201A Noise Figure
The measurement uncertainty calculator can be used to calculate the RSS (root sum 
square) measurement uncertainty. Measurement uncertainty is caused by device 
mismatch and other properties of the noise source, the device under test, and the 
N8201A downconverter. Once you measure or identify the various device 
characteristics, they can be entered into the Spectrum Analyzer GUI and it will calculate 
the RSS uncertainty.

This makes a frequency-independent calculation using one ENR uncertainty value. 
While it provides a good estimation of the measurement uncertainty, you may want more 
accuracy. You may want to use more accurate values for ENR, gain, and VSWR; or 
calculate values at a specific frequency of interest or at multiple frequencies. Refer to 
Application Note 57-2, Agilent part number 5952-3706E, for more information about 
calculating noise figure uncertainties. This document can be found at: 
http://www.agilent.com/find/nfu.
Noise Source
For the highest accuracy, and therefore the most meaningful results, you should select 
‘User Defined’ as the Noise Source whenever the actual value of the noise source 
calibration data is available. This allows you to enter the uncertainty of the Excess Noise 
Ratio (ENR) and the 50 Ω match (in dB, VSWR, or Reflection Coefficient), which can 
be from any noise source from any manufacturer. In addition, default values are provided 
giving typical parameters for noise sources from Agilent Technologies.
DUT
The device under test will be either an amplifier, upconverter, or downconverter. You 
will have to enter the measured (or documented) values for its noise figure, input match, 
output match, and gain into the fields in the calculator. (Gain is only required for an 
amplifier.)
Instrument
N8201A default values are provided. These are reasonable defaults for measurements 
below 3 GHz using the built-in preamp (Option 110 or Option 1DS). For more accurate 
calculations, you will need to input the values that are appropriate for your particular 
measurement and setup.
RSS value
The calculator provides the square root of the sum of the squares (RSS) of the various 
contributions to uncertainty. This is the recommended way to calculate the total 
measurement uncertainty since each of the contributing factors are random in nature.
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System Up Converters and Down Converters
64
The calculator is designed to calculate uncertainty for a measurement where the DUT is 
either an amplifier, a downconverter or an upconverter. It is not designed to calculate the 
uncertainty when measuring a DUT that is in a measurement setup that includes a system 
downconverter or system upconverter.
Example Calculation:
1 Access the uncertainty calculator click Mode Setup > Uncertainty Calculator.

Suppose that you are testing an amplifier. You must enter the device characteristics into 
the appropriate DUT fields on the calculator form. 

2 Choose from the list of functions and enter the applicable value. Use the keyboard to 
specify the desired value, then press Enter.

• gain = 20 dB

• noise figure = 4 dB

• input match = 1.4

• output match = 1.4

3 Now read out the calculated RSS uncertainty from the results field at the bottom of 
the display.
N8201A Noise Figure Measurement Personality Guide



Agilent N8201A  Performance Downconverter
Noise Figure Measurement Personality Guide
4
Making Frequency Converter 
Measurements

This chapter describes how to make measurements outside the baseband frequency range 
of the Noise Figure Measurement personality.
What You will Find in this Chapter
“Tips for Using the Measurement Examples" on page 66

“Overview of Frequency Converter Measurements" on page 67

“DUT Types" on page 68

“Basic Measurement — No Frequency Conversion" on page 69

“Frequency Down Converting DUT" on page 70

“Frequency Up Converting DUT" on page 73

“System Downconverter" on page 75

“Comparison of the 8970B, the NFA Analyzer and the Option 219 Noise Figure 
Measurement Application" on page 78

“Choosing and Setting Up the Local Oscillator" on page 79

“Connecting the System" on page 81

“Measuring a Frequency Converting DUT" on page 82

“Fixed LO Measurements" on page 90

“Measurements with a System Downconverter" on page 97

“Frequency Restrictions" on page 104
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Tips for Using the Measurement Examples
66
• Setup diagrams through out the Measurement chapters show a PSA series spectrum 
N8201A as the measuring device. The N8201A performance downconverter can be 
used as the measuring device as well. Notice that the Noise Source Drive Out +28 V 
is located on the front panel of the N8201A.

• All front panel key presses are indicated in bold text.

• All sub menu key presses are indicated in italic text.

• Make sure that you have selected the Noise Figure measurement personality. 

• Click Mode > Noise Figure

• Click Measure > Noise Figure.

• You can choose to maximize the Spectrum Analyzer GUI display. The advantage of 
doing this is that most of the sub menu keys are available on one page. Also, the 
display area will be much larger.

• If you choose to leave the Spectrum Analyzer GUI window at its default size, you 
may have to click More 1 of .... to get to the desired function.

• While going through the measurement examples, you may want to select Refresh 
Display Automatically. This way you can see changes as you apply them. This 
selection can slow down the processing time of the instrument, therefore; during 
normal testing you may choose to have this feature turned off.

• All sub menu keys that contain frequency units, for example start frequency, are 
editable. Click on the numeric entry to change the value. Use the PC’s keyboard to 
enter the desired value and then type in the first letter of the units designator. For 
example, G for gigahertz. 
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Overview of Frequency Converter Measurements
N8201A Noise Figure
1 Click Mode Setup > DUT Setup... > DUT to select the type of DUT being measured.

For more details on the available DUT types, see “DUT Types" on page 68.

Selecting the type of DUT displays the applicable functions for that type of DUT. 

2 Set the remaining parameters for the measurement.

System Downconverter When measuring an amplifier type DUT, this allows you to 
specify whether or not the system downconverter is to be used in the measurement. 
NOTE System Downconverter is only applicable when the DUT Type is Amplifier. The system 
downconverter can not be used with upconverters and downconverters.
Ext LO Frequency When measuring an up converting DUT, or a down converting 
DUT, this allows you to specify the fixed LO frequency being fed into the DUT. It also 
allows you to specify the LO frequency from the system downconverter.

Sideband  Specifies whether the measurement is to measure the lower sideband 
(LSB), the upper sideband (USB), or both upper and lower sideband, double sideband 
(DSB).

When measuring upconverter noise, only upper and lower sidebands can be measured at 
any one time. Double sidebands are not applicable.

When measuring downconverter noise, or an amplifier type DUT with the system 
downconverter, you can measure upper sideband (USB), lower sideband (LSB), or 
double sideband (DSB).

Frequency Context When the DUT is a downconverter or an upconverter, or you are 
using the system downconverter with an amplifier, you can select whether the 
frequencies displayed on the Spectrum Analyzer GUI represent the frequencies before or 
after conversion. Selecting a Frequency Context of IF Analyzer Input (Mode Setup > 
DUT Setup > Freq Context > IF Analyzer Input), specifies that the frequencies displayed 
are after the conversion, that is, the frequencies leaving the DUT or the system 
downconverter, and entering the N8201A. Selecting RF DUT Input as the Frequency 
Context (Mode Setup > DUT Setup > Freq Context > RF DUT Input) specifies that the 
frequencies displayed are the frequencies before the conversion That is, the frequencies 
entering the DUT. These are the same start and stop frequencies that are displayed in the 
Frequency Channel menu.

3 Configure the measurement (measurement frequency range, number of measurement 
points and averages and so forth) using the Frequency/Channel and BW/Avg keys.

For more details on configuring measurements, including calibration, see Chapter 2, 
“Making Basic Measurements.
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DUT Types

Available modes
68
The Noise Figure measurement personality (Option 219) allows you to measure the 
following types of DUT. You set the DUT Type by clicking Mode Setup > DUT Setup....

• Amplifier: The DUT is an amplifier-type device with no frequency conversion. This 
is the basic measurement mode where the measurement frequency is within the 
N8201A’s frequency range.

The Amplifier DUT is for any DUT that does not perform frequency conversion and 
includes amplifiers, filters, attenuators and so forth.

If you wish to measure the noise figure of an amplifier at a frequency outside the 
range of the N8201A, set DUT to Amplifier, and set System Downconverter to On. 
The LO must be fixed

• Downconv: The DUT is a frequency downconverter (that is, frequency 
downconversion occurs in the DUT itself). The LO must be fixed.

• Upconv: The DUT is a frequency upconverter (that is, frequency up conversion 
occurs in the DUT itself). The LO must be fixed.

Noise figure measurements involving frequency converters are necessary when:

• The frequency conversion is part of the DUT. For example, the DUT is a mixer or a 
receiver.

• The frequency conversion is part of the measurement test set-up. The DUT is to be 
measured at a higher frequency than the N8201A’s frequency range covers, hence an 
external mixer and local oscillator are added to the measurement test set-up to 
convert this frequency to a frequency within the N8201A's range.

The Noise Figure measurement personality (Option 219) can make a single frequency 
conversion, either in the DUT, or as an added system downconverter, which configures 
the N8201A as a frequency range extender.

The Noise Figure measurement personality can not control an external LO source 
remotely. You can only specify a fixed frequency for that LO, so any sweeping must be 
done by the internal LO under the control of the N8201A.
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Basic Measurement — No Frequency Conversion
N8201A Noise Figure
The basic measurement setup is shown in Figure 23, allowing you to compare more 
complex setups with it.

Figure 23 Basic Noise Figure Measurement - No Frequency Conversion

When you are performing an uncorrected measurement, the result is the measured noise 
figure of all of the components after the noise source. When the calibration setup is 
connected and the calibration performed, the Noise Figure measurement personality 
measures its own noise figure and that of the connection set up. If you then make a 
corrected measurement, the contribution of the calibration setup is subtracted from the 
uncorrected result, giving a corrected measurement of the DUT only. 

1 Click Mode Setup > DUT Setup... to access the DUT Setup menu. 

2 Click DUT > Amplifier.

3 System Downconverter On/Off.

NORMAL NOISE SOURCE

DUT

NOISE SOURCE DRIVE 
OUT +28 V (PULSED)

NORMAL NOISE SOURCE

NOISE SOURCE DRIVE 
OUT +28 V (PULSED)

CALIBRATION SETUP MEASUREMENT SETUP
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Frequency Down Converting DUT
70
In this mode, the DUT contains a frequency down converting device, for example, a 
mixer or receiver.

Making this measurement, the external Local Oscillator (LO) remains locked at one 
frequency and the Noise Figure measurement personality does the sweeping. It is not 
possible to control a variable frequency on the external LO.
Variable IF Fixed LO (equivalent to Mode 1.4 on an 8970B Noise Figure Meter)
This is an overview of the key presses needed to set up this type of measurement, see 
“Frequency Restrictions" on page 104, and “Fixed LO Measurements" on page 90 for an 
example of this measurement. This shows how to make an LSB measurement. However, 
you need to change the settings and apply the appropriate filtering. For greater detail on 
this see “Measuring a Frequency Converting DUT" on page 82.

1 Click Mode Setup > DUT Setup... to access the DUT Setup menu. Set the values on the 
DUT Setup form as shown in the following table.

Frequency Context

You can select whether to specify the frequencies at the DUT input (RF DUT Input) or at 
the N8201A’s input (IF Analyzer Input). 

IF Analyzer Input:  Specify the frequencies at the N8201A’s input, that is, at the 
DUT output after downconversion has taken place. 

Specify the start frequency and stop frequency by clicking the FREQUENCY/Channel 
key. The frequencies you specify are the frequencies at which the N8201A will make its 
measurements. These are the same frequencies that are shown on the results graph, in the 
results table, and on the results meter.

DUT DownConv

System 
Downconverter

Disabled

Ext LO Frequency Enter a value

Sideband LSB, USB or DSB. 

Frequency Context IF Analyzer Input or RF DUT Input. This determines whether 
you specify the measurement frequencies at the DUT input 
(RF DUT Input) or at the N8201A’s input (IF Analyzer Input). 
See Frequency Context (below) for a more detailed description.

Diagram Calibration or Measurement. This does not affect the 
measurement or calibration, but indicates how the noise 
source, the DUT and the N8201A should be set up. 
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N8201A Noise Figure
The RF start and RF stop frequencies are also displayed on the setup diagram. These are 
calculated from the specified IF start and IF stop frequencies, and the external LO 
frequency.

RF DUT Input:  Specify the frequencies at the DUT input, that is, before 
downconversion has taken place. 

Specify the start frequency and stop frequency by clicking Frequency Channel and 
entering the appropriate values. The frequencies you specify are the frequencies at the 
input to the DUT. These frequencies are then converted by the upconverter before being 
measured by the N8201A, and consequently do not represent the frequencies actually 
being measured by the N8201A.

The frequencies displayed on the results graph, in the results table, and on the results 
meter are the DUT input frequencies that you have specified. These displayed result 
frequencies do not represent the actual frequencies being measured by the N8201A.

The IF start and IF stop frequencies are also displayed on the setup diagram. These are 
calculated from the specified RF start and RF stop frequencies, and the external LO 
frequency.
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NOTE When making a DSB measurement with the Frequency Context set to RF DUT Input, (Mode 
Setup > DUT Setup > Freq Context > RF DUT Input) the frequencies you specify as the RF 
start and RF stop frequencies refer to the lower sideband only. There is no ambiguity when 
making USB or LSB measurements, or when specifying frequencies at the N8201A input, 
that is, with Frequency Context of IF Analyzer Input (Mode Setup > DUT Setup > Freq 
Context > IF Analyzer Input).

When making DSB measurements, it is important that the IF frequency is much smaller 
than the LO frequency. This is because the ENR values in the ENR table can only be applied 
to one frequency, which is the LO frequency. The ENR values can not be applied 
simultaneously to both the upper sideband and to the lower sideband. The ENR values are 
therefore applied to the midpoint between the upper sideband and the lower sideband, and 
this equates to the LO frequency.

Consequently, the higher the IF frequency is in comparison to the LO frequency, the further 
apart the upper and lower sidebands will be. The further these upper and lower sidebands 
are from the LO frequency, the less accurate will the ENR value be.

Another potential source of error is the frequency response of the DUT. If the frequency 
response varies over the measurement range, from lower to upper frequency, the noise 
figure results will only represent an average value.

It is recommended for greatest accuracy that the IF frequency be no greater than 1% of the 
LO frequency when making double sideband measurements. When making a swept 
measurement, no frequency in the swept frequency band should exceed 1% of the LO 
frequency.

Filtering is needed to remove the unwanted sideband when making single-sideband 
measurements. Filtering is also needed to filter out any LO leakage in the IF path. Ideally any 
filters should be included in the calibration path. However, if they are not in the path, you 
can enter loss compensation to account for any additional error.

The N8201A has a 3.0 GHz low pass filter which needs to be taken into account when 
planning the filter requirements during measurement and calibration.
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Frequency Up Converting DUT
N8201A Noise Figure
In this mode, the DUT contains a frequency up converting device, for example, a mixer 
used in the transmit path of a radio.

Making this measurement, the external Local Oscillator (LO) remains locked at one 
frequency and the Noise Figure measurement personality does the sweeping. It is not 
possible to control a variable frequency on the external LO.

Filtering is needed to remove the unwanted sideband when making single-sideband 
measurements. Filtering is also needed to filter out any LO leakage in the IF path. Ideally 
any filters should be included in the calibration path. However, if they are not in the path, 
you can enter loss compensation to account for any additional error.

The N8201A has a 3.0 GHz low pass filter which needs to be taken into account when 
planning the filter requirements during measurement and calibration.
Variable IF Fixed LO (equivalent to Mode 1.4 with SUM Sideband on an 8970B 
Noise Figure Meter)
This is an overview of the key presses needed to set up this type of measurement. For 
further details on frequency restrictions, see “Frequency Restrictions" on page 104. 

For an example of this measurement, see“Fixed LO Measurements" on page 90. This 
shows you how to make an LSB measurement. However, you need to change the settings 
and apply the appropriate filtering.

1 Click Mode Setup > DUT Setup... to access the DUT Setup form. 

2 Set the values on the DUT Setup form as shown in the following table.

DUT UpConv

System 
Downconverter

Disabled

Ext LO Frequency Enter a value

Sideband LSB or USB

Frequency Context IF Analyzer Input or RF DUT Input. This determines whether 
you specify the measurement frequencies at the DUT input (RF 
DUT Input) or at the N8201A’s input (IF Analyzer Input). See 
Frequency Context (below) for a more detailed description.

Diagram Calibration or Measurement. This does not affect the 
measurement or calibration, but indicates how the noise 
source, the DUT and the N8201A should be set up. 
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Frequency Context

Select whether to specify the frequencies at the DUT input (RF DUT Input) or at the 
N8201A’s input (IF Analyzer Input).

IF Analyzer Input: Specify the frequencies at the N8201A RF input, that is, at the DUT 
output after up conversion has taken place. 

Specify the start frequency and stop frequency by clicking FREQUENCY Channel. The 
frequencies you specify are the frequencies at which the N8201A will make its 
measurements. These are the same frequencies that are shown on the results graph, in the 
results table, and on the results meter.

The RF start and RF stop frequencies are also displayed on the setup diagram. These are 
calculated from the specified IF start and IF stop frequencies, and the external LO 
frequency.

RF DUT Input: Specify the frequencies at the DUT input, that is, before up conversion 
has taken place. 

Specify the start frequency and stop frequency by clicking FREQUENCY Channel. The 
frequencies you specify are the frequencies at the input to the DUT. These frequencies 
are then converted by the upconverter before being measured by the N8201A, and 
consequently do not represent the frequencies actually being measured by the N8201A.

The frequencies displayed on the results graph, in the results table, and on the results 
meter are the DUT input frequencies that you have specified. These displayed result 
frequencies do not represent the actual frequencies being measured by the N8201A.

The IF start and IF stop frequencies are also displayed on the setup diagram. These are 
calculated from the specified RF start and RF stop frequencies, and the external LO 
frequency.
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System Downconverter
N8201A Noise Figure
The DUT is a non-frequency converting device (for example an amplifier or filter) and 
its frequency is higher than the N8201A’s measurement range. Frequency down 
conversion is required within the measurement system, using a mixer external to the 
DUT, to convert the signal of interest to the frequency range of the N8201A.

Making this measurement, the external local oscillator (LO) remains locked at one 
frequency and the Noise Figure measurement personality executes the sweeping. It is not 
possible to control a variable frequency on the external LO.

Filtering is needed to remove the unwanted sideband when making single-sideband 
measurements. Filtering is also needed to filter out any LO leakage in the IF path. Ideally 
any filters should be included in the calibration path. However, if they are not in the path, 
you can enter loss compensation to account for any additional error.

The N8201A has a 3.0 GHz low pass filter which needs to be taken into account when 
planning the filter requirements during measurement and calibration of any 
measurement made at or below 3 GHz.
Fixed LO Variable IF (equivalent to Mode 1.2 on an 8970B Noise Figure Meter)
This is an overview of the key sequences needed to set up this type of measurement. See 
“Frequency Restrictions" on page 104 for the restrictions applicable to this 
measurement. See “Measurements with a System Downconverter" on page 97 for an 
example of this type of measurement. You will need to change the settings and apply the 
appropriate filtering. For greater detail on this, see “Measuring a Frequency Converting 
DUT" on page 82.

1 Click Mode Setup > DUT Setup... to access the DUT Setup form. 

2 Set the values on the DUT Setup form as shown in the following table. 

DUT Amplifier

System 
Downconverter

On

Ext LO Frequency Enter a value

Sideband LSB, USB or DSB

Frequency Context IF Analyzer Input or RF DUT Input. This determines whether 
you specify the measurement frequencies at the DUT input (RF 
DUT Input) or at the N8201A’s input (IF Analyzer Input). See 
Frequency Context (below) for a more detailed description.

Diagram Calibration or Measurement. This does not affect the 
measurement or calibration, but indicates how the noise 
source, the DUT and the N8201A should be set up. 
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Frequency Context

Select whether to specify the frequencies at the DUT input (RF DUT Input) or at the 
N8201A’s input (IF Analyzer Input).

IF Analyzer Input:  Specify the frequencies at the N8201A’s input, that is, at the DUT 
output after up conversion has taken place. 

Specify the start frequency and stop frequency by clicking Frequency Channel. The 
frequencies you specify are the frequencies at which the N8201A will make its 
measurements. These are the same frequencies that are shown on the results graph, in the 
results table, and on the results meter.

The RF start and RF stop frequencies are also displayed on the setup diagram. These are 
calculated from the specified IF start and IF stop frequencies, and the external LO 
frequency.

RF DUT Input:  Specify the frequencies at the DUT input, that is, before up conversion 
has taken place. 

Specify the start frequency and stop frequency by clicking Frequency Channel. The 
frequencies specified are the frequencies at the input to the DUT. These frequencies are 
then converted by the upconverter before being measured by the N8201A, and 
consequently do not represent the frequencies actually being measured by the N8201A.

The frequencies displayed on the results graph, in the results table, and on the results 
meter are the DUT input frequencies that you have specified. They are also used to 
determine the ENR values used in the calculations. These displayed result frequencies do 
not represent the actual frequencies being measured by the N8201A.

The IF start and IF stop frequencies are also displayed on the setup diagram. These are 
calculated from the specified RF start and RF stop frequencies, and the external LO 
frequency.

When making a DSB measurement with RF DUT Input, the frequencies you specify as 
the RF start and RF stop frequencies refer to the LSB only. There is no ambiguity when 
making USB or LSB measurements, or when specifying frequencies at the N8201A 
input. That is, with Frequency Context of IF Analyzer Input (Mode Setup > DUT Setup 
> Freq Context > IF Analyzer Input).

When making DSB measurements, it is important that the IF frequency is much smaller 
than the LO frequency. This is because the ENR values in the ENR table can only be 
applied to one frequency or, in the case of a swept measurement, to one set of 
frequencies. The ENR values can not be applied simultaneously to both the upper 
sideband and to the lower sideband. The ENR values are therefore applied to the 
midpoint between the upper sideband and the lower sideband, and this equates to the LO 
frequency.

Consequently, the higher the IF frequency is in comparison to the LO frequency, the 
further apart the upper and lower side bands will be. The further these upper and lower 
sideband are from the LO frequency, the less accurate will the ENR value be.
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N8201A Noise Figure
Another potential source of error is the frequency response of the DUT. If the frequency 
response varies over the measurement range, from lower to upper frequency, the noise 
figure results will only represent an average value.

It is recommended for greatest accuracy that the IF frequency be no greater than 1% of 
the LO frequency when making double sideband measurements. When making a swept 
measurement, no frequency in the swept frequency band should exceed 1% of the LO 
frequency.
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Table 7 shows the relationship between the 8970B noise figure analyzer and the N8201A 
Noise Figure Measurement application.

Table 7 8970B / NFA / Option 219 Measurement Cross Reference

8970B NFA Series N8201A Option 219

Mode 1.1: Swept LO System Downconverter  
Fixed IF Variable LO

Not supported

Mode 1.2: Fixed LO System Downconverter  
Variable IF Fixed LO

System downconverter Fixed 
LO

Mode 1.3: Swept LO Down converting  
Fixed IF Variable LO

Not supported

Mode 1.4: Fixed LO Down converting  
Variable IF Fixed LO

DUT = Downconv  Fixed LO

Mode 1.3 with SUM 
Sideband: Swept LO

Up converting  
Fixed IF Variable LO, USB

Not supported

Mode 1.4 with SUM 
Sideband: Fixed LO

Up converting  
Variable IF Fixed LO, USB

DUT = Upconv       Fixed 
LO           Side band = USB
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Choosing and Setting Up the Local Oscillator

Selecting a Local Oscillator for Extended Frequency Measurements
N8201A Noise Figure
Because of reciprocal mixing, noise components in the LO are converted into the IF 
band applied to the N8201A. This converted LO noise causes the measured noise figure 
to be higher than the noise figure of the mixer.

If the mixer is to be used with a particular LO in its final application, its noise figure 
should be measured with the same LO. The measurement then gives the noise figure for 
the combination of extended frequency device and LO in the final system.

For testing of extended frequency measurements, the LO must have a low noise floor 
over frequencies equal to the LO ± IF. It is also important that the LO has low broadband 
noise because any noise at the IF frequency will pass through to the IF and distort the 
results.

Effect of high LO spurious signals and noise on mixer measurements with low 
L-to-I rejection.

The spurious level of the LO also has to be low. At frequencies where there is a high 
spurious signal, the noise figure measured will have a peak at that IF. For example, 
ideally the LO’s noise, including spurious, needs to be below –90 dBm. If a mixer has 
higher isolation, then the noise of the LO can be higher since the mixer will be better 
able to reject the LO’s noise.

This is especially necessary if the mixer has a poor balance, or L-to-I isolation. With low 
isolation, the mixer is more likely to pass the LO noise through and thus increase the 
measured noise figure.

L-to-I rejection is the mixer’s ability to reject the fundamental, harmonics and spurious 
signals of the LO, and not allow them to pass through to the IF output.
Selecting a Local Oscillator 
Here are several criteria that must be met when choosing the LO: 

• It should have a frequency appropriate to the DUT’s frequency range, IF range, and 
sideband chosen.

• It should have sufficient power to drive mixers (typically, +7 dBm)

• It should have excellent frequency accuracy and repeatability (typically, the same as 
the N8201A.) 

The last point, frequency accuracy, deserves further comment. There are three 
frequency-dependent components in a noise figure measurement that must all be aligned 
to make an accurate measurement at the IF. The need for frequency accuracy is the main 
reason for recommending a synthesized source for the LO, such as the Agilent 83712B 
synthesized CW generator.
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Other LOs may be used, but should be tested to determine that their noise is sufficiently 
low, as LO noise can cause an increase in noise figure for the mixer/LO combination, 
and calibration of the system may not be possible. A broadband, high gain amplifier at 
the LO output usually generates unacceptable noise. This is almost always the case when 
a heterodyne-type sweep oscillator or signal generator is used. 

When making DSB measurements, it is important that the IF frequency is much smaller 
than the LO frequency. This is because the ENR values in the ENR table can only be 
applied to one frequency or, in the case of a swept measurement, to one set of 
frequencies. The ENR values can not be applied simultaneously to both the upper 
sideband and to the lower sideband. The ENR values are therefore applied to the 
midpoint between the upper sideband and the lower sideband, and this equates to the LO 
frequency.

Consequently, the higher the IF frequency is in comparison to the LO frequency, the 
further apart the upper and lower sidebands will be. The further these upper and lower 
sidebands are from the LO frequency, the less accurate will the ENR value be.

Another potential source of error is the frequency response of the DUT. If the frequency 
response varies over the measurement range, from lower to upper frequency, the noise 
figure results will only represent an average value.

It is recommended for greatest accuracy that the IF frequency be no greater than 1% of 
the LO frequency when making double sideband measurements. When making a swept 
measurement, no frequency in the swept frequency band should exceed 1% of the LO 
frequency.
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Connecting the System
N8201A Noise Figure
Figure 24 shows the connection diagram options you use to calibrate the N8201A with 
Option 219, and after calibration, to measure a DUT, whether it is a downconverter, an 
upconverter, amplifier, or a filter. It does not show where to place a filter to remove any 
unwanted sideband or input noise.
Setting Up the Noise Figure Analyzer
You can connect the 10 MHz timebase references, thus locking the N8201A and the LO 
to the same frequency reference.

1 Click System > Reference, and check that 10 MHz Out is set to On. 

2 Connect the N8201A 10 MHz OUT to the 10 MHz Ref In of the LO. 

To connect the 10 MHz reference output from the LO to the N8201A, ensure that 
External Reference is selected. 

1 Click System > Reference and check that Freq Ref is set to 10 MHz and to Ext. 

2 On the N8201A connect the 10 MHz Ref Out of the LO to the EXT REF IN. 

To connect the N8201A and make your measurements:

1 Turn the N8201A on and click Preset to return the N8201A to a known state. Go into 
the Noise Figure mode if the preset is not set to Mode.

2 Enter the ENR values in to the N8201A. Refer to“Entering Excess Noise Ratio 
(ENR) Data" on page 19.

3 Follow the procedure to calibrate the system, and measure the DUT.
NOISE SOURCE DRIVE 
OUT +28 V (PULSED)

NORMAL NOISE SOURCE NOISE SOURCE DRIVE 
OUT +28 V (PULSED)

LO LO
DUT

NORMAL NOISE SOURCE

CALIBRATION SETUP MEASUREMENT SETUP
Figure 24 Setting Up a N8201A for Frequency Converting DUT Measurement
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NOISE SOURCE DRIVE 
OUT +28 V (PULSED)

NORMAL 
NOISE SOURCE

NORMAL 
NOISE SOURCE

NOISE SOURCE DRIVE 
OUT +28 V (PULSED)

LO

DUT

CALIBRATION SETUP MEASUREMENT SETUP
Figure 25 Frequency Converting DUT Measurement

In this measurement, the DUT performs frequency conversion in the measurement setup. 
However, there is no frequency conversion in the calibration setup, as is shown in 
Figure 25. The purpose of the calibration setup is to allow the N8201A to measure its 
own noise figure and sensitivity with the noise source. This must be performed across 
the frequency range to which the N8201A will tune when performing the measurement. 

For both calibration and for measurement, a normal noise source must be connected to 
the NOISE SOURCE DRIVE OUT+28 V (PULSED) on the front panel of the N8201A. 

The LO frequency reference may be connected to the 10 MHz OUT on the N8201A. 
This locks the LO and the N8201A together for greater measurement accuracy.

For these measurements click Mode Setup > DUT Setup... and set the following 
parameters:

DUT Upconv or Downconv

System 
Downconverter

Not accessible

Ext LO Frequency Enter a value for the LO’s frequency

Sideband LSB, USB or DSB (Downconverters only)

Frequency Context IF Analyzer Input or RF DUT Input. This determines whether you 
specify the measurement frequencies at the DUT input (RF DUT 
Input) or at the N8201A’s input (IF Analyzer Input). See Frequency 
Context (below) for a more detailed description.

Diagram Calibration or Measurement. This does not affect the 
measurement or calibration, but indicates how the noise 
source, the DUT and the N8201A should be set up. 
N8201A Noise Figure Measurement Personality Guide



Making Frequency Converter Measurements 4

N8201A Noise Figure
Frequency Context

You can select whether to specify the frequencies at the DUT input (RF DUT Input) or at 
the N8201A’s input (IF Analyzer Input). 

IF Analyzer Input:  Specify the frequencies at the N8201A’s input, that is, at the DUT 
output after up conversion has taken place. 

Specify the start frequency and stop frequency by clicking FREQUENCY Channel. The 
frequencies you specify are the frequencies at which the N8201A will make its 
measurements. These are the same frequencies that are shown on the results graph, in the 
results table, and on the results meter. When the measurement is made, the N8201A 
calculates the input frequency to the DUT, and using the appropriate values from the 
noise source ENR table, interpolates as necessary and measures the DUT.

The RF start and RF stop frequencies are also displayed on the setup diagram. These are 
calculated from the specified IF start and IF stop frequencies, and the external LO 
frequency.

RF DUT Input:  Specify the frequencies at the DUT input, that is, before up conversion 
has taken place. 

Specify the start frequency and stop frequency by clicking FREQUENCY Channel. The 
frequencies you specify are the frequencies at the input to the DUT. These frequencies 
are then converted by the upconverter before being measured by the N8201A, and 
consequently do not represent the frequencies actually being measured by the N8201A. 
When the measurement is made, the N8201A calculates the input frequency to the 
N8201A, and using the appropriate values from the noise source ENR table, interpolates 
as necessary and measures the DUT.

The frequencies displayed on the results graph, in the results table, and on the results 
meter are the DUT input frequencies that you have specified. These displayed result 
frequencies do not represent the actual frequencies being measured by the N8201A.

The IF start and IF stop frequencies are also displayed on the setup diagram. These are 
calculated from the specified RF start and RF stop frequencies, and the external LO 
frequency.

When making a double sideband (DSB) measurement with Frequency Context set to RF 
DUT Input, (Mode Setup > DUT Setup > Freq Context > RF DUT Input) the frequencies you 
specify as the RF start and RF stop frequencies refer to the lower sideband only.

The Upconverter and Downconverter modes include any DUT that performs frequency 
conversion, whether a simple single mixer or a complex receiver structure.
Sidebands and Images
For any measurement involving frequency conversion, you need to consider the exact 
frequency ranges involved, and make decisions about the filtering requirements for the 
specific measurement. For example, there may be several different methods of 
measuring a mixer, and the method chosen may be set by the choice of available filters.
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Figure 26 Sidebands and Images with Down Conversion

Simple, ideal, mixers output signals on both the sum and difference of their RF and LO 
frequencies. Hence, for a fixed output frequency and a fixed LO frequency, there are two 
different input frequencies that are converted to the output frequency. This is shown in 
Figure 26.

The noise sources used in noise figure measurements are broadband. When using a 
downconverter, there is a probability that noise will be presented to a simple mixer in 
both the upper and lower input frequency bands that are converted into the same IF 
output band to which the N8201A is tuned. The N8201A receives mixer-created noise 
from the two frequency bands which are superimposed. The noise is random, and hence 
the two power levels combine by simple addition. Similarly, the N8201A receives 
noise-source-created noise from the two frequency bands combined as added power. 
Any measurement where two mixing products are combined like this is usually termed 
double sideband (DSB).

It is conventional to call the higher frequency band of an image pair the upper sideband 
(USB) and the lower frequency band of an image pair the lower sideband (LSB).

Non-ideal mixers exhibit some unwanted behaviors:

• Some of the input signal leaks directly to the output.

• Some of the LO signal, and its harmonics, leak directly to the output.

• Mixing products are created between the input signal and the harmonics of the LO.

There are other unwanted products involving input signal harmonics, but these tend to be 
less troublesome than those above, provided the mixer is operated at a level within its 
linear range.

 Input
Band

LSB Input USB Input

Amplitude

Frequency

FLO

Broadband Noise

Fusb-Flo
mixing

Flo-Flsb

mixing
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Signal Leakage

Direct signal leakage of input signal through to a mixer's output can occur, because the 
noise sources cover a broad frequency range. Signal leakage is not normally a problem 
unless the noise source has a large variation in ENR, or the mixer's RF-to-IF leakage is 
high.

LO Leakage

The LO power is normally greater than the largest input signal that a mixer is intended to 
operate with. The LO power leaking from the mixer's output is at a high level compared 
to the signal levels involved in the noise figure measurement. Hence, LO leakage needs 
to considered when measuring noise figure of a frequency converting DUT.

If the LO frequency is low enough to be passed by the input filter of the N8201A's RF 
section (a 3.0 GHz low pass filter), the LO leakage can prevent successful measurement 
of the DUT noise figure. Desensitization by LO leakage can be avoided by adding a 
filter between the DUT and the N8201A to remove the LO frequency component.

Low pass filters with cutoffs at low frequencies, may exhibit spurious resonances and 
leakage at low microwave frequencies. It may be necessary to use a pair of low pass 
filters, one microwave, one RF, in order to assure a stopband attenuation over a wide 
frequency range.
LO Harmonics
Many mixers are operated by sinusoidal LO signals. LO harmonics can be formed in the 
mixer at significantly high levels. It is common for the specified LO input level for a 
diode mixer to be chosen to operate the diodes between saturation and off conditions, 
hence making the mixer act as a switch. LO harmonic derived products from industry 
standard double-balanced mixers may be similar in level to what they would have been 
with a square-wave LO signal. Instead of just being sensitive at one pair of frequencies 

, the mixer input is sensitive at a series of pairs:

Filtering is needed to eliminate the noise input to the DUT at these higher order 
frequencies. However, their frequencies may be great enough that the mixer attenuates 
them, making them insignificant.

FLO FIF±[ ]

FLO FIF±[ ] 2FLO FIF±[ ] 3FLO FIF±[ ] 4FLO FIF±[ ] 5FLO FIF±[ ] …+ + + + +
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Single Sideband Measurements
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Most mixer applications involve single sideband (SSB) mixing - either LSB or USB, 
hence it is ideal to make noise figure measurements on a mixer in the circumstances in 
which it is used. Making an SSB measurement requires suitable filters to remove the 
unwanted image, any LO leakage, and other unwanted mixer products. This may require 
filters that are not readily available, or that are expensive, and a DSB measurement may 
be chosen as a compromise when measuring a downconverter or using the System 
Downconverter. There is no general guidance on what filtering is needed. Each case 
needs individual consideration. 

Items to be considered are: 

• Decide the frequency ranges that must be covered; Input, LO, and Output.

• Calculate the frequency range that the unwanted image will cover.

• Calculate the frequency range that the LO harmonic modes will cover.

• Choose a filter to go between the noise source and the DUT, that will pass the wanted 
input band and stop the unwanted input bands.

• Consider the LO frequency range (and harmonics), and whether or not a filter is 
needed to protect the N8201A input from being desensitized by LO leakage in the 
0 - 3.5 GHz range.

• Choose a filter, if necessary, to go between the DUT and the N8201A.

If any of these ranges conflict, making the filter requirements impossible, the 
measurement could be split into a group of smaller ranges, with different filters for each.

If the DUT is a complicated mixer, it may already contain filters to operate the mixer in 
single sideband mode over the frequency range of interest. A mixer in its final 
application exhibits the same problems that make noise figure measurement difficult, 
hence the application will need similar filtering to that needed during noise figure 
measurement.
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Figure 27 Single Sideband Mixer Measurements

Figure 27 shows an SSB mixer measurement (Downconverter, LSB) where a filter 
makes it single sideband. If the IF frequency is lowered, the N8201A is tuned to a lower 
frequency, and the USB and LSB bands will move closer to the LO frequency. This 
makes filtering more difficult. If the IF is lowered further, a point is reached where 
filtering is not possible and SSB measurements cannot be made. The width of the filter 
limits where the LO or IF frequencies sweep to make a measurement.

The N8201A performs frequency calculations and controls the frequency for a variety of 
mixer modes. However, you have to determine the filter requirements, and provide those 
filters in the measurement setup.

‘Downconverter’ means that the output frequency, (IF) is lower than the input, (RF). 

‘Upconverter’ means that the output frequency, (IF) is higher than the input (RF).

The N8201A can handle SSB mixer measurements in modes defined by the following 
combinational choices: 

• DUT: Upconverter, Downconverter, or Amplifier with System Downconverter On.

• Sideband: LSB or USB.
Double Sideband Measurements
Double sideband (DSB) measurements can only be made when the DUT is a 
downconverter, or when the DUT is an amplifier and the system downconverter is On. 
DSB techniques can be useful when making noise figure measurements under the 
following conditions:
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• When adequate filters for image-free SSB measurements are not available. 

• When frequency ranges have to be covered that make SSB filters impractical or 
impossible. 

DSB measurements do not eliminate the need for filtering. However, they can greatly 
simplify the filtering needed. This benefit is achieved at the loss of frequency resolution.
 Input
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LSB Input USB Input

Amplitude
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FLOFlo-Flsb
mixing

Fusb-Flo
mixing
Figure 28 Double Sideband Measurements

Figure 28 shows a double sideband, downconversion, mixing. Noise from two separated 
RF bands are mixed into the IF band, where the power addition takes place.

DSB measurements are made with the noise from a pair of separate bands, 
symmetrically arranged about the LO frequency. The IF frequency value should be low, 
ideally no larger than 1% of the LO frequency. As the two sidebands, the USB and the 
LSB, are generated at frequencies equal to LO±IF. This technique maintains the two 
bands close together. This is necessary because the assumption is made that the 
variations in noise source ENR, gain, and noise figure are constant between the two 
bands. ENR values are applied to the mid-point between the upper and lower sidebands, 
and this equates to the frequency of the LO. 

Figure 28 shows that noise from two bands are combined during the measurement. 
During calibration, when the DUT was not connected, only one band (at the IF 
frequency) was used.

If the assumptions about the parameters being flat over frequency between the two 
sidebands are valid, your results will show a doubling in power (3 dB increase) in noise 
level during the measurement of any down converting DUTs. There is also a doubling of 
measured power when using the System Downconverter, but compensation is not 
required because the calibration power is also doubled.
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This 3 dB increase in measured power with down converting DUTs can be corrected 
using the Loss Compensation Setup menu 

1 Click Input/Output > Loss Comp.

2 Click Loss Compensation Before DUT and set to Fixed.

3 Enter a Fixed Value of –3 dB.

4 Click Loss Comp Before Temp to set the noise source’s cold temperature. 

The DSB power addition occurs for both the hot and cold noise from the noise source, 
and the noise created in the input of the DUT. A temperature value can be assigned to 
this loss using Loss Comp Before Temp. Using the cold temperature of the noise source 
(often assumed to be 290 Kelvin) corrects for this, and the N8201A will give corrected 
results comparable to those that would have been given by an SSB measurement.

DSB measurements are not appropriate for making measurements where DUT 
performance, or noise source ENR, have significant variation over the frequency range 

.

When making a DSB measurement with Frequency Context set to RF DUT Input (Mode 
Setup > DUT Setup > Freq Context > RF DUT Input), the frequencies you specify as the 
RF start and RF stop frequencies refer to the LSB only.

LO Leakage (with specific DSB information)

LO leakage is a problem when working in the 200 kHz to 3 GHz range. It can be avoided 
by tuning the LO to frequencies greater than 3.5 GHz. Above 3.0 GHz, the N8201A's 
input filter progressively attenuates the LO signal. For a DSB downconverter 
measurement with the LO frequency below 3.5 GHz, a low pass filter will be needed. 
The cutoff frequency must be chosen to pass the IF frequency of the measurement. The 
amount of attenuation over the LO frequency range has to be sufficient to reduce the LO 
leakage down to the broadband (10.0 MHz - 3 GHz) noise level presented to the 
N8201A input.

With most DSB downconverter measurements, the IF is made low, with respect to, the 
RF and LO frequencies, so filter needs are not complex. 

Low pass filters with cutoffs at low frequencies, may exhibit spurious resonances and 
leakage at low microwave frequencies. It may be necessary to use a pair of low pass 
filters, one microwave, one RF, in order to assure a stopband attenuation over a wide 
frequency range.

LO Harmonics (with specific DSB information)

Many mixers have product pairs associated with harmonics of the LO. Depending on the 
mixer, these could be at a sufficient level to distort the measured noise figure results. To 
avoid this, insert an input filter between the noise source and the DUT. A high pass filter 
may also be needed in this location if signal leakage is a problem.

There is no general guidance on what filtering is needed. Each case needs individual 
consideration:

FLO FIF±[ ]
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• Decide the frequency ranges that have to be covered; Input, LO, and Output.

• Calculate the frequency range that the LO harmonic modes will cover.

• If LO harmonic related products are a problem, choose a filter to go between the 
noise source and the DUT, that will pass the wanted input band and stop the LO 
harmonic modes. If the frequency ranges are wide, the measurement may have to be 
split into frequency ranges with different filters for each.

• Consider the LO frequency (and harmonics). Is a filter needed to protect the N8201A 
input being desensitized by LO leakage in the 0 to 3.5 GHz range?

• Choose a filter, if necessary, to go between the DUT and the N8201A.

The N8201A can handle DSB mixer measurements when using a downconverter, or 
when the System Downconverter is On. 
Fixed LO
As the LO frequency is fixed, there is no sweep at the DUT input. This means that as the 
two sideband input pairs diverge, their average remains fixed. This feature can be useful 
for measuring a complex DUT where the effect of variation of performance of the 
post-mixer stage over IF frequency is of interest.

Because the LO frequency is held constant, it is the IF frequency at the N8201A input 
that is swept. Figure 29 illustrates this mode.
Sweep Point

FIF FLO

Start

Stop

LSB Input USB Input

Fixed LO

Fusb-Flo
mixing

Flo-Flsb
mixing

Frequency
Figure 29 Fixed LO Measurements
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Making Frequency Converting DUT Measurements
N8201A Noise Figure
An example is provided on the following pages using the N8201A to make a fixed 
frequency measurement. The LO is locked at a specified frequency, and a lower 
sideband (LSB) measurement of a mixer is made. The example can be modified to make 
measurements where the IF is swept. Also, from the example, upper and double 
sideband measurements can be made. The changes in the example’s procedure are 
explained in each case.

Calibration of the measurement system is similar to a basic calibration, the noise source 
is connected directly to the RF input of the N8201A and a calibration is made. The DUT 
is then placed between the noise source and the N8201A, and a corrected measurement 
is made.

The RF input section on the N8201A has a built-in 3.0 GHz low pass filter. This filter 
needs to be accounted for when planning the filter requirements during calibration and 
measurement.
Making Down Converting DUT Measurements using a Fixed LO and Fixed IF 
(Equivalent to Mode 1.4 on an 8970B Noise Figure Analyzer)
Both double and single sideband measurements may be made in this mode. This 
measurement may be useful to choose the optimum IF for a mixer or receiver, or to 
measure how a mixer’s or a receiver’s noise figure and gain vary with IF. 

Lower Sideband Measurement

A signal generator is used to supply an LO at 970 MHz. Setting the RF frequency of 
interest to 900 MHz, with the LO of 970 MHz provides an IF of 70 MHz. This also 
meets with the need to maintain the LO frequency out of the N8201A’s passband. See 
Figure 30.

In the example, a 900 MHz band pass filter is used between the noise source and the 
DUT to remove the upper sideband. (see Figure 30).

A 70 MHz band pass filter is used between the DUT and the N8201A to remove all 
signals except the 70 MHz signal in which we are interested.
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Figure 30 Fixed LO (970 MHz) and Fixed IF (70 MHz), LSB Spectrum

Initial Setup Procedure

Follow the overview procedure of the initial set up.

1 Power Up the N8201A and the LO. You need to wait for the recommended warm up 
time to get accurate measurement results.

2 Connect the 10 MHz reference, if required. see “Connecting the System" on page 81.

3 Load the ENR values for the chosen noise source. See “Entering Excess Noise Ratio 
(ENR) Data" on page 19 for more detail.

4 Set up the LO. See “Choosing and Setting Up the Local Oscillator" on page 79 for 
more detail.

5 Connect the system and add filtering where required. Figure 31 on page 93 shows the 
connections. 

Setting Up the DUT

1 Click Mode Setup > DUT Setup.... The DUT Setup form is displayed. Confirm that 
the DUT field is set to DownConv.

2 Click Ext LO Frequency and use the keyboard to enter the LO frequency of 970 MHz. 
(Enter “M” as the units designator for megahertz.)

3 Click Sideband and choose the lower sideband by clicking LSB.

4 Click Frequency Context and select IF Analyzer Input. This means that we will 
specify the frequency at the analyzer’s input (70 MHz), and the RF frequency will be 
calculated by the noise figure application.

In this example measurement, 70 MHz bandpass and 200 MHz low-pass filters have 
been used between the DUT and the N8201A. These filters have been added at this 
calibration stage to remove any errors that they might contribute from the final result.

(GHz)

IF
(70 MHz)

LO
970 MHz

RF (USB)
1.04 GHz

RF (LSB)
900 MHz

dB

1.00.80.60.40.2 1.2

900 MHz
band pass filter

70 MHz
band pass filter

Rejected
USB
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Setting Frequency, Frequency Mode, and Averaging

1 Click FREQUENCY Channel. Use the keyboard to specify the frequency mode and 
frequency parameters. In this example of a fixed frequency noise figure measurement 
on a downconverter, the appropriate settings are

• Freq Mode: Fixed

• Fixed Freq: 70 MHz 

There are two possible frequencies you can enter - the RF frequency (before down 
conversion) or the IF frequency (after down conversion). In this example, we previously 
specified that the Frequency Context was IF Analyzer Input, so a value of 70 MHz is 
used.

2 To configure the rest of the measurement, click Meas Setup. Use the keyboard to 
specify the remaining measurement parameters. In this example, the appropriate 
settings are:

• Averaging: ON (You can only set averaging to on for N8201A Option 110 
instruments.)

• Average Number: 10

• Internal preamp: On

Calibration of the Measurement Setup

Calibration of the setup for a noise figure measurement is specific to the frequency you 
have set. If you change the frequency after calibration, you will have to recalibrate the 
measurement.

To connect the noise source and N8201A for calibration, see Figure 31. Connect any 
After DUT filtering prior to calibration.
NOISE SOURCE DRIVE 
OUT +28 V (PULSED)

NORMAL 
NOISE SOURCE

NORMAL 
NOISE SOURCE

NOISE SOURCE DRIVE 
OUT +28 V (PULSED)

LO

DUT

CALIBRATION SETUP MEASUREMENT SETUP
Figure 31 Frequency Converting DUT Calibration and Measurement
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1 Click Meas Setup > Calibrate.

When calibration is complete the measurement system is calibrated at the mixer 
input. The red Uncorr text changes to green Corr text in the top right hand side of 
the display.

2 Click Trace/View > View > Meter to see the calibration results.

Figure 32 Typical Calibration Results

After calibration the instrument will not be jittering near 0 dB with no DUT inserted. 
This is because the instrument is now using the ENR value for the RF, while the input is 
tuned to the IF. When the DUT is added, the noise figure analyzer measures the noise 
figure of the DUT. If the configuration is arranged to reject one sideband, the SSB result 
is displayed. If both sidebands are converted by the mixer the DSB result is displayed.

Making the Corrected Noise Figure and Gain Measurement

A measurement corrected for the noise contributed by the N8201A may now be made. 
Insert the DUT into the system as shown in Figure 31. 

1 Click Trace/View > > View > Meter to display the results. A typical display of noise 
figure and gain (conversion loss) is shown in Figure 33. 

The filtering used for this example measurement comprised:

• 900 MHz bandpass filter between the noise source and the DUT

• 70 MHz bandpass and 200 MHz low-pass filters between the DUT and the N8201A
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Figure 33 Typical Microwave Results

Once you have successfully made the measurement you may want to save the set up for 
future measurements. This can be done by saving the state. For more details, see the PSA 
Series Spectrum Analyzers User’s and Programmer’s Guide.

Upper Sideband Measurement

The USB measurement set up is similar to the LSB measurement procedure described in 
“Lower Sideband Measurement" on page 91. However, the filtering requirements will be 
different because the LSB has to be filtered out. Follow the LSB procedure, and in the 
DUT Setup... form select USB as the sideband option.

Double Sideband Measurement

The DSB measurement set up is similar to the LSB measurement procedure described in 
“Lower Sideband Measurement" on page 91. Follow the LSB procedure, and in the DUT 
Setup... form select the DSB as the sideband option.

If the assumptions about the parameters being flat over frequency between the two 
sidebands are valid, your results will show a doubling in power (3 dB increase) in noise 
level during a DSB measurement. This can be corrected using the Loss Compensation 
Setup screen 

1 Click Input/Output > Loss Comp.

2 Click Loss Compensation Before DUT and set to Fixed.

3 Enter a Fixed Value of –3 dB.

4 Click Loss Comp Before Temp to set the noise source’s cold temperature. 
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The DSB power addition occurs for both the hot and cold noise from the noise source, 
and the noise created in the input of the DUT. A temperature value can be assigned to 
this loss using Loss Before Temp function. Using the Cold temperature of the noise 
source (often assumed to be 290 Kelvin) corrects for this, and the N8201A will give 
corrected results comparable to those that would have been given by an SSB 
measurement.
Making Up Converting DUT Measurements using a Fixed LO and Variable IF 
(Equivalent to Mode 1.4 with SUM on an 8970B Noise Figure Meter)
Lower Sideband Measurement

The lower sideband measurement set up is similar to the LSB measurement procedure 
described in “Lower Sideband Measurement" on page 91. However, with an up 
converting measurement, the RF is the lower frequency, and the IF is the higher 
frequency to which you will convert. Follow the LSB procedure, and in the DUT Setup... 
form ensure the LSB is the sideband option is selected, and select Upconv instead of 
Downconv as the DUT. The filtering requirements will be different as you need to 
remove the LO signal from the IF path.

Upper Sideband Measurement

The upper sideband measurement set up is similar to the LSB measurement procedure 
described in “Lower Sideband Measurement" on page 91. However, with an up 
converting measurement, the RF is the lower frequency, and the IF is the higher 
frequency to which you will convert. Follow the LSB procedure, and in the DUT Setup... 
form ensure the LSB is the sideband option is selected, and select Upconv instead of 
Downconv as the DUT. The filtering requirements will be different as you need to 
remove the LO signal from the IF path.
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Measurements with a System Downconverter 
N8201A Noise Figure
A system downconverter can be thought of as a frequency extender for the N8201A, to 
allow measurements to be made on DUTs at frequencies the N8201A does not cover in 
its frequency range.
NOISE SOURCE DRIVE 
OUT +28 V (PULSED)

NORMAL NOISE SOURCE NOISE SOURCE DRIVE 
OUT +28 V (PULSED)

LO LO
DUT

NORMAL NOISE SOURCE

CALIBRATION SETUP MEASUREMENT SETUP
Figure 34 System Downconverter Calibration and Measurement

A system downconverter is part of the measuring system, and is present in both the 
calibration setup and the measurement setup (see Figure 34.) During calibration the 
noise performance of both the N8201A and the system downconverter are measured. 
Because of this, when corrected measurements are performed, the results then apply to 
the DUT only. ENR data for the same frequency range is used for both calibration and 
measurements

The N8201A has the capability to control a single frequency conversion, so system 
downconverter measurements under the N8201A's control are limited to non-frequency 
converting DUTs.

The N8201A can be used in much more complex systems, with multiple frequency 
conversions between the DUT and measurement system. However, the control of such 
systems is application-specific. You need to perform frequency calculations to suit that 
particular system, account for the effects of any DSB conversions, determine filter 
requirements, and calculate the appropriate ENR values for calibration and 
measurement.
USB, LSB or DSB?
If the DUT is broadband, a system downconverter could operate in USB, LSB, or DSB 
mode, and the same circumstances occur in both calibration and measurements, hence 
DSB sideband power addition corrections are not needed. Corrected measurements 
cancel any sideband summation effects.
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If the DUT is narrowband and a DSB system downconverter is used, the 
calibration setup will operate in true DSB mode. However, the measurement 
setup mode will be influenced by the DUT’s selectivity.

The possibilities fit into two groups and a third situation which should be 
avoided:

• The DUT bandwidth is much greater than the LSB-USB separation, so a 
normal DSB measurement results.

• The DUT bandwidth is much less than the LSB-USB separation, and the 
sweep width is less than the USB-LSB separation, so a SSB 
measurement results. This needs a gain correction factor due to the DSB 
calibration.

There is a third situation and this must be avoided. This is where the DUT 
selectivity can resolve the individual sidebands of the DSB measurement 
and the sweep is wide enough to scan the DUT across them. Different parts 
of the measurement plot are in different modes. USB, LSB and DSB could 
occur in different places on the same plot, with gradual changes between 
them, set by the shape of the DUT's frequency response. Variable gain 
correction would be needed across the plot and the corrections needed would 
change if adjustments to the DUT changed its shape.
Measurement Modes with a DSB System Downconverter
The N8201A only supports the use of a fixed LO, with any frequency 
sweeping being done by the N8201A. The benefits of a DSB measurement 
are minimal filter requirements, and wide frequency coverage. DSB 
measurements are appropriate for wideband DUTs. Their disadvantages, 
covered in “USB, LSB or DSB?" on page 97, make them inappropriate for 
narrowband DUTs. The usual aim is to choose as low a frequency IF as 
possible, in order to minimize the separation between the sidebands, and 
thus get the optimum resolution possible. Figure 35 shows this.

When making DSB measurements, it is important that the IF frequency is 
much smaller than the LO frequency. This is because the ENR values in the 
ENR table can only be applied to one frequency or, in the case of a swept 
measurement, to one set of frequencies. The ENR values can not be applied 
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simultaneously to both the upper sideband and to the lower sideband. The ENR values 
are therefore applied to the midpoint between the upper sideband and the lower 
sideband, and this equates to the LO frequency.

Consequently, the higher the IF frequency is in comparison to the LO frequency, the 
further apart the upper and lower sidebands will be. The further these upper and lower 
sidebands are from the LO frequency, the less accurate will the ENR value be.

Another potential source of error is the frequency response of the DUT. If the frequency 
response varies over the measurement range, from lower to upper frequency, the noise 
figure results will only represent an average value.

It is recommended for greatest accuracy that the IF frequency be no greater than 1% of 
the LO frequency when making double sideband measurements. When making a swept 
measurement, no frequency in the swept frequency band should exceed 1% of the LO 
frequency.

Figure 35 DSB System Downconverter Measurements

DSB system downconverter measurements have implicit linear averaging of DUT 
characteristics. The same ENR values are used for both the USB and LSB frequencies, 
and are taken from the average frequencies of the USB and the LSB. This corresponds to 
the LO frequency. Results returned are the average of the two sideband powers.

For microwave measurements, above 3.5 GHz, the N8201A's input filter will reject LO 
leakage from the downconverter, otherwise a filter is needed between the system 
downconverter and the N8201A. Also, considerations about mixer LO harmonic modes 
apply.
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N8201A Input
Band

LSB Input USB Input
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Measurement Modes with an SSB System Downconverter
100
The N8201A can perform frequency calculations for USB, for LSB, or for USB system 
downconverter conversions.

The filtering requirements will be measurement-specific. 

Figure 36 shows how filtering makes an LSB measurement, and Figure 37 shows a USB 
downconversion measurement.
N8201A Input LSB Input USB Input

Amplitude

Frequency

FLO

Band

Flo-Flsb
mixing

Depending on Flo, a
downconverter output filter
may be needed to reject 

Noise reaching mixer from
the DUT Input filter

LO-IF leakage

FRFFIF
Figure 36 LSB System Downconverter Measurements
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Figure 37 USB System Downconverter Measurements

Ideally choose a high IF frequency for the conversion to separate the USB and LSB 
bands, thus simplifying the filter requirements.

The filter needed to make an SSB measurement could be part of the DUT, or a 
measurement-specific filter must be obtained and applied at the input to the system 
downconverter.

The bandwidth of the SSB filter limits the maximum frequency range over which a 
measurement can be swept. Therefore SSB measurements are not suited to very 
wideband DUTs.

Filtering is needed to select the wanted sideband. A swept noise figure measurement is 
then possible even if the though LO cannot be swept. 
FIXED LO, LSB
The main benefit of the fixed LO system downconverter modes is that a programmable 
synthesized LO is not needed.
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Figure 38 LSB Measurements

Figure 38 shows how the N8201A sweeps its own input frequency so that as the LSB 
tunes, the frequency increases across the sweep. The filter required is either a low pass or 
a band pass. The maximum sweep width is now limited to the maximum IF frequency, 
less an allowance for the filter transition band.
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Figure 39 USB Measurements
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Figure 39 shows that as the N8201A is tuned in the normal direction, that is, from a low 
frequency to a high frequency, the USB and the IF vary in unison. The filter can be a 
band pass or high pass, and the sweep width is again limited to the maximum IF 
frequency, less an allowance for the filter transition band.
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Frequency Restrictions
104
To assist you in troubleshooting problems that you may have encountered when setting 
up these measurement modes, the restrictions that apply to the different types of 
measurements are detailed on the following pages.

The N8201A will only return messages if the frequencies used at the ports of the 
frequency converter fall outside the valid range that the N8201A can handle. Under such 
conditions, a valid measurement cannot be performed. Within these limits, it is up to you 
to specify valid frequencies at all ports for the type of DUT currently selected.
Glossary of Restricted Terms
Table 8 is a description of the terms used in the restrictions.

Table 8 Restricted Terms

Term Description

IF The output from DUT frequency or the 
tuned frequency of the N8201A

IFSTART  IFSTART is lower than IFSTOP.

IFSTOP  IFSTOP is higher than IFSTART.

RF The input to DUT frequencies

RFSTART  RFSTART is lower than RFSTOP.

RFSTOP  RFSTOP is higher than RFSTART.

FLO External LO
General Restrictions
In noise figure measurements, the following general restrictions apply:

• The IF frequency range is limited to a minimum of 10 kHz, and a maximum of  
26.5 GHz.

• The RF frequency range is from 1 Hz to 325 GHz, depending on the DUT setup.

Regardless of whether the input frequencies are RF frequencies or IF frequencies, the 
Frequency/Channel menu is used to enter these frequency values.

• The minimum frequency separation between consecutive points is 10 Hz.
Frequency Down Converting DUT
In this measurement, the DUT contains a frequency down converting device. Two 
examples are a mixer or receiver. These are the applicable restrictions:
N8201A Noise Figure Measurement Personality Guide



Making Frequency Converter Measurements 4

N8201A Noise Figure
LSB Restrictions

With LSB measurements, the following restrictions apply:

• RFSTOP < FLO

• RFSTART > IFSTOP

• FLO - RFSTOP ≥ 10 kHz

USB Restrictions

With USB measurements, the following restrictions apply:

• RFSTART > FLO

• IFSTOP < FLO

• RFSTART - FLO ≥ 10 kHz

DSB Restrictions

With DSB measurements, the following restrictions apply:

• RFSTART > IFSTOP
Frequency Up Converting DUT
In this measurement, the DUT contains a frequency up converting device. One example 
is a mixer used in a transmitter.

LSB Restrictions

With LSB measurements, following restrictions apply:

• IFSTOP < FLO

• IFSTART > RFSTOP

USB Restrictions

With USB measurements, the following restrictions apply:

• IFSTART > FLO

• RFSTOP < FLO
System Downconverter
The DUT is a non-frequency converting device, for example an amplifier or filter 
measurement, and its frequency is outside the N8201A’s measurement range or outside 
its range of maximum accuracy. Frequency down conversion is required within the 
measurement system, in other words, using a mixer, external to the DUT, to convert the 
signal of interest to the frequency range of the N8201A.
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LSB Restrictions

With LSB measurements, the following restrictions apply:

• RFSTOP < FLO

• RFSTART > IFSTOP

• FLO - RFSTOP ≥ 10 kHz

USB Restrictions

With USB measurements, the following restrictions apply:

• RFSTART > FLO

• IFSTOP < FLO

• RFSTART - FLO ≥ 10 kHz

DSB Restrictions

With DSB measurements, the following restrictions apply:

• RFSTART > IFSTOP
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5
Front-Panel Key Reference 

This chapter details the front-panel keys and menu keys. The front-panel keys are listed 
alphabetically and are described with their associated menu keys. The menu keys are 
arranged as they appear in the N8201A Option H02 Spectrum Analyzer GUI menus.
Key Descriptions and Locations
This chapter provides information on the Noise Figure measurement mode functions 
only. 
AMPLITUDE Y Scale page 109 

BW/Avg page 111

Det/Demod page 113 

Display page 115 

File page 117

FREQUENCY Channel page 121 

Input/Output page 124 

Marker page 127 

Measure Control page 128 

Meas Setup page 129 

MEASURE page 133 

MODE page 134 

Mode Setup page 135 

Mode Setup — DUT Setup page 135 

Mode Setup - Uncertainty Calculator page 136 

Peak Search page 138

Preset page 139 

Source page 140 

SPAN X Scale page 141 

Sweep Menu page 142 

System page 143
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Trigger page 145

Trace/View page 146 
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AMPLITUDE Y Scale 

Scale/Div

NOTE The following functions are the same for both display A and display B. 
N8201A Noise Figure
Sets the units per vertical graticule division in the measurement window on the display. 
If more than one measurement window is displayed (for example, when making Noise 
Figure measurements), the active window is indicated by a green border. The active 
window can be changed by clicking Trace/View > Display.
Ref Value
Ref Value is only available when Measure > Noise Figure is selected.

Specifies the amplitude level represented by the Ref Position (see below) on the 
graticule display. The units of measurement are either dB or Kelvin, depending on the 
measurement being displayed in the active window.
Ref Position
Ref Position is only available when Measure > Noise Figure is selected.

The reference position on each trace is indicated by a small chevron (the ‘>’ and ‘<’ 
signs) at either side of the graticule. The value of this reference position on the graticule 
is specified with the Ref Value key (see above). The Ref Position key allows you to vary 
the position of the reference trace between top, center, and bottom of the graticule. 

Top

Sets the reference position to the top line of the graticule. Its position is indicated by a 
small chevron on either side of the graticule.

Ctr

Sets the reference position to the center of the graticule. Its position is indicated by a 
small chevron on either side of the graticule.

Bot

Sets the reference position to the bottom line of the graticule. Its position is indicated by 
a small chevron on either side of the graticule.
Auto Scale
Auto Scale is only available when Measure > Noise Figure is selected.
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Automatically sets both the Scale/Div and the Ref Value to values that are suitable for 
the current trace data. 
Ref Level
Reference Level is only available when Measure > Monitor Spectrum is selected.

Specifies the absolute amplitude level represented by the top line on the graticule 
display. The units of measurement are dB.
Attenuation
Attenuation is only available when Measure > Monitor Spectrum is selected.

Adjusts the input attenuation in 2 dB increments on the N8201A. The N8201A input 
attenuator reduces the power level of the input signal delivered to the input mixer. If set 
manually, the attenuator is recoupled when Attenuation (Auto) is selected. 
Optimize Ref Level
Optimize Ref Level is only available when Measure > Monitor Spectrum is selected.

Optimizes the Reference Level and Attenuation settings for the current signal. The 
reference level will be set to a value that keeps the signal as close as possible to the top 
of the display. Attenuation will be set to a level that maintains a maximum mixer level of 
–20 dBm.
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BW/Avg 
N8201A Noise Figure
Activates the resolution bandwidth function, and displays the menu keys that control 
both the bandwidth and averaging functions.
Res BW
Sets the resolution bandwidth. Resolution bandwidth is the 3 dB bandwidth of the 
N8201A’s resolution bandwidth filter. It is called resolution bandwidth because two 
closely-spaced equal amplitude signals are just resolved if they are separated by an 
amount equal to the N8201A 3 dB bandwidth. 

Sweep time is coupled to RBW. As the RBW changes, the sweep time (if set to Auto) is 
changed to maintain amplitude calibration. 

Manual

Allows you to set the 3 dB filter bandwidth (RBW) of the N8201A’s resolution 
bandwidth filter. 

You can specify the Resolution Bandwidth in 10% steps from 1 Hz to 3 MHz, plus 
bandwidths of 4, 5, 6, or 8 MHz. 

If an unavailable bandwidth is entered with the keyboard, the closest available 
bandwidth is selected.

Auto 

Automatically sets the resolution bandwidth for the best results. At measurement 
frequencies greater than 3 MHz, the resolution bandwidth will be set to 1 MHz. For 
measurement frequencies below 3 MHz, the resolution bandwidth will be set to 10% of 
the measurement frequency.

After the N8201A has been calibrated, changing the RBW setting to a value which 
crosses the 1.5 MHz boundary will invalidate the calibration data. This will happen if 
your RBW setting is changed from a value above 1.5 MHz to one that is lower than or 
equal to 1.5 MHz, or if it is changed from a value below or equal to 1.5 MHz to one that 
is higher. You must recalibrate the N8201A for the new setting.

The available range is from 1 Hz to 8 MHz in approximately 10% steps. In addition, a 
wide-open video filter bandwidth (VBW) may be chosen by selecting 50 MHz. 

Video BW (Auto) selects automatic coupling of the video BW filter to the resolution 
bandwidth filter using the ratio set by the VBW/RBW key.
Video BW Auto/Man
Video BW Auto/Man is only available when Measure > Monitor Spectrum is selected.
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Enables the N8201A’s post-detection filter from 1 Hz to 8 MHz in approximately 10% 
steps. In addition, a wide-open video filter bandwidth (VBW) may be chosen by 
selecting 50 MHz. Video BW Auto selects automatic coupling of the video bandwidth 
filter to the resolution bandwidth filter using the VBW/RBW ratio set by the VBW/RBW 
key.

Sweep time is coupled to video bandwidth. As the VBW is changed, the sweep time 
(when set to Auto) is changed to maintain amplitude calibration. This occurs because of 
common hardware between the two circuits, even though the video bandwidth filter is 
not actually “in-circuit” when the detector is set to Average. Because the purpose of the 
average detector and the VBW filter are the same, either can be used to reduce the 
variance of the result.

Although the VBW filter is not “in-circuit” when using the Average detector, the Video 
BW key can have an effect on (Auto) sweep time, and is not disabled. In this case, 
reducing the VBW setting increases the sweep time, which increases the averaging time, 
producing a lower-variance trace.

However, when the EMI Average detector is selected, Video BW is restricted to 1 Hz. 
while the sweep time is set to Auto.

When using the average detector with either Sweep Time set to Manual, or in zero span, 
the VBW setting has no effect and is disabled (greyed out).

A “#” mark appears next to VBW on the bottom of the display when it is not coupled. To 
couple the video bandwidth, click Video BW Auto.
VBW/RBW
VBW/RBW is only available when Measure > Monitor Spectrum is selected.

Sets the ratio between the video and resolution bandwidths. Setting video bandwidth 
wider than resolution bandwidth (VBW/RBW ratio > 1.000) provides best peak 
measurements of signals such as wideband radar pulses. Setting VBW narrower than 
RBW (VBW/RBW ratio <1.000) reduces the variance of noise-like signals and makes 
spectral components close to the noise floor easier to view. 
Span/RBW
Span/RBW is only available when Measure > Monitor Spectrum is selected.

Selects the ratio of the span to the resolution bandwidth. A factory preset sets the ratio to 
106:1. 
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Det/Demod 
N8201A Noise Figure
Det/Demod functions are available in Measure > Monitor Spectrum mode only. In 
Noise Figure mode, Average detection is used.
Detector
Allows you to select a specific detector for a particular measurement.

When discussing detectors, it is important to understand the concept of a trace “bucket.” 
For every trace point displayed, there is a finite time during which the data for that point 
is collected. The N8201A has the ability to look at all of the data collected during that 
time and present a single point of trace data based on the detector mode. The interval 
during which the data for that trace point is being collected, is called the “bucket.” Thus, 
a trace is more than a series of single points. It is actually a series of trace “buckets.” The 
data may be sampled many times within each bucket.

The detector in use is indicated on the left side of the display. 

Normal

Displays the peak of CW-like signals and maximums and minimums of noise-like 
signals. 

Average

Displays the average of the signal within the bucket. The averaging method depends 
upon Avg/VBW Type selection of either Log-Pwr Avg (Video) or Pwr Avg (RMS).

Peak

Displays the maximum of the signal within the bucket.

Because a spectral component's true peak may not be found, neither average nor sample 
detectors measure amplitudes of CW signals as accurately as peak or normal, but they do 
measure noise without the biases of peak detection.

Sample

Displays the instantaneous level of the signal at the center of the bucket represented by 
each display point.

Because a spectral component's true peak may not be found, neither average nor sample 
detectors measure amplitudes of CW signals as accurately as peak or normal, but they do 
measure noise without the biases of peak detection.

Negative Peak

Displays the minimum of the signal within the bucket.
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Quasi Peak

A fast rise and fall detector used in making CISPR EMI compliant measurements. 
Quasi-peak detection is a weighted form of peak detection. During quasi-peak detection, 
the displayed response drops as the repetition rate of the measured signal decreases. This 
signal weighting is accomplished by circuitry with specific charge (1 millisecond) and 
discharge (600 milliseconds) time constants. For continuous wave signals, peak and 
quasi-peak values are the same.

EMI Average

Displays the instantaneous level of the signal at the center of the bucket, just like the 
sample detector. 

EMI Peak

Displays the maximum of the signal within the bucket using CISPR related bandwidths.

MIL Peak

Displays the maximum of the signal within the bucket using MIL related bandwidths.
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Display
N8201A Noise Figure
Accesses the menu keys that allows you to see and setup different measurement displays.
Limits
Limit functions are only available when Measure > Noise Figure is selected.

Limit lines can be defined to compare the data to your defined limits and indicate a pass 
or fail condition. Limits accesses menus that allow you to create, modify, and change the 
properties of limit lines. There are two limit line sets in the GUI.

Limit Line 1:A, 2:A, 3:B, 4:B

Selects the limit line for editing. Limit lines 1A and 2A are available for Display A (the 
top display), limit lines 3B and 4B are available for Display B (the bottom display).

Limit State On/Off

Turns the limit state On or Off. The limit state can be on for testing purposes even if the 
limit line display is set to off (Display Off).

Type Upper/Lower

Defines the limit you are editing as either an upper or lower limit. An Upper limit fails if 
the trace exceeds the limit. A Lower limit fails if the trace falls below the limit.

Display On/Off

Turns limit-line display On or Off. 

Test On/Off

Turns the testing of the limit line On or Off. If the trace is at or within the bounds of the 
set limit, PASS LIMIT# is displayed in green in the upper-left corner of the 
measurement area where # is the number of the selected limit line. Only positive 
margins are allowed for lower limits and only negative margins are allowed for upper 
limits. If the trace is out of the limit boundaries, FAIL LIMIT# is displayed in red. 

Edit...

Allows you to modify the limit line table for the selected limit line. That is, 1:A, 2:A, 
3:B, 4:B.

Disable All Limits

Turns off the display of all limit lines. 
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Preferences
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Preferences is only available when Measure > Noise Figure is selected.

Accesses a menu of selections to customize the display’s appearance.

Graticule

Displays or hides the graticule lines on the display.

Annotation 

Displays or hides the annotation pertaining to the current display.
Display Line
Display Line is only available when Measure > Monitor Spectrum is selected.

Activates an adjustable horizontal line that is used as a visual reference line. The line has 
an amplitude that corresponds to its vertical position relative to the reference level. The 
value of the display line appears on the left side of the display below the label Dl. The 
display line can be adjusted by clicking the numeric value and using the keyboard to 
enter a new value.
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File
N8201A Noise Figure
Displays a menu of functions that enable you to load, save, and manage data on the 
N8201A’s internal drive or to your PC. You can recall, save, copy, delete, or rename files 
of instrument states, trace data, and screen captures. 

You can save the following types of files:

• State - A file that contains a copy of the state of the N8201A at the time the file is 
saved. The settings of most N8201A functions are saved in the state files but not 
traces, limits, and corrections. When a State file is loaded into the N8201A, the 
N8201A is restored to the same state as when the file was saved. Some settings are 
not saved in the State files, for example the time/date display style and 
auto-alignment state; these settings are called “persistent.” In this manual, each 
function describes whether that function is saved in “Instrument State” or is 
persistent.

• Trace - A file that contains a copy of the trace data for one or more traces. There are 
two formats for trace files, Trace + State and CSV files.

• Trace + State: A file that contains the trace data and a copy of the current 
N8201A state. The trace and state are stored in an internal data format (TRC), 
which cannot be loaded into a PC, but can be loaded back into the N8201A. 
Traces can be loaded individually or as a group. When a Trace + State file is 
loaded into the N8201A the trace data that was on the screen, when saved, is 
loaded into the N8201A. This enables you to view the trace as it looked when it 
was saved. Because the state data is also saved, the N8201A settings, including all 
the annotation on the screen, is restored as well. To preserve the trace data, the 
traces contained in the saved files are placed in View mode (see Trace/View, 
page 146) so that they are not immediately overwritten by new trace data. This 
means that you can save traces while making a measurement, and later load them 
back into the N8201A, where you can print them or transfer them to a computer, 
in CSV format, for analysis. If you wish to compare two saved traces, place traces 
in view mode before saving them. This prevents the trace from being rewritten 
based on a state change from subsequent loads.

• CSV: A file that contains trace data in comma-separated values format (CSV, 
standard PC spreadsheet format), can be read into a spreadsheet for analysis. Most 
spreadsheet programs support CSV format. They cannot be loaded back into the 
N8201A.

• Limits - A file that contains a copy of the N8201A limit sets at the time the file is 
saved. Limits provide data sets to determine whether a trace has exceeded preset 
specifications. Limit sets can hold up to 200 points and can only be saved 
individually. Refer to the File > Save > Source key description, page 120. When you 
load a Limits file into the N8201A, you restore all of the limit sets that were in the 
instrument at the time of the save. 
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• Corrections - A file that contains a copy of the N8201A correction tables at the time 
the file is saved (CBL, ANT, OTH, AMP). Corrections provide a way to adjust the 
trace display for preset gain factors (such as for cable loss). A correction set can hold 
up to 200 points. Pressing Corrections activates the Source key. Refer to the File, 
Save, Source key description, page 131. When you load a Corrections file into the 
N8201A, you restore all of the corrections values that were in the instrument at the 
time of the save.
Browse User Directory
Opens the instrument directory where the stored data files are located.
Load
Accesses a menu to load stored files into the instrument.

Load Now

Loads the selected file into the instrument.

Type

Allows you to select the desired type of instrument-data files to be displayed. Common 
types of instrument data files include trace data, limit line data, and amplitude correction 
data. 
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N8201A Noise Figure
Table 9 Instrument Data File Types
Type Format Destination Extension

State State STA

Trace Trace + State Trace 1, 2, 3 or all traces TRC

Comma separated trace values Trace 1, 2, 3 or all traces CSV

Limit Internal data format LIM

Screen Bitmap GIF

Reverse bitmap GIF

Corrections Internal data format ANT, CBL, OTH, and AMP

Measurement 
Results

Comma separated values CSV

ENR Meas 
Common Table

Internal data format ENR

ENR Cal Table Internal data format ENR

Loss Comp 
Before DUT

Internal data format LOS

Loss Comp 
After DUT

Internal data format LOS

Freq List Internal data format LST
Destination

When the file type is set to Trace, Destination accesses the keys to load either Trace 1, 2, 
3 or All traces. 

When the file type is set to Corrections, Destination accesses the keys to select Antenna, 
Cable, Other, or User as the type of correction to load.

When the file type is set to Limits, Destination accesses the keys to load either Limit 
Line 1, 2, 3, or 4. Limit sets can only be loaded individually.

Source Device 

Specifies either the N8201A or the PC as the source of the saved files.

File Name

Opens the dialog box allowing selection of a previously stored file. Depending on the 
Source Device selected, a different dialog box will appear.
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Instrument Opens the Load File from Instrument window where the saved files are 
stored.

PC Opens Windows Explorer allowing you to navigate to the saved files.
Save
Accesses a menu to save a file to either the instrument or the PC.

Save Now

Saves the specified file.

Type

Allows you to select the desired type of instrument-data files to be saved. Common types 
of instrument data files include trace data, limit line data, and amplitude correction data. 
See Table 9.

Format

When Trace is selected as the file type, then you can either choose to save the trace data 
as Trace + State or as a CSV file. See page 117 for more information on these file 
formats.

Source

When the file type is set to Trace, Source accesses the keys to save either Trace 1, 2, 3 or 
All traces. Saving all traces saves all traces in a single file.

When the file type is set to Corrections, Source accesses the keys to select Antenna, 
Cable, Other, or User as the type of correction to save.

When the file type is set to Limits, Source accesses the keys to save either Limit Line 1, 
2, 3, or 4. Limit sets can hold up to 200 data points and can only be saved individually.

Destination Device Instrument PC

Specifies either the N8201A or the PC as the destination drive for the saved files.

File Name

Opens the dialog box allowing you to save a file. Depending on the Source Device 
selected, a different dialog box will appear.

Instrument Opens the Load File from Instrument window where the saved files are 
stored.

PC Opens Windows Explorer allowing you to navigate to the directory where the 
saved files are stored.
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FREQUENCY Channel 
N8201A Noise Figure
Accesses the menu of frequency functions.
Freq Mode 
Available in Measure > Noise Figure only.

Specifies either swept, list, or fixed frequency modes. The selected frequency mode is 
displayed in the menu key.

Sweep

The measurements are made at frequencies generated from the selected frequency range 
and the number of measurement points.

Fixed

The measurements are made at a fixed frequency.

List

The measurements are made at the frequencies specified in the frequency table.
Start Freq
Sets the frequency at which the measurement sweep starts. In the graphical format, the 
trace starts at the left side of the graticule. When Start Freq is selected its value is 
displayed above the graticule.

When measuring at frequencies below 20 MHz, Agilent recommends that you switch to 
DC coupling for greater measurement accuracy. 
Stop Freq

CAUTION Do not switch to DC Coupling if the input signal contains a DC component. You risk 
permanently damaging the N8201A’s front end mixer if you do this.
Sets the frequency at which the measurement sweep stops. In the graphical format, the 
trace stops at the right side of the graticule. When you change the Stop frequency, the 
Span and Center Frequencies will be adjusted to keep the measurement frequency range 
centered. When Stop Freq is selected its value is displayed above the graticule. 
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Center Freq
122
Sets the frequency at which the measurement frequency range is centered. When you 
change the Center Frequency, the Start and Stop Frequencies are adjusted without 
modifying the Span setting. When Center Freq is selected its value is displayed above 
the graticule. 
Points
Available in Measure > Noise Figure only.

Sets the number of discrete equidistant frequency points at which measurements are 
made during Sweep frequency mode. The maximum number of points allowed is 401. 
The default value is 11. The number of points is shown at the bottom of the display.

The maximum number of 401 points is conditional, as this number is limited by the 
frequency span. Where the minimum resolution between any two points is set at 10 kHz, 
the frequency’s measurement range must be greater than 4 MHz to achieve 401 points.
Freq Offset
Available in Measure > Monitor Spectrum only.

When set to Man, the Frequency Offset can be set by using the keyboard and selecting 
the first letter of units designator. For example “G” for gigahertz. The default setting for 
frequency offset is Man.

When set to Auto, the frequency offset settings are calculated automatically using the 
settings under DUT Setup.

The frequency offset is used to account for frequency conversions external to the 
N8201A. This value is added to the display readout of the marker frequency, center 
frequency, start frequency, stop frequency, and all other absolute frequency settings in 
the N8201A. When a frequency offset is entered, the value appears below the center of 
the graticule. To eliminate an offset, perform a Factory Preset or manually set the 
frequency offset to 0 Hz.

This command does not affect any bandwidths or the settings of relative frequency 
parameters such as delta markers or span. It does not affect the current hardware settings 
of the N8201A, but only the displayed frequency values. Offsets are not added to the 
frequency count readouts. Entering an offset does not affect the trace display.

Frequency Context (Mode Setup, DUT Setup...) must be set to RF for the Auto setting of 
Freq Offset to have any effect. When the Frequency Context is set to IF, and Freq Offset 
is set to Auto, the frequency offset will be set to 0 Hz. All frequencies are displayed as 
they are at the N8201A input, that is, after the DUT.
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Fixed Freq
N8201A Noise Figure
Sets the frequency point used in fixed frequency measurements. When Fixed Freq is 
selected its value is displayed in the left and right lower annotation as start and stop 
values respectively. 
Freq List…
Accesses a form to enter or edit a frequency list.

The frequency list allows you to enter a list of frequencies at which measurements are to 
be made. Frequency lists are limited to 401 entry points. The number of points is shown 
at the bottom of the display. 

The frequencies are automatically sorted in ascending order, and duplicate frequencies 
are allowed. When a frequency is duplicated in the table, that frequency will be 
measured once for each entry.
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Input/Output
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Displays a menu that allows you to control the input and output signals to and from the 
N8201A.
Noise Figure Corrections
Available in Measure > Noise Figure only.

Accesses menus that allow you to set Noise Figure Correction On or Off, and to enter the 
minimum and the maximum attenuation values used in calibration.

Noise Figure Corrections

Selects either corrected and uncorrected results.This key is grayed out unless a valid 
calibration (Meas Setup, Calibration...) has been performed.

On Displays corrected data.

Off Displays uncorrected data.

If you change the frequency range to greater than the current calibration, the message 
“User Cal invalidated; Freq outside cal range” is displayed. If you 
want corrected measurements over a greater range, you need to calibrate the N8201A 
again before making this measurement.

If you change the frequency range to less than the current calibration, the message 
“User Cal will be interpolated” is displayed. This demonstrates that the 
N8201A is using interpolated results and interpolated errors may be introduced.

Min Atten

Changes the RF attenuator’s minimum input attenuation during calibration. The range is 
from 0 dB to 40 dB and can be set in 4 dB steps. The default value is 0 dB.

Max Atten

Changes the RF attenuator’s maximum input attenuation during calibration. It can be set 
in 4 dB steps. The default value is 8 dB.
Loss Comp
Available in Measure > Noise Figure only.

Accesses features which allows the N8201A to compensate for losses. For example, the 
losses could be due to additional cabling either before or after the DUT’s measurement 
or both. You can compensate for this loss either by using the same fixed value over the 
whole frequency span, or by using values that vary across the frequency span and which 
have been specified in a table.
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N8201A Noise Figure
Setup...

Brings up the Loss Compensation form, allowing you to specify the parameters 
associated with loss compensation.

Loss Compensation Before DUT Allows you to specify what type of Loss 
Compensation is used before the Device Under Test: Fixed, Table, or none.

Off - No loss compensation is made before the DUT. 

Fixed - Loss Compensation is at a fixed value over the entire frequency span.

Table - Loss Compensation varies across the frequency span, using values specified in a 
table.

Loss Comp Before DUT Fixed Value Sets the amount of compensation, before the 
device under test, as a fixed value. This is only valid if the Before DUT (Fixed) is 
enabled. You can enter the value as dB or linear. However, the linear value is converted 
to dB. The lower limit is –100.000 dB and the upper limit is 100.000 dB. The default 
value is 0.000 dB.

Loss Comp Before DUT Temp Sets the temperature of loss compensation, before the 
device under test, as a fixed value. This is only valid if Before DUT is enabled. You can 
enter the value as K (Kelvin), C (degrees Celsius), or F (degrees Fahrenheit). However, 
the C and F values are converted to K. The lower limit is 0.00K and the upper limit is 
29,650,000.00 K. The default value is 0.00K.

Loss Comp After DUT Specifies what type of Loss Compensation is used after the 
Device Under Test.

Off - No loss compensation is made after the DUT. 

Fixed - Loss Compensation is at a fixed value over the entire frequency span.

Table - Loss Compensation varies across the frequency span, using values specified in a 
table.

Loss Comp After DUT Fixed Val Sets the amount of compensation, after the device 
under test, as a fixed value. This is only valid if the After DUT (Fixed) is enabled. You 
can enter the value as dB or linear. However, the linear value is converted to dB. The 
lower limit is –100.000 dB and the upper limit is 100.000 dB. The default value is 
0.000 dB.

Loss Comp After DUT Temp Sets the temperature of loss compensation, after the 
device under test, as a fixed value. This is only valid if After DUT is enabled. You can 
enter the value as K, C, or F. However, the C and F values are converted to K. The lower 
limit is 0.00K and the upper limit is 29,650,000.00 K. The default value is 0.00K.

Before DUT Table... 

Brings up the Loss Compensation Before DUT editor.
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After DUT Table... 

Brings up the Loss Compensation After DUT editor.
Attenuation
Available in Measure > Noise Figure only.

Adjusts the input attenuation. The range of settings is limited by the Min Atten and Max 
Atten settings (see page 124). Within this range, it can be set in 4 dB steps. The N8201A 
input attenuator reduces the power level of the input signal delivered to the input mixer. 
Input/Output
Available in Measure > Noise Figure only.

Displays the functions that control some of the N8201’s signal input and outputs.
RF Coupling

CAUTION Do not switch to DC Coupling if the input signal contains a DC component. You risk 
permanently damaging the N8201A front end mixer if you do this.
Specifies alternating current (AC) or direct current (DC) coupling at the N8201A RF 
input port. Selecting AC coupling switches in a blocking capacitor that blocks any DC 
voltage present at the input. This decreases the input frequency range of the N8201A, but 
prevents damage to the input circuitry of the N8201A if there is a DC voltage present at 
the RF input.

In AC coupling mode, signals less than 20 MHz are not calibrated. You must switch to 
DC coupling to see calibrated frequencies of less than 20 MH. Note that the message DC 
Coupled will be displayed when DC is selected.

Some amplitude specifications apply only when coupling is set to DC coupling. 

RF

Selects the front panel RF port as the signal input.

Amptd Ref

Selects the 50 MHz, –25 dBm internal amplitude as the signal input.
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Marker
N8201A Noise Figure
Marker functions are available in Measure > Noise Figure mode only.

Displays a menu to set each of the four markers to mark or display a particular 
measurement.
Select Marker
Selects one of the four possible markers. Having selected one of the markers, use the 
other softkeys on this menu to specify the type of marker or measurement.
Mode
Normal

Sets the specified marker to be a normal marker. That is, it marks the point of the 
frequency offset that you specify, and then the N8201A measures and displays the phase 
noise at this point.

Delta

Activates a pair of markers at your current frequency offset. The marker that is indicated 
by an ‘R’ on the display is fixed while the second marker can be moved using the arrow 
keys or entering a value in the Position box. The frequency difference and the phase 
noise difference between these two points is displayed.

Off

Switches the specified marker off.
Marker All Off
Switches all markers off. All markers are removed from the graticule display, and if the 
marker table is also being displayed, all entries will be removed from it.
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Meas Ctrl (Control)
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These functions allow you to pause and resume the currently selected measurement and 
to select between continuous and single measurements.
Restart
Restarts a previously paused measurement at the beginning. If the current measurement 
is still in progress, it will stop it as soon as possible and restart it from the beginning.
Measure Single/Cont
Switches the N8201A between triggering a Continuous measurement/sweep or 
triggering a Single measurement. The front panel Single key also puts the N8201A in 
single measurement mode.
Pause
Pauses the currently running measurement. Pressing Pause will toggle between pausing 
and resuming the measurement. If an averaged measurement is in progress, the average 
counter is frozen when the measurement is halted.
N8201A Noise Figure Measurement Personality Guide



Front-Panel Key Reference 5
Meas Setup 
N8201A Noise Figure
Displays a menu that allows you to enter custom setup parameters for a measurement. 
The setup menu displayed depends on whether the Monitor Spectrum or the Noise 
Figure measurement was selected in the MEASURE menu. 
Avg Number
Allows you to specify the number of measurements that will be averaged. After the 
specified number of average counts, the Avg Mode setting determines the averaging 
action. You can also set the averaging function to On or Off. 

On 

Enables the measurement averaging.

Off 

Disables the measurement averaging.
Avg Mode
Selects the type of termination control used for the averaging function. This determines 
the averaging action after the specified number of measurements (average count) is 
reached.

For Measure > Noise Figure mode, Avg Mode is set to Repeat.

Exp

After the average count is reached, each successive data acquisition is exponentially 
weighted and combined with the existing average.

Repeat

After the average count is reached, the averaging is reset and a new average is started.
Calibrate
Available for Measure > Noise Figure only.

Performs the internal calibration routine. The calibration is similar to a measurement 
except that the device under test is not in the measurement path. It is used to correct any 
noise added by the second stage test system.

The values generated during a calibration are used to correct subsequent measurements 
as long as the calibration remains valid or until the next calibration.
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ENR
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Available for Measure > Noise Figure only.

Accesses a menu which allows you to select a noise source preference, enter the ENR 
(Excess Noise Ration) table, specify a Tcold temperature, specify a spot Thot temperature, 
or select a spot frequency ENR value.

Mode 

Selects the mode for measurement: Spot or Table.

Table Sets the ENR mode to Table. All ENR data is taken from the table of data.

Spot Sets the ENR mode to Spot. All ENR table data is ignored, and a single value 
specified in SPOT ENR or SPOT T hot is used instead. 

Common Table

Turns the Common ENR Data Table On or Off.

On Uses the same noise source ENR data during both the measurement and the 
calibration.

Off Uses separate noise source ENR data is used for the measurement and the 
calibration.

Meas & Cal Table

Displays the form allowing you to enter the ENR table data that is used for both 
measurement and calibration.

Serial # Specifies the serial number of the noise source associated with the ENR table. 
Use the keyboard to enter the numeric value. The value is displayed in the highlighted 
area and in the active function area. To complete the entry press Enter. 

Model ID Specifies the model number of the noise source associated with the ENR 
table. Use the keyboard to enter the value. The value is displayed in the highlighted area 
and in the active function area. To complete the entry press Enter.

Table Allows you to enter new ENR data with the associated frequencies or edit 
existing data. 

Meas Table...

Available when Common Table is Off.
N8201A Noise Figure Measurement Personality Guide



Front-Panel Key Reference 5

N8201A Noise Figure
Displays the form allowing you to enter the ENR table data that is used for 
measurement. This measurement ENR table is used for measurements when Common 
Table (see “Common Table" on page 130) is switched Off. When Common Table is 
switched On, this same table of ENR data is used both for measurements and for 
calibration.

Serial # Specifies the serial number of the noise source associated with the ENR table. 
Use the keyboard to enter a value. The value is displayed in the highlighted area and in 
the active function area. To complete the entry press Enter.

Model ID Specifies the model number of the noise source associated with the ENR 
table. Use the keyboard to enter a value. The value is displayed in the highlighted area 
and in the active function area. To complete the entry press Enter.

Table Allows you to enter new ENR data with the associated frequencies or edit 
existing data. 

Cal Table...

Available when Common Table is Off.

Displays the form allowing you to enter the ENR table data that is used for calibration. 
This calibration ENR table is used for calibration when Common Table (see “Common 
Table" on page 130) is switched Off. When Common Table is switched On, the table of 
ENR data that is used for measurements will also be used for calibration, and the data in 
this calibration table will therefore not be used.

Serial # Specifies the serial number of the noise source associated with the ENR table. 
Use the keyboard to enter a value. The value is displayed in the highlighted area and in 
the active function area. To complete the entry press the Return key or the ESC key, or 
use the Tab key to move to the next field.

Model ID Specifies the model number of the noise source associated with the ENR 
table. Use the keyboard to enter a value. The value is displayed in the highlighted area 
and in the active function area. To complete the entry press the Return key or the ESC 
key, or use the Tab key to move to the next field.

Table Allows you to enter new ENR data with the associated frequencies or edit 
existing data. 

Spot

Sets a single value for SPOT ENR or SPOT T hot.

Spot State Sets the Spot State to either ENR or T hot.

Spot ENR Sets the amplitude of the ENR Spot 
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Spot T hot Sets the T hot temperature. T hot is the virtual temperature that the noise 
source is operating at when turned on.

T cold Default/User

Sets the T cold temperature. T cold is the ambient temperature that the noise source is 
operating at when the noise source is turned off.

Available for Measure > Noise Figure only.
Int Preamp
Turns the internal preamplifier On or Off manually. 

For Monitor Spectrum mode, Internal Preamp is set to On. For Noise Figure mode, 
Internal Preamp is set to off.
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MEASURE
N8201A Noise Figure
Accesses menu keys that allow you to make Monitor Spectrum, and Noise Figure 
measurements.
Monitor Spectrum 
Displays the frequency spectrum and gives access to the functions associated with 
making a frequency spectrum measurement.
Noise Figure
Gives you access to the range of Noise Figure measurements and parameters.
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MODE 
134
Accesses menu keys allowing you to select the measurement mode of the N8201A. 
Additional measurement personality software must be installed and activated in the 
N8201A for the other mode keys to be labeled and functional. 
Spectrum Analysis
Accesses the spectrum analyzer menu keys and associated functions.
Noise Figure
Accesses the Noise Figure measurement personality menu keys and associated 
functions. This allows you to setup and make valid Noise Figure measurements.

This menu will have additional entries if other personalities have been installed, for 
example, Phase Noise.
N8201A Noise Figure Measurement Personality Guide



Front-Panel Key Reference 5
Mode Setup 
N8201A Noise Figure
Accesses a menu allowing you to view information about the Noise Figure application 
and to set the noise figure measurement parameters back to their factory default settings.
DUT Setup...
Allows you to prepare the N8201A to make noise figure measurements on specific 
devices. The keys you will see depend on the parameter that you are setting.

DUT

Specifies the type of DUT that you are testing.

Amplifier Sets the DUT to Amplifier when you are testing a device that performs no 
frequency conversion of its own. The device can be used with or without an external 
system downconverter.

UpConv Sets the DUT to upconverter when you are testing a device that performs 
internal frequency up conversion.

DownConv Sets the DUT to downconverter when you are testing a device that 
performs internal frequency down conversion.

System Downconverter On/Off

Selects whether or not the System Downconverter is On or Off. This is only accessible if 
the Device Under Test is set to Amplifier. See above.

Ext LO Freq

Specifies the LO frequency of the device specified under DUT at 30 GHz.

Sideband

Sets the measurement side-band selection to either lower side-band (LSB), Upper 
side-band (LSB), or Double side-band (DSB). 

Freq Context

Determines how frequencies are interpreted when using a frequency converting device.

RF DUT Input The frequencies are displayed as they are when leaving the DUT or the 
system downconverter, that is after any frequency conversion has taken place. These are 
the frequencies that the N8201A is actually measuring.

IF Analyzer Input The frequencies are displayed as they are when entering the DUT, 
that is before any frequency conversion has taken place.
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Uncertainty Calculator
136
Displays the Uncertainty Calculator. This makes a frequency-independent calculation 
using one ENR uncertainty value. While it provides a good estimation of the 
measurement uncertainty, you may want more accuracy. You may want to use more 
accurate values for ENR, gain and VSWR, or calculate values at a specific frequency of 
interest or at multiple frequencies.

Refer to Application Note 57-2, Agilent part number 5952-3706E, for more information 
about calculating noise figure uncertainties. This document can be found at: 
http://literature.agilent.com/litweb/pdf/5952-3706E.pdf. Refer also to Application Note 
57-3, Agilent part number 5980-0288E, for hints for making successful noise figure 
measurements. This document can be fount at 
http://literature.agilent.com/litweb/pdf/5980-0288E.pdf.

RSS NF Meas Uncertainty

Sets the Root Sum of Squares measurement uncertainty to 4 dB. 

Noise Source Model

Selects a predefined noise source model using the displayed default values, or allows 
you to define your own noise source.

User Defined Defines a noise source, and allows you to specify its parameters 
manually.

Agilent 346A Selects Agilent 346A if you are using an Agilent Technologies 346A 
noise source. The ENR uncertainty and match for this noise source will be set 
automatically.

Agilent 346B Select Agilent 346B if you are using an Agilent Technologies 346B 
noise source. The ENR uncertainty and match for this noise source will be set 
automatically.

Agilent 346C Select Agilent 346C if you are using an Agilent Technologies 346C 
noise source. The ENR uncertainty and match for this noise source will be set 
automatically.

ENR Uncertainty

Sets and views the Excess Noise Ratio (ENR) Uncertainty of the noise source.

Match

Sets and views the 50 ohm Match of the User Defined noise source. The match can be 
entered as Return Loss, VSWR, or as a Reflection Co-efficient. You do not need to 
specify the unit of measurement, if any. The value you enter is used to determine the 
what the entry is, as described below:
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N8201A Noise Figure
A value less than 0 Return Loss, unit of measurement is dB.

A value greater than or equal to 0 and less than 1 Reflection coefficient, no unit of 
measurement.

A value greater than or equal to 1 VSWR, no unit of measurement.

DUT Noise Figure

Sets the noise figure of the DUT. 

DUT Gain

Sets the gain of the DUT.

DUT Input Match

Sets the 50 ohm input match of the DUT. 

DUT Output Match

Sets the 50 ohm output match of the DUT.

Instrument Noise Figure

Sets the noise figure of the N8201A.

Instrument NF Uncertainty

Sets the noise figure uncertainty of the N8201A.

Instrument Gain Uncertainty

Sets the gain uncertainty of the N8201A.

Instrument Input Match

Sets the instrument input match.
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Peak Search
138
Places a marker on the highest peak and displays the search menu. Peaks that are less 
than 1% of the current span away from 0 Hz are ignored. For example, if Span is 1 MHz, 
peaks will not be found between –10 kHz and +10 kHz. If no valid peak is found, an 
error (No Peak Found) is displayed. To clear this message, press ESC before attempting 
another search.
Minimum
Moves the active marker to the minimum detected amplitude value on the current trace.
Maximum
Moves the active marker to the maximum detected amplitude value on the current trace.
Pk-Pk
Finds and displays the amplitude and frequency differences between the highest and 
lowest trace points by setting a reference marker on the peak signal and placing a ⊗ 
marker on the minimum signal.
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Preset 
N8201A Noise Figure
Provides a convenient starting point for making most measurements. 

The parameter settings depend on the preset type (user, mode, or factory) selected from 
the System keys. If the preset type is set to Factory, pressing Preset results in an 
immediate N8201A preset to the factory defaults. If it is set to User, pressing Preset 
accesses a menu that allows you choose the preset settings from either the factory default 
values or the settings you have previously defined as the User preset state. Refer to 
“Power On/Preset" on page 143.
User Preset
Restores the N8201A to a user defined state. The state was defined from the System 
menu when the Power On/Preset function was selected and Save User Preset was 
pressed. If you did not save a user state, then the current power-up state is stored as the 
user preset file for use when Preset is pressed.
Factory Preset
A full factory preset is executed so the N8201A is returned to the factory default state. 
The preset type can be set to Factory from the Power On/Preset function in the System 
menu.
Mode Preset
Restores the mode defaults of the current mode, or of the mode that was in use when the 
N8201A was turned off or powered down. 
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Source 
140
Source is only available in Measure > Monitor Spectrum mode.

Allows you to turn the noise source On or Off manually. 
Noise Source
Toggles between the On and the Off settings.

On

Switches the noise source On.

Off

Switches the noise source Off.
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SPAN X Scale 

Span
N8201A Noise Figure
Sets the frequency range symmetrically about the center frequency.
Full Span
Full Span is only available in Measure > Monitor Spectrum mode.

Changes the measurement span to the full span of the N8201A. 
Zero Span
Zero Span is only available in Measure > Monitor Spectrum mode.

Changes the measurement span to 0 Hz.
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Sweep 

Sweep Time
142
Specifies the sweep time for the measurement or allows the N8201A set it automatically. 
For a Noise Figure measurement, the sweep time is set to a predefined value based on 
the RBW setting.

Manual

Adjusts the sweep time manually using the keyboard.

Auto

Determines the sweep time automatically. The sweep time will be affected by the RBW 
setting.
Sweep
Specifies whether the N8201A sweeps (or measures) continually, or whether it performs 
a single sweep and then stops. 

Single

Performs one single measurement and then stops. You have to press Single every time 
you want to make another measurement.

Cont

Continuously measures the signal it is receiving and repeatedly updates the plots and the 
measurements.
Points
Points is only available in Measure > Monitor Spectrum mode.

Specifies the number of data points used to generate the display. 
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System
N8201A Noise Figure
Displays the System menu keys to control overall system functions. 
Show Errors
Accesses a menu to display the last several errors reported. The most recent error will 
appear at the top of the list. If the same error message occurs several times the error 
message will be incremented rather than added to the list as a new error message. 

Update Error List

When On, the error list will be updated with new errors.

Verbose SCPI

Adds additional information to the error messages returned by the SYSTem:ERRor? 
command. It indicates which remote command was executing when the error occurred 
and what about that command was unacceptable. 

Clear Error Queue

Clears the error queue from the Show Errors display.
Power On/Preset
Determines the state of the instrument when the power is first turned on.

Power On Last/Preset

Sets the power On state to the last instrument settings used before power Off, or to the 
instrument preset state, which is determined by the Preset Type as described below.

Preset Type

Enables you to select what type of preset will be initiated when you select the Preset 
front panel key.

User Sets the preset state to the user-defined settings. If you have not saved a user 
state, then the instrument will save the power-up state for you to use as a default user 
preset state.

Mode Sets the preset state to the current mode factory default instrument state.

Factory Restores the factory default instrument state. A factory preset switches the 
N8201A to Spectrum Analyzer mode and resets the settings of all the modes to the 
factory defaults (That is, Spectrum Analysis Mode with continuous sweep). 
 Measurement Personality Guide 143



144

5 Front-Panel Key Reference
Save User Preset

Saves the current state of the N8201A into the User Preset state register. After the state is 
saved, go to System, Power On/Preset, Preset Type, User in order to have this state used 
as the preset state. 
Time/Date
Displays the menu keys used to set and display the real-time clock.

Time Date On/Off

Turns the display of the real time clock on or off.

Date Format MDY/DMY

Sets the date display to month-day-year or day-month-year. It is set to a month-day-year 
format when the instrument system defaults are restored. 

Set Time

Sets the time of the real-time clock. Enter the time in 24 hour HHMMSS format.

Set Date

Sets the date of the real-time clock. Enter the date in the YYYYMMDD format.
Alignments
Displays functions that control the automatic alignment of the instrument and loads 
default values for the alignment system. 
Auto Align

Turns the instrument automatic alignment on or off, or alerts you that alignments are 
needed.

On Initiates an automatic alignment.

Alert Notifies you when an automatic alignment needs to be run. A 3 degree (Celsius) 
temperature change or a time span of 24 hours since the last successful alignment will 
trigger an alert that alignments need to be done, but no alignments will be performed 
without user input. 

Off The instrument will not initiate any visible alignments or alerts.
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N8201A Noise Figure
Align All Now

Immediately executes an alignment cycle of all the subsystems (that is Align RF, Align 
IF, Align ADC, and Align Current Sys Gain). The instrument will stop any measurement 
currently underway, perform the full alignment, then restart the measurement from the 
beginning (similar to pressing the Restart key). All other operations are stopped and the 
alignments will be visible on the display.

Align Subsys

Access the functions to immediately execute an alignment of one of the subsystems (that 
is, Align RF, Align IF, Align ADC, and Align Current Sys Gain). When one of the 
subsystem alignments is started all other operations are stopped.

Align RF Initiates an alignment of the RF assembly.

Align IF  Initiates an alignment of the IF assembly.

Align ADC Initiates an alignment of the ADC circuitry.

Align Current IF Flatness Initiates an alignment of the current IF flatness, for the 
purpose of improving absolute amplitude within FFT sweeps and improving group delay 
in some digital demodulation measurements.

Align Current Sys Gain Initiates a fine-tuning adjustment of the system gain, 
primarily to correct for small amplitude variations that occur as resolution bandwidth is 
switched.

Restore Align Defaults

Loads the default values for the alignment system, turns on the frequency correction, and 
resets the timebase to the factory values. Align All Now must be executed three times 
after initiating a Restore Alignments Defaults function to meet specifications.
Restore System Defaults
Resets the system settings, including most “persistent” functions, to their factory 
defaults. Persistent functions are things such as the time/date display style and 
auto-alignment state. These are parameters that are unaffected by a power cycle or an 
instrument preset.

It also performs a Factory Preset that resets the N8201A to the Spectrum Analysis Mode. 
It does not reset user data such as saved instrument states.
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Trace/View 
146
Trace/View functions are only available in Measure > Noise Figure mode.

Accesses the View and Trace menu keys that allow you to set and view the measurement 
result information. The menu options will vary depending on the measurement that is 
selected under the Measure menu. 
View 
Graph

Displays the measurement results in the form of a graph.

Table

Displays the measurement results in the form of a table.

Meter

Displays the measurement results in the form of a textual display.
Combined
When you have chosen to view the measurement results in the form of a Graph, you can 
refine the view further by choosing either to combine the results in one graph, or to 
display the results in two separate graphs.

On

Select On to combine the measurement results in one graph on the display.

Off

Select Off to display the measurement results in two separate graphs on the display.
Display
Displays the two graphs at the same time, or either one separately.

Both

Displays both measurement graphs in the display window.

A Only

Displays graph A in the display window.
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N8201A Noise Figure
B Only

Displays graph B in the display window.
Result A
Determines the type of measurement result to be displayed in the upper graph window in 
Graph view, and in the left hand column in the Table and Meter views. The type of 
measurement result can be selected from the following list:

Noise Figure

Selects Noise Figure as the measurement result, and dB as the unit of measurement.

Noise Factor 

Selects Noise Factor as the measurement result, which is a unitless measurement.

Gain

Selects Gain as the measurement result.

Y-Factor

Selects Y-Factor as the measurement result.

T effective

Selects equivalent temperature as the measurement result.

P hot

Selects hot power density as the measurement result.

P cold

Selects cold power density as the measurement result.
 Measurement Personality Guide 147



5 Front-Panel Key Reference
Result B

NOTE Noise Factor measurements lack a unit of measurement as the results represent the ratio of 
two ratios, that is, they represent the ratio of the signal to noise ratio at the input signal to 
the signal to noise ratio at the output. Ref Level and Scale/Div values can still be entered in 
dB, but these values will be converted to linear values, and displayed in the results 
graph/table as linear values.

Conversely, Noise Figure, Gain, Y-Factor, Phot, and Pcold all use dB as the unit of 
measurement, but Scale/Div and Ref Level can all be entered as a unitless ratio. This ratio 
will be automatically converted to dB for display in the Graph, Table or Meter views.

T effective results are always displayed in Kelvin. For T effective measurements, Scale/Div 
and Ref Level can be entered in Celsius (C) or Fahrenheit (F), but will be converted to Kelvin 
for display in the Graph, Table or Meter views.
148
Determines the type of measurement result to be displayed in the lower graph window in 
Graph view, and in the right hand column in the Table Meter views. The type of 
measurement result can be selected from the following list:

Noise Figure

Selects Noise Figure as the measurement result. 

Noise Factor 

Selects Noise Factor as the measurement result, which is a unitless measurement

Gain

Selects Gain as the measurement result.

Y-Factor

Selects Y-Factor as the measurement result.

T effective

Selects equivalent temperature as the measurement result.

P hot

Selects hot power density as the measurement result.

P cold

Selects cold power density as the measurement result.
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NOTE Noise Factor measurements lack a unit of measurement as the results represent the ratio of 
two ratios, that is, they represent the ratio of the signal to noise ratio at the input signal to 
the signal to noise ratio at the output. Ref Level and Scale/Div values can still be entered in 
dB, but these values will be converted to linear values, and displayed in the results 
graph/table as linear values.

Conversely, Noise Figure, Gain, Y-Factor, Phot, and Pcold all use dB as the unit of 
measurement, but Scale/Div and Ref Level can all be entered as a unitless ratio. This ratio 
will be automatically converted to dB for display in the Graph, Table or Meter views.

T effective results are always displayed in Kelvin. For T effective measurements, Scale/Div 
and Ref Level can be entered in Celsius (C) or Fahrenheit (F), but will be converted to Kelvin 
for display in the Graph, Table or Meter views.
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Trig
150
Displays menu keys for selecting the trigger mode of a sweep or measurement. When in 
a trigger mode other than Free Run, the N8201A will begin a sweep only with the proper 
triggering condition. 
Trigger
Accesses a menu of trigger modes.

Free Run

Sets the trigger to start a new sweep as soon as the last one has ended (continuous sweep 
mode) or immediately (single sweep mode).

Video

Activates the trigger condition that allows the next sweep to start if the detected RF 
envelope voltage crosses a level set by the video trigger level. When Video is pressed, a 
line appears on the display. The N8201A triggers when the input signal exceeds the 
trigger level at the left edge of the display. The line remains on the display as long as 
video trigger is the trigger type.

Line

Sets the trigger to start a new sweep to be synchronized with the next cycle of line 
voltage.

Trigger In

Sets the trigger to start a new sweep whenever the external voltage (connected to the 
front panel Trigger In) passes through approximately 1.5 V.

RF Burst

Sets the trigger to start by an RF burst envelope signal.
Trig Slope
Sets the trigger polarity to positive to trigger on the rising edge, or negative to trigger on 
the falling edge.
Trig Delay
Sets the trigger delay to Off.
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NOTE Trigger Delay is not available in Free Run mode, so turning Free Run on turns off Trigger 
Delay, but preserves the value of Trigger Delay.
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Agilent N8201A  Performance Downconverter
Noise Figure Measurement Personality Guide
6
Language Reference

These commands are only available when the Noise Figure mode has been selected 
using INSTrument:SELect NFIGURE or INSTrument:NSELect 219. If the Noise Figure 
mode is selected, commands that are unique to another mode are not available.
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CALCulate Subsystem
154
This subsystem is used to perform post-acquisition data processing. In effect, the 
collection of new data triggers the CALCulate subsystem. In this instrument, the primary 
functions in this subsystem are markers and limits.

The SCPI default for data output format is ASCII. The format can be changed to binary 
with FORMat:DATA which transports faster over the bus.
Test Current Results Against all Limits 
:CALCulate:CLIMits:FAIL?

Queries the status of the current measurement limit testing. It returns a 0 if the measured 
results pass when compared with the current limits. It returns a 1 if the measured results 
fail any limit tests.
Noise Figure Measurement

Noise Figure—Number of Points on a Limit Line
:CALCulate[:NFIGure]:LLINe[1]|2|3|4:COUNT?

Queries and returns the number of sets of points in the selected limit line. One set of 
points comprises a frequency value (in Hz), an amplitude limit value (unitless), and a 1 
or a 0 determining connectivity to the previous point.

Factory Preset: 2

Range: 0 - 101 point-sets.

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Display, Limits, Limit Line, Edit...
Noise Figure—Specifying Point Values for a Limit Line
:CALCulate[:NFIGure]:LLINe[1]|2|3|4[:DATA] 
<frequency>,<amplitude>,<connected>[<frequency>,<amplitude>, 
<connected>]

:CALCulate[:NFIGure]:LLINe[1]|2|3|4[:DATA]?

Specifies the limit line values.
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N8201A Noise Figure
The amplitude values of the limit lines have no units of their own. Instead they take on 
the units of the graph to which the limit line is applied. If the units of the graph are 
changed then the limit line values take on the new units without rescaling.

<frequency> - is a frequency in Hz. Frequency values do not allow units (for instance, 
MHz) to be specified. They are always in Hz.

<ampl> - amplitude values are unitless.

<connected> - connected values are either 0 or 1. A 1 means this point is connected to 
the previously defined point to define the limit line. A 0 means this is a point of 
discontinuity and is not connected to the preceding point.

Limit lines 1 and 2 apply to the trace that is displayed in the upper graph. Limit lines 3 
and 4 apply to the trace that is displayed in the lower graph.

Factory Preset: 10,0,1,2.65e+10,0,1

Range: 0 - 101 point-sets.

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Display, Limits, Limit Line, Edit...
Noise Figure—Limit Line Display Control
:CALCulate[:NFIGure]:LLINe[1]|2|3|4:DISPlay[:STATe] OFF|ON|0|1

:CALCulate[:NFIGure]:LLINe[1]|2|3|4:DISPlay[:STATe]?

Turns the display of a limit line On or Off. Limit line checking still occurs even when the 
limit line display has been turned off.

Factory Preset: On

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode. A Limit Line Display State of On will 
be overridden if the Limit Line State is set to Off.

Front Panel Access: Display, Limits, Limit Line, Edit...
Noise Figure—Limit Line State Control
:CALCulate[:NFIGure]:LLINe[1]|2|3|4[:STATe] OFF|ON|0|1

:CALCulate[:NFIGure]:LLINe[1]|2|3|4[:STATe]?
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Turns the limit line state On or Off. When the limit line state (this command) is Off, both 
the display and the testing of the limit line are disabled, regardless of their individual 
ON|OFF settings. When the limit line state is set to On, the display and the testing of the 
limit line are both enabled, and their individual ON|OFF settings then come into effect.

Factory Preset: Off

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Display, Limits, Limit Line, Edit...
Noise Figure—Limit Line Test Control
:CALCulate[:NFIGure]:LLINe[1]|2|3|4:TEST[:STATe] OFF|ON|0|1

:CALCulate[:NFIGure]:LLINe[1]|2|3|4:TEST[:STATe]?

Turns the limit line trace testing On or Off for the specified limit line.

Factory Preset: Off

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode. A Limit Line Test State of On will be 
overridden if the Limit Line State is set to Off.

Front Panel Access: Display, Limits, Limit Line, Edit...
Noise Figure—Limit Line Type Control
:CALCulate[:NFIGure]:LLINe[1]|2|3|4:TYPE UPPer|LOWer

:CALCulate[:NFIGure]:LLINe[1]|2|3|4:TYPE?

Sets the limit line type. An upper limit line defines the maximum allowable value when 
comparing with the data, and a lower limit line defines the minimum allowable value.

Factory Preset: UPPer

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Display, Limits, Limit Line, Edit...
N8201A Noise Figure Measurement Personality Guide



Language Reference 6
Noise Figure—Marker Band Pair Mode
N8201A Noise Figure
:CALCulate[:NFIGure]:MARKer[1]|2|3|4:BPAir:MODE NORMal:REFerence

:CALCulate[:NFIGure]:MARKer[1]|2|3|4:BPAir:MODE?

Specifies which marker within a pair of linked markers (the band pair) is to be controlled 
using the Marker Position scroll bar.

Factory Preset: NORMal

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Marker, Mode, Delta
Noise Figure—Marker Mode
:CALCulate[:NFIGure]:MARKer[1]|2|3|4:MODE POSition|DELTa|BPAir

:CALCulate[:NFIGure]:MARKer[1]|2|3|4:MODE?

Sets the marker mode for the specified marker. The three valid marker modes are:

Normal (POSition)

Activates a single marker on the displayed traces. The marker’s number is displayed 
above the marker on the display. The marker’s position can be changed using the 
keyboard. The marker’s amplitudes are updated automatically.

DELTa

Activates a pair of delta markers on the displayed traces. Once you activate the DELTa 
markers, the position of the reference marker is fixed. Only the position of the delta 
marker can be changed.

Band Pair (BPAir)

Activates a pair of delta markers on the displayed traces. When band pair (BPAir) 
markers are activated, both the reference marker’s position and the delta marker’s 
position can be changed.

Factory Preset: OFF

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Marker
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Noise Figure—Marker Search Continuous
158
:CALCulate[:NFIGure]:MARKer[1]|2|3|4:SEARch:CONTinuous OFF|ON|0|1

:CALCulate[:NFIGure]:MARKer[1]|2|3|4:SEARch:CONTinuous?

Searches continuously for maximum, minimum, or peak-to-peak points for the current 
marker. When set to On, a peak search is performed after every measurement sweep.

Factory Preset: OFF

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Peak Search
Noise Figure—Marker Search Type
:CALCulate[:NFIGure]:MARKer[1]|2|3|4:SEARch:TYPE MAXimum|MINimum|PEAK

:CALCulate[:NFIGure]:MARKer[1]|2|3|4:SEARch:TYPE?

Specifies the type of search performed by the specified marker. The three valid types of 
search are:

MAXimum

Searches for and finds the highest peak on the trace. This is not valid when the marker 
mode is set to Band Pair.

MINimum

Searches for and finds the lowest trough on the trace. This is not valid when the marker 
mode is Band Pair

PEAK

When a peak search is performed, the Band Pair markers are placed on the highest and 
the lowest points of the trace. The reference marker is placed on the highest point of the 
trace, and the delta marker on the lowest.

Factory Preset: MAXimum

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

All of these searches can be made continuous by switching Continuous to ON (See 
“Noise Figure—Marker Search Continuous" on page 158.), or by repeatedly pressing the 
‘Find...’ softkey.
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Front Panel Access: Peak Search
Noise Figure—Marker State
:CALCulate[:NFIGure]:MARKer[1]|2|3|4:[:STATe] OFF|ON|0|1

:CALCulate[:NFIGure]:MARKer[1]|2|3|4:[:STATe]?

Turns the specified marker On or Off.

Factory Preset: 

• Marker 1 - On

• Markers 2, 3, and 4 - Off

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Marker
Noise Figure—Marker X Position
:CALCulate[:NFIGure]:MARKer[1]|2|3|4:X <freq>

:CALCulate[:NFIGure]:MARKer[1]|2|3|4:X?

Sets the X-axis position of the specified marker on the trace. When setting the X-axis 
position, the unit of measurement is assumed to be Hz unless you specify otherwise. 
When querying the X-axis position, the result is always returned in Hz.

Factory Preset: None

Range: Same as the measurement range

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Peak Search
Noise Figure—Marker Y Position
:CALCulate[:NFIGure]:MARKer[1]|2|3|4:Y?

Returns two comma-separated values representing the current marker’s positions on the 
two traces. Each value is in the Y-axis unit of the relevant trace.

Factory Preset: None
 Measurement Personality Guide 159



160

6 Language Reference
Range: Same as the measurement range

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: TAB (until the marker table becomes visible)
Noise Figure—DUT Gain
:CALCulate:UNCertainty:DUT:GAIN <value>

:CALCulate:UNCertainty:DUT:GAIN?

Specifies the measured gain of the device under test (DUT).

Factory Preset: 20.00 dB

Range: –100 dB to 100 dB

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Mode Setup, Uncertainty Calculator...
Noise Figure—DUT Input Match
:CALCulate:UNCertainty:DUT:MATCh:INPut <value>

:CALCulate:UNCertainty:DUT:MATCh:INPut?

Specifies the measured Input Match of the DUT.

Factory Preset: 1.500

Range: –100 to 100

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode. 

The unit of measurement, which can be dB, VSWR (Voltage Standing Wave Ratio) or 
Reflection Coefficient, is calculated from the input value.Negative values are assumed to 
be return loss in dB, values equal to or greater than 1 represent VSWR, and values 
greater than or equal to zero and less than 1 represent the reflection coefficient.

Front Panel Access: Mode Setup, Uncertainty Calculator...
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:CALCulate:UNCertainty:DUT:MATCh:OUTPut <value>

:CALCulate:UNCertainty:DUT:MATCh:OUTPut?

Specifies the measured Output Match of the DUT.

Factory Preset: 1.500

Range: –100 to 100

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

The unit of measurement, which can be dB, VSWR (Voltage Standing Wave Ratio) or 
Reflection Coefficient, is determined by the input value. Negative values are assumed to 
be return loss in dB, values equal to or greater than 1 represent VSWR, and values 
greater than or equal to zero and less than 1 represent the reflection coefficient.

Front Panel Access: Mode Setup, Uncertainty Calculator...
Noise Figure—DUT Noise Figure
:CALCulate:UNCertainty:DUT:NFIGure <value>

:CALCulate:UNCertainty:DUT:NFIGure?

Specifies the measured Noise Figure of the Device Under Test (DUT).

Factory Preset: 3.0 dB

Range: –100 dB to 100 dB

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Mode Setup, Uncertainty Calculator...
Noise Figure—Instrument Gain
:CALCulate:UNCertainty:INSTrument:GAIN <value>

:CALCulate:UNCertainty:INSTrument:GAIN?

Specifies the gain of the N8201A. The Instrument Gain is set by default to pre-calculated 
values of 0.17 dB.
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Factory Preset: - 0.17 dB

Range:  –100 dB to 100 dB

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Mode Setup, Uncertainty Calculator...
Noise Figure—Instrument Match
:CALCulate:UNCertainty:INSTrument:MATCh <value>

:CALCulate:UNCertainty:INSTrument:MATCh?

Specifies the measured Match of the N8201A. The Instrument Match is set by default to 
a pre-calculated VSWR value of 1.60 f.

Factory Preset: 1.6000

Range: –100 to 100

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

The unit of measurement, which can be dB, VSWR (Voltage Standing Wave Ratio) or 
Reflection Coefficient, is determined by the input value. Negative values are assumed to 
be return loss in dB, values equal to or greater than 1 represent VSWR, and values 
greater than or equal to zero and less than 1 represent the reflection coefficient.

Front Panel Access: Mode Setup, Uncertainty Calculator...
Noise Figure—Instrument Noise Figure
:CALCulate:UNCertainty:INSTrument:NFIGure <value>

:CALCulate:UNCertainty:INSTrument:NFIGure?

Specifies the measured Noise Figure of the N8201A. The default settings are 6.0 dB. 
More appropriate values can be found in the relevant specifications guides.

Factory Preset: 6.0 dB

Range: –100 dB to 100 dB

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.
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Front Panel Access: Mode Setup, Uncertainty Calculator...
Noise Figure—Instrument Noise Figure Uncertainty
:CALCulate:UNCertainty:INSTrument:NFIGure:UNCertainty <value>

:CALCulate:UNCertainty:INSTrument:NFIGure:UNCertainty?

Specifies the measured Noise Figure Uncertainty of the N8201A. The default setting of 
0.05 dB is good for most measurements.

Factory Preset: 0.05 dB

Range: –100 dB to 100 dB

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Mode Setup, Uncertainty Calculator...
Noise Figure—RSS Uncertainty
:CALCulate:UNCertainty:RSS?

Queries and returns the Root Sum Squared (RSS) Uncertainty value. The RSS 
Uncertainty value, expressed in dB, is a measure of the overall uncertainty of your noise 
figure measurement. It is calculated from all the individual uncertainty parameters 
known to the N8201A. An indicated RSS Uncertainty value of x dB means that your 
measurement’s uncertainty is ± x dB.

Factory Preset: Calculated

Range: Any positive value < 100 dB

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Mode Setup, Uncertainty Calculator...
Noise Figure—Noise Source ENR Uncertainty
:CALCulate:UNCertainty:SOURce:ENR <value>

:CALCulate:UNCertainty:SOURce:ENR?

Sets the Excess Noise Ratio (ENR) Uncertainty of your noise source.
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Factory Preset: 0.20 dB

Range: –100 dB to 100 dB

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

The ENR Uncertainty can only be modified when your noise source is User Defined. For 
greatest accuracy, set your noise source to User Defined, and enter the value specific to 
your noise source.

Front Panel Access: Mode Setup, Uncertainty Calculator...
Noise Figure—Noise Source Match
:CALCulate:UNCertainty:SOURce:MATCh <value>

:CALCulate:UNCertainty:SOURce:MATCh?

Sets the Match of your noise source.

Factory Preset: 1.1500

Range: –100 to 100

Remarks: 

You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

The unit of measurement, which can be dB, VSWR (Voltage Standing Wave Ratio) or 
Reflection Coefficient, is determined by the input value. Negative values are assumed 
to be return loss in dB, values equal to or greater than 1 represent VSWR, and values 
greater than or equal to zero and less than 1 represent the reflection coefficient.

The Noise Source Match can only be modified when your noise source is User 
Defined. 

Front Panel Access: Mode Setup, Uncertainty Calculator...
Noise Figure—Noise Source Match
:CALCulate:UNCertainty:SOURce:TYPE <value>

:CALCulate:UNCertainty:SOURce:TYPE?
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Specifies the type of noise source you will be using for your measurements. The three 
pre-defined noise sources, Agilent Technologies’ models 346A, 346B and 346C have 
pre-defined match and uncertainty figures which cannot be changed. Only by selecting a 
source type of USER (user defined) can you change the match and uncertainty figures.

Factory Preset: 346B

Range: USER|346A|346B|346C

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Mode Setup, Uncertainty Calculator...
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CONFigure Subsystem
166
The CONFigure commands are used with several other commands to control the 
measurement process. The full set of commands is described in the section “MEASure 
Group of Commands" on page 189.

Selecting measurements with the CONFigure/FETCh/MEASure/READ commands sets 
the instrument state to the defaults for that measurement and to make a single 
measurement. Other commands are available for each measurement to allow you to 
change: settings, view, limits, etc. Refer to:

SENSe:<measurement>, SENSe:CHANnel, SENSe:CORRection, SENSe:DEFaults, 
SENSe:DEViation, SENSe:FREQuency, SENSe:PACKet, SENSe:POWer, 
SENSe:RADio, SENSe:SYNC

CALCulate:<measurement>, CALCulate:CLIMits

DISPlay:<measurement>

TRIGger

The INITiate[:IMMediate] or INITiate:RESTart commands will initiate the taking of 
measurement data without resetting any of the measurement settings that you have 
changed from their defaults.
Configure the Selected Measurement 
:CONFigure:<measurement>

A CONFigure command must specify the desired measurement. It will set the 
instrument settings for that measurement’s standard defaults, but should not initiate the 
taking of data. The available measurements are described in the MEASure subsystem.

If CONFigure initiates the taking of data, the data should be ignored. Other SCPI 
commands can be processed immediately after sending CONFigure. You do not need to 
wait for the CONF command to complete this 'false' data acquisition.
Configure Query 
:CONFigure? 

The CONFigure query returns the name of the current measurement.
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The DISPlay controls the selection and presentation of textual, graphical, and TRACe 
information. Within a DISPlay, information may be separated into individual WINDows.
Full Screen Display 
:DISPlay:FSCReen[:STATe] OFF|ON|0|1

:DISPlay:FSCReen[:STATe]?

For Noise Figure Mode only:

:DISPlay:FSCREEN|FULLSCREEN[:STATe] ON|OFF|1|0

:DISPlay:FSCREEN|FULLSCREEN[:STATe]?

When the full screen function is activated, the measurement window expands 
horizontally over the entire instrument display. That is, it turns off the display of the 
softkey labels. Pressing any other key that results in a new menu will cancel the full 
screen function.

State Saved: Not saved in state.

Factory Preset: Off

Factory Default: Off

Front Panel Access: None

Example: DISP:FSCR ON
Set the Display Line Level 
:DISPlay:MONitor:WINDow:TRACe:Y:DLINe <power>

:DISPlay:MONitor:WINDow:TRACe:Y:DLINe?

Sets the vertical position of the display line.

Factory Preset: –25 dBm

Range: –170 dBm to 30 dBm

Default Unit: dBm 
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Remarks: You must be in Noise Figure to use this command. Use 
:INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: When in Monitor Spectrum measurement, Display
Set the Display Line State 
:DISPlay:MONitor:WINDow:TRACe:Y:DLINe:STATe ON|OFF|1|0

:DISPlay:MONitor:WINDow:TRACe:Y:DLINe:STATe?

Enables or disables the display line.

Factory Preset: OFF

Remarks: You must be in Noise Figure to use this command. Use 
:INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Display > Limits 
Set the Y-Axis Scale per Division 
:DISPlay:MONitor:WINDow:TRACe:Y[:SCALe]:PDIVision <dB>

:DISPlay:MONitor:WINDow:TRACe:Y[:SCALe]:PDIVision?

Sets the Y-axis scale per division.

Factory Preset: 10 dB

Range: 0.1 dB to 20 dB

Remarks: You must be in Noise Figure to use this command. Use 
:INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Amplitude > Scale/Div
Set the Reference Level 
:DISPlay:MONitor:WINDow:TRACe:Y[:SCALe]:RLEVel <dB>

:DISPlay:MONitor:WINDow:TRACe:Y[:SCALe]:RLEVel?

Sets the amplitude reference level for the Y-axis. The reference level is the amplitude 
power represented by the top graticule on the display.

Factory Preset: 
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With no pre-amp present: –20 dBm

With pre-amp (either On or Off): –50 dBm (automatically adjusted according to 
power)

Range: 

Without pre-amp, or pre-amp OFF: –170 dBm to 30 dB

With pre-amp ON: –170 dBm to –10 dBm

Remarks: You must be in Noise Figure to use this command. Use 
:INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: When in Monitor Spectrum measurement, Amplitude
Set Display Annotation On/Off 
:DISPlay[:NFIGure]:ANNotation[:STATe] ON|OFF|1|0

:DISPlay[:NFIGure]:ANNotation[:STATe]?

Turns the display of the annotation on or off.

Factory Preset: ON

Remarks: You must be in Noise Figure to use this command. Use 
:INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Display, Preferences
Date and Time Display 
:DISPlay[:NFIGure]:ANNotation:CLOCk:DATE:FORMat MDY|DMY

:DISPlay[:NFIGure]:ANNotation:CLOCk:DATE:FORMat?

Allows you to set the format for displaying the real-time clock. To set the date time use 
 :SYSTem:DATE <year>,<month>,<day>.

Factory Preset: DMY

Remarks: This parameter is persistent, which means that it retains the setting 
previously selected, even through a power cycle.

Front Panel Access: System, Time/Date, Date Format MDY DMY
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Date and Time Display 
170
:DISPlay[:NFIGure]:ANNotation:CLOCk[:STATe] OFF|ON|0|1

:DISPlay[:NFIGure]:ANNotation:CLOCk[:STATe]?

Turns on and off the display of the date and time on the N8201A display. The time and 
date pertain to all windows.

Factory Preset: On

Remarks: This parameter is persistent, which means that it retains the setting 
previously selected, even through a power cycle.

Front Panel Access: System, Time/Date, Time/Date On Off
Noise Figure Corrections 
:DISPlay[:NFIGure]:DATA:CORRections[:STATe] ON|OFF|1|0

:DISPlay[:NFIGure]:DATA:CORRections[:STATe]?

Enables or disables the display of corrected data. An error will be returned if a user 
calibration has not been performed prior to issuing this command.

Factory Preset: ON

Remarks: You must be in Noise Figure to use this command. Use 
:INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Input, Noise Figure Corrections
Select Results for Display (A) 
:DISPlay[:NFIGure]:DATA:TRACe[1] 
NFIGure|NFACtor|GAIN|YFACtor|TEFFective|PHOT|PCOLd

:DISPlay[:NFIGure]:DATA:TRACe[1]?

Selects the type of measurement results to be displayed in the upper display window 
when in graph view, or in the center column in the table or meter views. 

The seven types of result are:

• NFIGure - Noise figure

• NFACtor - Noise factor (linear noise figure)

• GAIN - Gain
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• YFACtor - Y-factor

• PHOT - Hot power density

• PCOLd - Cold power density

Factory Preset: NFIGure

Range: NFIGure, NFACtor, GAIN, YFACtor, TEFFective, PHOT or PCOLd

Remarks: You must be in Noise Figure to use this command. Use 
:INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Trace/View, Result A
Select Results for Display (B) 
:DISPlay[:NFIGure]:DATA:TRACe2 
NFIGure|NFACtor|GAIN|YFACtor|TEFFective|PHOT|PCOLd

:DISPlay[:NFIGure]:DATA:TRACe[1]?

Selects the type of measurement results to be displayed in the lower display window 
when in graph view, or in the right column in the table or meter views. 

The seven types of result are:

• NFIGure - Noise figure

• NFACtor - Noise factor (linear noise figure)

• GAIN - Gain

• YFACtor - Y-factor

• PHOT - Hot power density

• PCOLd - Cold power density

Factory Preset: NFIGure

Range: NFIGure, NFACtor, GAIN, YFACtor, TEFFective, PHOT or PCOLd

Remarks: You must be in Noise Figure to use this command. Use 
:INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Trace/View, Result B
Select Results Format 
:DISPlay[:NFIGure]:FORMat GRAPh|TABLe|METer
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:DISPlay[:NFIGure]:FORMat?

Selects the format in which the measurement results will be displayed. It is not necessary 
to capture new data when you change the results format. This means that you can capture 
data in a single sweep, and then view this data in any of the three views.

• GRAPh - Displays the results graphically

• TABLe - Displays the results in a table with one line per discrete frequency

• METer - Displays the results at one specified frequency

Factory Preset: GRAPh

Remarks: You must be in Noise Figure to use this command. Use 
:INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Trace/View, View 
Set Graticule On or Off 
:DISPlay[:NFIGure]:GRATicule[:STATe] ON|OFF|1|0

:DISPlay[:NFIGure]:GRATicule[:STATe]?

Specifies whether or not the graticule lines will be displayed.

Factory Preset: ON

Remarks: You must be in Noise Figure to use this command. Use 
:INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Display, Preferences
Set Graph View 
:DISPlay[:NFIGure]:TRACe:COMBined[:STATe] ON|OFF|1|0

:DISPlay[:NFIGure]:TRACe:COMBined[:STATe]?

Specifies whether the two graph traces are displayed on separate graphs or in one 
combined graph with two scales.

• ON - Both traces are displayed on one graph with two scales

• OFF - The two graphs are displayed separately on the screen

Factory Preset: OFF

Remarks: You must be in Noise Figure to use this command. Use 
:INSTrument:SELect NFIGURE to set the mode.
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Front Panel Access: Trace/View, View
Noise Figure - Set the Y-Axis Scale per Division 
:DISPlay[:NFIGure]:TRACe:Y[:SCALe]:PDIVision <result>, <value>

:DISPlay[:NFIGure]:TRACe:Y[:SCALe]:PDIVision?

Sets the Y-axis scale per division for the specified graph window. The graph window is 
determined by the <result> setting, which can be one of:

• NFIGure — Noise Figure

• NFACtor — Noise Factor

• GAIN — Gain

• YFACtor — Y-Factor

• TEFFective — Effective Temp

• PHOT — Hot Power Density

• PCOLd — Cold Power Density

If the graph window that you have specified with this command is not visible, the new 
scaling will take effect the next time that the window is displayed.

Factory Preset: Presets are dependent on the <result> setting as follows:

• Noise Figure — 1.0 dB

• Noise Factor — 0.74189

• Gain — 5.0 dB

• Y Factor — 1.0 dB

• Effective Temp — 200 K

• Hot Power Density — 1.0 dB

• Cold Power Density — 1.0 dB

Range: The ranges are dependent on the <result> setting as follows:

• Noise Figure — 0.001 dB to 20 dB

• Noise Factor — 0.001 to 100

• Gain — 0.001 dB to 20 dB

• Y Factor — 0.001 dB to 20 dB

• Effective Temp — 0.1 K to 20,000,000 K

• Hot Power Density — 0.001 dB to 20 dB

• Cold Power Density — 0.001 dB to 20 dB
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Remarks: You must be in Noise Figure to use this command. Use 
:INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Amplitude
Noise Figure - Set the Y-Axis Reference Value 
:DISPlay[:NFIGure]:TRACe:Y[:SCALe]:RLEVel:VALue <result>, <value>

:DISPlay[:NFIGure]:TRACe:Y[:SCALe]:RLEVel:VALue?

Sets the Y-axis reference value for the specified graph window. The graph window is 
determined by the <result> setting, which can be one of:

• NFIGure — Noise Figure

• NFACtor — Noise Factor

• GAIN — Gain

• YFACtor — Y-Factor

• TEFFective — Effective Temp

• PHOT — Hot Power Density

• PCOLd — Cold Power Density

If the graph window that you have specified with this command is not visible, the new 
reference value will take effect the next time that the window is displayed.

Factory Preset: Presets are dependent on the <result> setting as follows:

• Noise Figure — 4.0 dB

• Noise Factor — 2.51189

• Gain — 15.0 dB

• Y Factor — 5.0 dB

• Effective Temp — 1000 K

• Hot Power Density — 5.0 dB

• Cold Power Density — 5.0 dB

Range: The ranges are dependent on the <result> setting as follows:

• Noise Figure — –100 dB to 100 dB

• Noise Factor — 0 to 1 × 109

• Gain — –100 dB to 100 dB

• Y Factor — –100 dB to 100 dB

• Effective Temp — –100,000,000 K to 100,000,000 K

• Hot Power Density — –100 dB to 100 dB
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• Cold Power Density — –100 dB to 100 dB

Remarks: You must be in Noise Figure to use this command. Use 
:INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Amplitude
Noise Figure - Set the Y-Axis Reference Position 
:DISPlay[:NFIGure]:TRACe:Y[:SCALe]:RPOSition <result>, <value>

:DISPlay[:NFIGure]:TRACe:Y[:SCALe]:RPOSition?

Sets the Y-axis reference position for the specified graph window. The graph window is 
determined by the <result> setting, which can be one of:

• NFIGure — Noise Figure

• NFACtor — Noise Factor

• GAIN — Gain

• YFACtor — Y-Factor

• TEFFective — Effective Temp

• PHOT — Hot Power Density

• PCOLd — Cold Power Density

If the graph window that you have specified with this command is not visible, the new 
reference position will take effect the next time that the window is displayed.

Factory Preset: CENTer for all <result> settings

Range: TOP|CENTer|BOTTom for all <result> settings

Remarks: You must be in Noise Figure to use this command. Use 
:INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Amplitude
Zoom Window
:DISPlay:[NFIGure]:ZOOM:WINDow OFF|UPPer|LOWer 

:DISPlay:[NFIGure]:ZOOM:WINDow?

Selects the upper or lower window and expands it to fill the entire display.

• OFF — Returns the display to dual display.

• UPPer — Zoom the upper window.
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• LOWer — Zoom the lower window.

Factory Preset: OFF

Remarks: You must be in Noise Figure to use this command. Use 
:INSTrument:SELect NFIGURE to set the mode.
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FETCh Subsystem
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The FETCh? queries are used with several other commands to control the measurement 
process. These commands are described in the section on the “MEASure Group of 
Commands" on page 189. These commands apply only to measurements found in the 
MEASURE menu.

This command puts selected data from the most recent measurement into the output 
buffer (new data is initiated/measured). Use FETCh if you have already made a good 
measurement and you want to look at several types of data (different [n] values) from the 
single measurement. FETCh saves you the time of re-making the measurement. You can 
only fetch results from the measurement that is currently active.

If you need to make a new measurement, use the READ command, which is equivalent 
to an INITiate[:IMMediate] followed by a FETCh. 

:FETCh <meas>? will return valid data only when the measurement is in one of the 
following states:

idle

initiated

paused
Fetch the Current Measurement Results 
:FETCh:<measurement>[n]?

A FETCh? command must specify the desired measurement. It will return the valid 
results that are currently available, but will not initiate the taking of any new data. You 
can only fetch results from the measurement that is currently selected. The code number 
n selects the kind of results that will be returned. The available measurements and data 
results are described in the “MEASure Group of Commands" on page 189.
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FORMat Subsystem
178
The FORMat subsystem sets a data format for transferring numeric and array 
information. The TRACe[:DATA] command is affected by FORMat subsystem 
commands.
Byte Order 
:FORMat:BORDer NORMal|SWAPped

:FORMat:BORDer?

Selects the binary data byte order for numeric data transfer. In normal mode the most 
significant byte is sent first. In swapped mode the least significant byte is first. (PCs use 
the swapped order.) Binary data byte order functionality does not apply to ASCII.

This command selects the binary data byte order for data transfer. It controls whether 
binary data is transferred in normal or swapped mode. This command affects only the 
byte order for setting and querying trace data for the command  :TRACe[:DATA] and 
query  :TRACe[:DATA]?

Normal mode is when the byte sequence begins with the most significant byte (MSB) 
first, and ends with the least significant byte (LSB) last in the sequence: 1|2|3|4. 
Swapped mode is when the byte sequence begins with the LSB first, and ends with the 
MSB last in the sequence: 4|3|2|1.

Factory Preset: Normal

Remarks: You must be in the Spectrum Analysis, Basic or Noise Figure mode to use 
this command. Use INSTrument:SELect NFIGURE to set the mode.
Numeric Data Format 
:FORMat[:TRACe][:DATA] ASCii|REAL[,32]

:FORMat[:TRACe][:DATA]?

Controls the format of data input/output, that is, any data transfer across any remote port. 
The REAL and ASCII formats will format data in the current display units. The format 
of state data cannot be changed. It is always in a machine readable format only.

This command specifies the formats used for trace data during data transfer across any 
remote port.

For corrected trace data (:TRACe[:DATA] with parameter <trace_name>), REAL and 
ASCii formats will provide trace data in the current amplitude units. INTeger format will 
provide trace data in mdBm. The fastest mode is INTeger,32.
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For uncorrected trace data (:TRACe[:DATA] with parameter RAWTRACE), UINTeger 
and INTeger formats apply to RAWTRACE queries, and return uncorrected ADC 
values. The fastest mode is UINTeger,16.

For state data, the format cannot be changed. It is always in a machine readable format 
only.

ASCII - Amplitude values are in ASCII, in amplitude units, separated by commas. 
ASCII format requires more memory than the binary formats. Therefore, handling 
large amounts of this type of data, will take more time and storage space.

Integer,16 - Binary 16-bit integer values in internal units (dBm), in a definite length 
block. 

Integer,32 - Binary 32-bit integer values in internal units (dBm), in a definite length 
block.

Real,32 or Real,64 - Binary 32-bit (or 64-bit) real values in amplitude unit, in a 
definite length block. Transfers of real data are done in a binary block format.

UINTeger,16 - Binary 16-bit unsigned integer that is uncorrected ADC values, in a 
definite length block. This format is almost never applicable with current 
measurement data.

A definite length block of data starts with an ASCII header that begins with # and 
indicates how many additional data points are following in the block. Suppose the 
header is #512320.

• The first digit in the header (5) tells you how many additional digits/bytes there 
are in the header.

• The 12320 means 12 thousand, 3 hundred, 20 data bytes follow the header.

Corrected Trace Data Types 
:TRACe:DATA?<trace_name>

Data Type Result

ASCii Display Units

INT,32 (fastest) Internal Units

REAL,32 Display Units

REAL,64 Display Units

Uncorrected Trace Data Types 
:TRACe:DATA? RAWTRACE

Data Type Result

INT,32 Uncorrected ADC Values

UINT,16 (fastest) Uncorrected ADC Values
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• Divide this number of bytes by your selected data format bytes/point, either 8 (for 
real 64), or 4 (for real 32). In this example, if you are using real 64 then there are 
1540 points in the block.

Example: FORM REAL,64

Factory Preset: 

Real,32 for Spectrum Analysis mode

ASCII for Basic and Noise Figure modes

Remarks: The acceptable settings for this command change for the different modes as 
described above.
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INITiate Subsystem
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The INITiate subsystem is used to initiate a trigger for a measurement. These commands 
only initiate measurements from the MEASURE front panel key or the “MEASure 
Group of Commands" on page 189. Refer also to the TRIGger and ABORt subsystems 
for related commands.
Take New Data Acquisition for Selected Measurement 
:INITiate:<measurement> 

Initiates a trigger cycle for the measurement specified, but does not return data. The 
valid measurement names are described in the MEASure subsystem.

If your selected measurement is not currently active, the instrument will change to the 
measurement in your INIT:<meas> command and initiate a trigger cycle.

This command is not available for the one-button measurements in the Spectrum 
Analysis mode.

Example: INIT:NFIG
Continuous or Single Measurements 
:INITiate:CONTinuous OFF|ON|0|1

:INITiate:CONTinuous?

Selects whether a trigger is continuously initiated or not. Each trigger initiates a single, 
complete, measurement operation.

When set to ON another trigger cycle is initiated at the completion of each measurement.

When set to OFF, the trigger system remains in the “idle” state until an 
INITiate[:IMMediate] command is received. On receiving the INITiate[:IMMediate] 
command, it will go through a single trigger/measurement cycle, and then return to the 
“idle” state.

Example: INIT:CONT ON

Factory Preset: On

*RST: Off (recommended for remote operation)

Front Panel Access: Meas Control, Measure Cont Single
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Take New Data Acquisitions 
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:INITiate[:IMMediate]

Triggers the instrument, if external triggering is the type of trigger event selected. 
Otherwise, the command is ignored. Use the TRIGer[:SEQuence]:SOURce EXT 
command to select the external trigger.

The instrument must be in the single measurement mode. If INIT:CONT is ON, then the 
command is ignored. The desired measurement must be selected and waiting. The 
command causes the system to exit the “waiting” state and go to the “initiated” state.

The trigger system is initiated and completes one full trigger cycle. It returns to the 
“waiting” state on completion of the trigger cycle. Depending upon the measurement and 
the number of averages, there may be multiple data acquisitions, with multiple trigger 
events, for one full trigger cycle.

Example: INIT:IMM

Remarks: •

See also the *TRG command and the TRIGger subsystem.

Use  :FETCh? to transfer a measurement result from memory to the output buffer. 
Refer to individual commands in the FETCh subsystem for more information.

Front Panel Access: 

Sweep, Sweep Cont Single

Single

Meas Control, Measure Cont Single
Pause the Measurement 
:INITiate:PAUSe

Pauses the current measurement by changing the current measurement state from the 
“wait for trigger” state to the “paused” state. If the measurement is not in the “wait for 
trigger” state, when the command is issued, the transition will be made the next time that 
state is entered as part of the trigger cycle. When in the paused state, the N8201A 
auto-align process stops. If the N8201A is paused for a long period of time, 
measurement accuracy may degrade.

Example: INIT:PAUS

Front Panel Access: Meas Control, Pause
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:INITiate:RESTart

Applies to measurements found in the MEASURE menu. It restarts the current 
measurement from the “idle” state regardless of its current operating state. It is 
equivalent to: 

INITiate[:IMMediate]

ABORt (for continuous measurement mode)

Example: INIT:REST

Front Panel Access: 

Restart

 or 

Meas Control, Restart
Resume the Measurement 
:INITiate:RESume 

Resumes the current measurement by changing the current measurement state from the 
“paused state” back to the “wait for trigger” state. If the measurement is not in the 
“paused” state, when the command is issued, an error is reported. 

Example: INIT:RES

Front Panel Access: Meas Control, Resume
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The INPut subsystem controls the characteristics of all the instrument input ports.
RF Attenuation Setting 
:INPut[:NFIGure]:ATTenuation <power>

:INPut[:NFIGure]:ATTenuation

Sets the attenuation value for the RF/Microwave input.

This command has the same effect as

:SENSe:NFIGure:MANual:RF|:MWAVe:FIXed <power>

Factory Preset: 0 dB

Range: 0 dB to 40 dB in 4 dB steps

The Range is never lower than the Min. RF Attenuation setting, and never higher than 
the Max. RF Attenuation.

Front Panel Access: Input, Attenuation
Maximum Microwave Attenuation Setting 
:INPut[:NFIGure]:ATTenuation:MWAVe:MAXimum <integer>

:INPut[:NFIGure]:ATTenuation:MWAVe:MAXimum

See “RF Attenuation Setting" on page 184.

This command gives backwards compatibility with Agilent Technologies’ Noise Figure 
Analyzers (NFAs). It is functionally identical to the command

:INPut[:NFIGure]:ATTenuation[:RF]:MAXimum <integer>
Minimum Microwave Attenuation Setting 
:INPut[:NFIGure]:ATTenuation:MWAVe:MINimum <integer>

:INPut[:NFIGure]:ATTenuation:MWAVe:MINimum

See “Minimum Microwave Attenuation Setting" on page 184.

Provides backwards compatibility with Agilent Tecnologies’ Noise Figure Analyzers 
(NFAs). It is functionally identical to the command
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:INPut[:NFIGure]:ATTenuation[:RF]:MINimum <integer>
Maximum RF Attenuation Setting 
:INPut[:NFIGure]:ATTenuation[:RF]:MAXimum <integer>

:INPut[:NFIGure]:ATTenuation[:RF]:MAXimum

Sets the maximum RF attenuation setting when a calibration is performed.

Use this command and the minimum RF attenuation command to limit the attenuation 
range used during calibration. See “Minimum Microwave Attenuation Setting" on 
page 184.

Factory Preset: 0 dB

Range: 0 dB to 40 dB in 4 dB steps 

Never lower than the Min. RF Attenuation setting.

Front Panel Access: Input, Noise Figure Corrections, Input Cal
Minimum RF Attenuation Setting 
:INPut[:NFIGure]:ATTenuation[:RF]:MINimum <integer>

:INPut[:NFIGure]:ATTenuation[:RF]:MINimum

Sets the minimum RF attenuation setting when a calibration is performed.

Use this command and the maximum RF attenuation command to limit the attenuation 
range used during calibration. See“Maximum RF Attenuation Setting" on page 185.

Factory Preset: 0 dB

Range: 0 dB to 40 dB in 4 dB steps 

Never higher than the Max. RF Attenuation.

Front Panel Access: Input, Noise Figure Corrections, Input Cal
RF Input Port Coupling 
:INPut:COUPling AC|DC

:INPut:COUPling? AC|DC

Selects AC or DC coupling for the front panel RF INPUT port. A blocking capacitor is 
switched in for the ac mode.
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Instrument damage can occur if there is a DC component present at the RF INPUT and 
DC coupling is selected.

Factory Preset: (3 Hz - 26.5 GHz) - AC

Front Panel Access: Input/Output (or Input), Coupling AC DC
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This subsystem includes commands for querying and selecting instrument measurement 
(personality option) modes.
Select Application by Number 
:INSTrument:NSELect <integer>

:INSTrument:NSELect?

Selects the measurement mode by its instrument number. The actual available choices 
depends upon which applications are installed in the instrument. 

1= SA

8 = BASIC 

14 = PNOISE (phase noise)

219 = NFIGURE (noise figure)

If you are using the SCPI status registers and the analyzer mode is changed, the status 
bits should be read, and any errors resolved, prior to switching modes. Error conditions 
that exist prior to switching modes cannot be detected using the condition registers after 
the mode change. This is true unless they recur after the mode change, although 
transitions of these conditions can be detected using the event registers.

Changing modes resets all SCPI status registers and mask registers to their power-on 
defaults. Hence, any event or condition register masks must be re-established after a 
mode change. Also note that the power up status bit is set by any mode change, since that 
is the default state after power up. 

Example: INST:NSEL 219

Factory Preset: Persistent state with factory default of 1 

Range: 1 to x, where x depends upon which applications are installed.

Front Panel Access: MODE
Select Application 
:INSTrument[:SELect] SA|PNOISE|BASIC||NFIGURE

:INSTrument[:SELect]?
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Selects the measurement mode. The actual available choices depend upon which modes 
(measurement applications) are installed in the instrument. A list of the valid choices is 
returned with the INST:CAT? query. 

Once an instrument mode is selected, only the commands that are valid for that mode 
can be executed.

1 = SA

8 = BASIC 

14 = PNOISE (phase noise)

219 = NFIGURE (noise figure)

If you are using the status bits and the analyzer mode is changed, the status bits should 
be read, and any errors resolved, prior to switching modes. Error conditions that exist 
prior to switching modes cannot be detected using the condition registers after the mode 
change. This is true unless they recur after the mode change, although transitions of 
these conditions can be detected using the event registers.

Changing modes resets all SCPI status registers and mask registers to their power-on 
defaults. Hence, any event or condition register masks must be re-established after a 
mode change. Also note that the power up status bit is set by any mode change, since that 
is the default state after power up. 

Example: INST:SEL PNOISE

Factory Preset: Persistent state with factory default of Spectrum Analyzer mode.

Front Panel Access: MODE
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This group includes the CONFigure, FETCh, MEASure, and READ commands that are 
used to make measurements and return results. The different commands can be used to 
provide fine control of the overall measurement process, like changing measurement 
parameters from their default settings. Most measurements should be done in single 
measurement mode, rather than measuring continuously.

The SCPI default for the format of any data output is ASCII. The format can be changed 
to binary with FORMat:DATA which transports faster over the bus.

Command Interactions: MEASure, CONFigure, FETCh, INITiate and READ
Figure 40 Measurement Group of Commands
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Measure Commands:

:MEASure:<measurement>[n]?

This is a fast single-command way to make a measurement using the factory default instrument settings. These 
are the settings and units that conform to the Mode Setup settings (e.g. radio standard) that you have currently 
selected.

• Stops the current measurement (if any) and sets up the instrument for the specified measurement using the 
factory defaults

• Initiates the data acquisition for the measurement

• Blocks other SCPI communication, waiting until the measurement is complete before returning results.

• After the data is valid it returns the scalar results, or the trace data, for the specified measurement. The type 
of data returned may be defined by an [n] value that is sent with the command.

The scalar measurement results will be returned if the optional [n] value is not included, or is set to 1. If the 
[n] value is set to a value other than 1, the selected trace data results will be returned. See each command for 
details of what types of scalar results or trace data results are available.

ASCII is the default format for the data output. (Older versions of Spectrum Analysis and Phase Noise mode 
measurements only use ASCII.) The binary data formats should be used for handling large blocks of data 
since they are smaller and faster than the ASCII format. Refer to the FORMat:DATA command for more 
information.

If you need to change some of the measurement parameters from the factory default settings you can set up the 
measurement with the CONFigure command. Use the commands in the SENSe:<measurement> and 
CALCulate:<measurement> subsystems to change the settings. Then you can use the READ? command to 
initiate the measurement and query the results. See Figure 40 on page 189.

If you need to repeatedly make a given measurement with settings other than the factory defaults, you can use 
the commands in the SENSe:<measurement> and CALCulate:<measurement> subsystems to set up the 
measurement. Then use the READ? command to initiate the measurement and query results.

Measurement settings persist if you initiate a different measurement and then return to a previous one. Use 
READ:<measurement>? if you want to use those persistent settings. If you want to go back to the default 
settings, use MEASure:<measurement>?.

Configure Commands:

:CONFigure:<measurement> 

This command stops the current measurement (if any) and sets up the instrument for the specified measurement 
using the factory default instrument settings. It sets the instrument to single measurement mode but should not 
initiate the taking of measurement data unless INIT:CONTinuous is ON. After you change any measurement 
settings, the READ command can be used to initiate a measurement without changing the settings back to their 
defaults. 

The CONFigure? query returns the current measurement name.
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Fetch Commands:

:FETCh:<measurement>[n]?

This command puts selected data from the most recent measurement into the output buffer. Use FETCh if you 
have already made a good measurement and you want to return several types of data (different [n] values, e.g. 
both scalars and trace data) from a single measurement. FETCh saves you the time of re-making the 
measurement. You can only FETCh results from the measurement that is currently active, it will not change to a 
different measurement. 

If you need to get new measurement data, use the READ command, which is equivalent to an INITiate followed 
by a FETCh. 

The scalar measurement results will be returned if the optional [n] value is not included, or is set to 1. If the [n] 
value is set to a value other than 1, the selected trace data results will be returned. See each command for details 
of what types of scalar results or trace data results are available. The binary data formats should be used for 
handling large blocks of data since they are smaller and transfer faster then the ASCII format. (FORMat:DATA)

FETCh may be used to return results other than those specified with the original READ or MEASure command 
that you sent.

INITiate Commands:

:INITiate:<measurement>

This command is not available for measurements in all the instrument modes: 

• Initiates a trigger cycle for the specified measurement, but does not output any data. You must then use the 
FETCh<meas> command to return data. If a measurement other than the current one is specified, the 
instrument will switch to that measurement and then initiate it.

For example, suppose you have previously initiated the ACP measurement, but now you are running the 
channel power measurement. If you send INIT:ACP? it will change from channel power to ACP and will 
initiate an ACP measurement.

• Does not change any of the measurement settings. For example, if you have previously started the ACP 
measurement and you send INIT:ACP? it will initiate a new ACP measurement using the same instrument 
settings as the last time ACP was run.

• If your selected measurement is currently active (in the idle state) it triggers the measurement, assuming the 
trigger conditions are met. Then it completes one trigger cycle. Depending upon the measurement and the 
number of averages, there may be multiple data acquisitions, with multiple trigger events, for one full trigger 
cycle.
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Monitor Spectrum 

READ Commands:

:READ:<measurement>[n]?

• Does not preset the measurement to the factory default settings. For example, if you have previously 
initiated the ACP measurement and you send READ:ACP? it will initiate a new measurement using the 
same instrument settings.

• Initiates the measurement and puts valid data into the output buffer. If a measurement other than the current 
one is specified, the instrument will switch to that measurement before it initiates the measurement and 
returns results.

For example, suppose you have previously initiated the ACP measurement, but now you are running the 
channel power measurement. Then you send READ:ACP? It will change from channel power back to ACP 
and, using the previous ACP settings, will initiate the measurement and return results.

• Blocks other SCPI communication, waiting until the measurement is complete before returning the results

If the optional [n] value is not included, or is set to 1, the scalar measurement results will be returned. If the 
[n] value is set to a value other than 1, the selected trace data results will be returned. See each command for 
details of what types of scalar results or trace data results are available. The binary data formats should be 
used when handling large blocks of data since they are smaller and faster then the ASCII format. 
(FORMat:DATA)
192
Measures the power levels across the specified spectral band using one of three traces. 
By default, the N8201A’s entire range is measured.

The general functionality of CONFigure, FETCh, MEASure, and READ are described at 
the beginning of this section. See the SENSe:MONitor commands for more 
measurement related commands.

:CONFigure:MONitor

:FETCh:MONitor[n]

:READ:MONitor[n]

:MEASure:MONitor[n]

Front Panel Access: Measure, Monitor Spectrum

After the measurement is selected, press Restore Meas Defaults to restore factory 
defaults.
N8201A Noise Figure Measurement Personality Guide



Language Reference 6

N8201A Noise Figure
Table 10 Measurement Results Available

n Results Returned

n=1 (or not specified) Trace 1 data if available, otherwise nothing

2 Trace 2 data if available, otherwise nothing

3 Trace 3 data if available, otherwise nothing
Noise Figure Measurement 
Returns a set of thirteen noise figure measurement results in a specified order and 
separated by commas. The order in which the thirteen results are returned is shown in the 
table below, and they represent the last data measured in the last measurement sweep that 
was made.

You must be in Noise Figure mode to use these commands. Use INSTrument:SELect 
NFIGURE to set the mode.

The general functionality of CONFigure, FETCh, MEASure, and READ are described at 
the beginning of this section. 

:CONFigure[:NFIGure]

:INITiate[:NFIGure]

:FETCh[:NFIGure]?

:READ[:NFIGure]?

:MEASure[:NFIGure]?

Front Panel Access: Trace/View, Result A and B

After the measurement is selected, press Restore Meas Defaults to restore factory 
defaults.
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NFIGure

Measurement Results Returned

Returns the following scalar results, in order.
Tcold scalar value
Corrected scalar result for Noise Figure
Corrected scalar result for Noise Factor
Corrected scalar result for Gain
Corrected scalar result for Effective Temperature
Corrected scalar result for Hot Power Density
Corrected scalar result for Cold Power Density
Uncorrected scalar result for Noise Figure
Uncorrected scalar result for Noise Factor
Uncorrected scalar result for Gain
Uncorrected scalar result for Effective Temperature
Uncorrected scalar result for Hot Power Density
Uncorrected scalar result for Cold Power Density
Noise Figure Measurement - Gain Results
Returns the Gain values used in calculating the measurement results. The returned values 
are in the default units of dB.

Sweep results are returned as a list of comma separated values, one value for each 
measurement frequency.

You must be in Noise Figure mode to use these commands. Use INSTrument:SELect 
NFIGURE to set the mode.

The general functionality of CONFigure, FETCh, MEASure, and READ are described at 
the beginning of this section.

:FETCh[:NFIGure]([:ARRay]|:SCALar)[:DATA]:CORRected:GAIN?

:READ[:NFIGure]([:ARRay]|:SCALar)[:DATA]:CORRected:GAIN?

:MEASure[:NFIGure]([:ARRay]|:SCALar)[:DATA]:CORRected:GAIN?

Front Panel Access: Trace/View, Result A or B

After the measurement is selected, press Restore Meas Defaults to restore factory 
defaults.
Noise Figure Measurement - Noise Factor Results 
Returns the Noise Factor values used in calculating the measurement results. The 
returned values are linear.
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Sweep results are returned as a list of comma separated values, one value for each 
measurement frequency.

You must be in Noise Figure mode to use these commands. Use INSTrument:SELect 
NFIGURE to set the mode.

The general functionality of CONFigure, FETCh, MEASure, and READ are described at 
the beginning of this section.

:FETCh[:NFIGure]([:ARRay]|:SCALar)[:DATA](:CORRected|:UNCorrected) 
:NFACtor?

:READ[:NFIGure]([:ARRay]|:SCALar)[:DATA](:CORRected|:UNCorrected) 
:NFACtor?

:MEASure[:NFIGure]([:ARRay]|:SCALar)[:DATA](:CORRected|:UNCorrected) 
:NFACtor?

Front Panel Access: Trace/View, Result A or B

After the measurement is selected, press Restore Meas Defaults to restore factory 
defaults.
Noise Figure Measurement - Noise Figure Results 
Returns the Noise Figure values used in calculating the measurement results. The 
returned values are in the default units of dB.

Sweep results are returned as a list of comma separated values, one value for each 
measurement frequency.

You must be in Noise Figure mode to use these commands. Use INSTrument:SELect 
NFIGURE to set the mode.

The general functionality of CONFigure, FETCh, MEASure, and READ are described at 
the beginning of this section.

:FETCh[:NFIGure]([:ARRay]|:SCALar)[:DATA](:CORRected|:UNCorrected) 
:NFIGure?

:READ[:NFIGure]([:ARRay]|:SCALar)[:DATA](:CORRected|:UNCorrected) 
:NFIGure?

:MEASure[:NFIGure]([:ARRay]|:SCALar)[:DATA](:CORRected|:UNCorrected) 
:NFIGure?

Front Panel Access: Trace/View, Result A or B

After the measurement is selected, press Restore Meas Defaults to restore factory 
defaults.
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Noise Figure Measurement - Cold Power Pcold Density Results 
196
Returns the Cold Power values from the most recently completed swept frequency 
measurement. The returned values are in the default units of dB.

The instrument makes cold power measurements with the noise source switched off. The 
reported value is a power level which is relative to the power at the input.

Sweep results are returned as a list of comma separated values, one value for each 
measurement frequency.

You must be in Noise Figure mode to use these commands. Use INSTrument:SELect 
NFIGURE to set the mode.

The general functionality of CONFigure, FETCh, MEASure, and READ are described at 
the beginning of this section.

:FETCh[:NFIGure]([:ARRay]|:SCALar)[:DATA](:CORRected|:UNCorrected) 
:PCOLd?

:READ[:NFIGure]([:ARRay]|:SCALar)[:DATA](:CORRected|:UNCorrected) 
:PCOLd?

:MEASure[:NFIGure]([:ARRay]|:SCALar)[:DATA](:CORRected|:UNCorrected) 
:PCOLd?

Front Panel Access: Trace/View, Result A or B 

After the measurement is selected, press Restore Meas Defaults to restore factory 
defaults.
Noise Figure Measurement - Hot Power Phot Density Results 
Returns the Hot Power values from the most recently completed swept frequency 
measurement. The returned values are in the default units of dB.

The instrument makes hot power measurements with the noise source switched on. The 
reported value is a power level which is relative to the power at the input.

Sweep results are returned as a list of comma separated values, one value for each 
measurement frequency.

You must be in Noise Figure mode to use these commands. Use INSTrument:SELect 
NFIGURE to set the mode.

The general functionality of CONFigure, FETCh, MEASure, and READ are described at 
the beginning of this section.

:FETCh[:NFIGure]([:ARRay]|:SCALar)[:DATA](:CORRected|:UNCorrected) 
:PHOT?
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:READ[:NFIGure]([:ARRay]|:SCALar)[:DATA](:CORRected|:UNCorrected) 
:PHOT?

:MEASure[:NFIGure]([:ARRay]|:SCALar)[:DATA](:CORRected|:UNCorrected) 
:PHOT?

Front Panel Access: Trace/View, Result A or B

After the measurement is selected, press Restore Meas Defaults to restore factory 
defaults.
Noise Figure Measurement - Effective Temperature Results 
Returns the Effective Temperature values from the most recently completed swept 
frequency measurement. The returned values are in the default units of degrees Kelvin.

Sweep results are returned as a list of comma separated values, one value for each 
measurement frequency.

You must be in Noise Figure mode to use these commands. Use INSTrument:SELect 
NFIGURE to set the mode.

The general functionality of CONFigure, FETCh, MEASure, and READ are described at 
the beginning of this section.

:FETCh[:NFIGure]([:ARRay]|:SCALar)[:DATA](:CORRected|:UNCorrected) 
:TEFFective?

:READ[:NFIGure]([:ARRay]|:SCALar)[:DATA](:CORRected|:UNCorrected) 
:TEFFective?

:MEASure[:NFIGure]([:ARRay]|:SCALar)[:DATA](:CORRected|:UNCorrected) 
:TEFFective?

Front Panel Access: Trace/View, Result A or B

After the measurement is selected, press Restore Meas Defaults to restore factory 
defaults.
Noise Figure Measurement - Tcold Results 
Returns the Tcold values used in calculating the measurement results. The results 
returned are from the most recently completed swept measurement if :ARRay has been 
selected, or from the most recently completed fixed measurement if :SCALar has been 
selected. The returned values are in the default units of degrees Kelvin.

Sweep results are returned as a list of comma separated values, one value for each 
measurement frequency.
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You must be in Noise Figure mode to use these commands. Use INSTrument:SELect 
NFIGURE to set the mode.

The general functionality of CONFigure, FETCh, MEASure, and READ are described at 
the beginning of this section.

:FETCh[:NFIGure]([:ARRay]|:SCALar)[:DATA]:TCOLd?

:READ[:NFIGure]([:ARRay]|:SCALar)[:DATA]:TCOLd?

:MEASure[:NFIGure]([:ARRay]|:SCALar)[:DATA]:TCOLd?

Front Panel Access: Trace/View, Result A or B

After the measurement is selected, press Restore Meas Defaults to restore factory 
defaults.
Noise Figure Measurement - Y Factor Results 
Returns the Y Factor values from the most recently completed swept frequency 
measurement. The results returned are from the most recently completed swept 
measurement if :ARRay has been selected, or from the most recently completed fixed 
measurement if :SCALar has been selected. The returned values are in the default units 
of dB.

Sweep results are returned as a list of comma separated values, one value for each 
measurement frequency.

You must be in Noise Figure mode to use these commands. Use INSTrument:SELect 
NFIGURE to set the mode.

The general functionality of CONFigure, FETCh, MEASure, and READ are described at 
the beginning of this section.

:FETCh[:NFIGure]([:ARRay]|:SCALar)[:DATA]:UNCorrected :YFACtor?

:READ[:NFIGure]([:ARRay]|:SCALar)[:DATA]:UNCorrected :YFACtor?

:MEASure[:NFIGure]([:ARRay]|:SCALar)[:DATA]:UNCorrected :YFACtor?

Front Panel Access: Trace/View, Result A or B

After the measurement is selected, press Restore Meas Defaults to restore factory 
defaults.
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The purpose of the MMEMory subsystem is to provide access to mass storage devices 
such as internal drives. If mass storage is not specified in the filename, the default mass 
storage will be used.

Refer also to  :CALCulate and  :TRACe subsystems for more trace and limit line 
commands.

The MMEMory command syntax term <file_name> is a specifier having the form: 
drive:name.ext, where the following rules apply:

“drive” is “C:”

“name” is a DOS file name of up to eight characters, letters (A-Z, a-z) and numbers (0-9) 
only (lower case letters are read as uppercase)

“ext” is an optional file extension using the same rules as “name,” but consists of up to 
three characters total. (The default file extension will be added if it is not specified.)
Load a Noise Figure ENR Table from a File 
:MMEMory:LOAD:ENR CALibration|MEASurement, <file_name>

Loads the ENR data in the file <file_name> to the specified correction set.

Example: :MMEM:LOAD:ENR MEASurements, “C:TEST.ENR”

Front Panel Access: 

File, Load, Type, ENR Cal Table, Source Device Instrument/PC, File Name, Load Now

File, Load, Type, More, ENR Meas/Common Table, Source Device Instrument/PC, File 
Name, Load Now
Load a Noise Figure Frequency List Table from a File 
:MMEMory[:NFIGure]:LOAD:FREQuency, <file_name>

Loads the frequency data in the file <filename> to the frequency table.

Example: :MMEM:LOAD:FREQuency, “C:TEST.LST”

Front Panel Access: File, Load, Type, Freq List, Source Device Instrument/PC, File 
Name, Load Now
Load a Limit Line from Memory to the Instrument 
:MMEMory:LOAD:LIMit LLINe1|LLINe2|LLINe3|LLINe4,<file_name>
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Loads a limit line, from the specified file in mass storage to the instrument. Loading a 
time limit line deletes any frequency limit lines. Similarly, loading a frequency limit line 
deletes any time limit lines. If you do not specify the file extension, the instrument will 
assume your file has an extension of  .LIM. If your file has no extension, the instrument 
will not find the file.

Example: :MMEM:LOAD:LIM LLIN2,“C:mylimit.lim” 

Front Panel Access: File, Load, Type, Limits, Source Limit 1 or Limit 2, Source 
Device Instrument/PC, File Name, Load Now
Load a Noise Figure Loss Compensation Table from a File 
:MMEMory:LOAD:LOSS BEFore|AFTer, <file_name>

Loads the Loss Compensation data in the file <file_name> to the specified loss 
compensation table.

Example: :MMEM:LOAD:LOSS BEFore, “C:TEST.LOS”

Front Panel Access: 

File, Load, Type, Loss Comp Before DUT, Device Destination Instrument/PC, File 
Name, Load Now

File, Load, Type, Loss Comp After DUT, Device Destination Instrument/PC, File 
Name, Load Now
Store a Noise Figure ENR Table to a File 
:MMEMory:STORe:ENR CALibration|MEASurement, <file_name>

Stores the ENR calibration or measurement data to the file <file_name>.

Example: :MMEM:STORe:ENR MEASurement, “C:TEST.ENR”

Front Panel Access: 

File, Store, Type, ENR Cal Table, Source Device Instrument/PC, File Name, Save 
Now

File, Store, Type, ENR Meas/Common Table, Device Destination Instrument/PC, 
File Name, Save Now
Store a Limit Line in a File 
:MMEMory:STORe:LIMit LLINe1|LLINe2,<file_name>
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:MMEMory:STORe:LIMit LLINe1|LLINe2|LLINe3|LLINe4,<file_name>

Stores the current limit line to the specified file in memory. If you do not specify the file 
extension, the instrument will assign an extension of  .LIM.

Example: MMEM:STOR:LIM LLIN2,”C:mylimit.lim”

Remarks: This command will fail if the <file_name> already exists. There is no SCPI 
short form for parameters LLINE1|LLINE2.

Front Panel Access: File, Save, Type, Limits, Source Limit 1 or Limit 2, Device 
Destination Instrument/PC, File Name, Save Now
Store a Noise Figure Frequency List Table to a File 
:MMEMory[:NFIGure]:STORe:FREQuency, <file_name>

Stores the frequency data in the specified Frequency table to the file <file_name>.

Example: :MMEM:STORe:FREQuency, “C:TEST.LST”

Front Panel Access: File, Save, Type, Freq List, Device Destination Instrument/PC, 
File Name, Save Now
Store a Noise Figure Loss Compensation Table to a File 
:MMEMory:STORe:LOSS BEFore|AFTer, <file_name>

Stores the Loss Compensation data in the specified Loss Compensation table to the file 
<file_name>.

Example: :MMEM:STORe:LOSS BEFore, “C:TEST.LOS”

Front Panel Access: 

File, Save, Type, Loss Comp Before DUT, Device Destination Instrument/PC, File 
Name, Save Now

File, Save, Type, Loss Comp After DUT, Device Destination Instrument/PC, File 
Name, Save Now
Store a Measurement Results in a File
:MMEMory:STORe:RESults filename.csv 

Saves the measurement results to a file in memory. The file name must have a file 
extension of  .csv and will be in the CSV (comma-separated values) format.
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Example: MMEM:STOR:RES ‘C:mymeas.csv’

Front Panel Access: File, Save, Type, Measurement Results, Device Destination 
Instrument/PC, File Name, Save Now
Store a Trace in a File 
:MMEMory:STORe:TRACe TRACe1|TRACe2|ALL, <file_name>

Stores the specified trace or traces to the specified file in memory. The file is in comma 
separated value (CSV) format, with the data stored in <frequency>/<amplitude> pairs.

Example: MMEM:STOR:TRAC TRACE2,“C:mytrace.trc”

Front Panel Access: File, Save, Type, Trace, Source, Device Destination 
Instrument/PC, File Name, Save Now
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OUTPut Subsystem
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The OUTPut subsystem controls the characteristics of the source output port.
Turn Noise Source On/Off 
:OUTPut:] OFF|ON|0|1

:OUTPut:MONitor:NOIse[:STATe]?

Turns the noise source On or Off.

Factory Preset: Off

Front Panel Access: Source 
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READ Subsystem
204
The READ? commands are used with several other commands and are documented in 
the section on the “MEASure Group of Commands” on page 301.

Initiate and Read Measurement Data 

:READ:<measurement>[n]?

A READ? query must specify the desired measurement. It will cause a measurement to 
occur without changing any of the current settings and will return any valid results. The 
code number n selects the kind of results that will be returned. The available 
measurements and data results are described in the “MEASure Group of Commands” on 
page 301.
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These commands are used to set the instrument state parameters so that you can measure 
a particular input signal. Some SENSe commands are only for use with specific 
measurements found under the MEASURE key menu or the “MEASure Group of 
Commands" on page 189. The measurement must be active before you can use these 
commands.

The SCPI default for the format of any data output is ASCII. The format can be changed 
to binary with FORMat:DATA which transports faster over the bus.
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Bandwidth Commands 

Resolution Bandwidth 
206
[:SENSe]:MONitor:BANDwidth|BWIDth[:RESolution] <freq>

[:SENSe]:MONitor:BANDwidth|BWIDth[:RESolution]?

Enables you to select the 3.01 dB resolution bandwidth (RBW) of the N8201A in 10% 
steps from 1 Hz to 3 MHz, plus bandwidths of 4, 5, 6, or 8 MHz. 

If an unavailable bandwidth is specified, the closest available bandwidth is selected.

Sweep time is coupled to RBW. As the RBW changes, the sweep time (if set to Auto) is 
changed to maintain amplitude calibration. 

Factory Preset: 3 MHz

Range: 1 Hz to 8 MHz.

Default Unit: Hz

Front Panel Access: BW/Avg
Video Bandwidth 
[:SENSe]:MONitor:BANDwidth|BWIDth:VIDeo <freq>

[:SENSe]:MONitor:BANDwidth|BWIDth:VIDeo?

Specifies the video bandwidth.

You can change the N8201A post-detection filter from 1 Hz to 8 MHz in approximately 
10% steps. In addition, a wide-open video filter bandwidth (VBW) may be chosen by 
selecting 50 MHz.

Factory Preset: Automatically calculated

Range: 1 Hz to 8 MHz, plus 50 MHz.

Default Unit: Hz

Front Panel Access: BW/Avg 
Video Bandwidth Automatic 
[:SENSe]:MONitor:BANDwidth|BWIDth:VIDeo:AUTO OFF|ON|0|1
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[:SENSe]:MONitor:BANDwidth|BWIDth:VIDeo:AUTO?

Couples the video bandwidth to the resolution bandwidth, using the VBW/RBW ratio 
that you have set. 

Factory Preset: ON

Front Panel Access: BW/Avg
Video to Resolution Bandwidth Ratio 
[:SENSe]:MONitor:BANDwidth|BWIDth:VIDeo:RATio <numeric>

[:SENSe]:MONitor:BANDwidth|BWIDth:VIDeo:RATio?

Specifies the ratio of the video bandwidth to the resolution bandwidth. 

Factory Preset: 1.0

Range: 0.00001 to 10

Front Panel Access: BW/Avg
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Configure Commands

Downconverter Fixed LO Frequency 
208
[:SENSe]:CONFigure:MODE:DOWNconv:LOSCillator:FREQuency <value>

[:SENSe]:CONFigure:MODE:DOWNconv:LOSCillator:FREQuency?

Sets the down converter fixed LO frequency. 

This noise figure application (Option 219) can only measure fixed LO devices.

Factory Preset: 30 GHz

Range: 1 Hz to 325 GHz 

Default Unit: Hz

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Mode Setup, DUT Setup, DUT, Downconverter, Ext LO Freq
Downconverter Frequency Context 
[:SENSe]:CONFigure:MODE:DOWNconv:FREQuency:CONText RF|IF

[:SENSe]:CONFigure:MODE:DOWNconv:FREQuency:CONText?

Determines whether the frequencies are displayed before any down conversion has taken 
place (RF), or after any down conversion (IF). It is only when the frequency context is 
set to IF that the displayed frequencies represent the actual frequencies that the N8201A 
is measuring.

RF - Frequencies are displayed as they are when they enter the DUT, that is, before any 
frequency conversion has taken place.

IF - Frequencies are displayed as they are when they leave the DUT, that is, after any 
frequency conversion has taken place. These are therefore the frequencies entering the 
N8201A.

Factory Preset: IF

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Mode Setup, DUT Setup, Frequency Context
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Downconverter LO Offset 
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[:SENSe]:CONFigure:MODE:DOWNconv:LOSCillator:OFFSet LSB|USB|DSB

[:SENSe]:CONFigure:MODE:DOWNconv:LOSCillator:OFFSet?

Sets the type of offset for the downconverter.

LSB - Lower Sideband (Signal frequency < LO frequency).

USB - Upper Sideband (Signal frequency > LO frequency)

DSB - Double sideband (no offset).

Factory Preset: LSB

Remarks: 

You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

You must have specified the DUT type as Downconverter to use this command. Use 
[:SENSe]:CONFigure:MODE:DUT to set the DUT type.

Front Panel Access: Mode Setup, DUT Setup, Sideband
Select DUT type 
[:SENSe]:CONFigure:MODE:DUT AMPLifier|DOWNconv|UPConv

[:SENSe]:CONFigure:MODE:DUT?

Sets the type of DUT whose noise figure is to be measured.

AMPLifier - the DUT is an amplifier that performs no frequency conversion. It can 
be used with or without an external system downconverter.

DOWNconv - the DUT performs its own frequency down conversion. A 
DOWNconverter cannot be used with an external system down converter.

UPConv - the DUT performs its own frequency up conversion. An upconverter 
cannot be used with an external system downconverter.

Factory Preset: AMPLifier

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Mode Setup, DUT Setup, DUT, Amplifier
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System Downconverter Control 
210
[:SENSe]:CONFigure:MODE:SYSTem:DOWNconv[:STATe] ON|OFF|1|0

[:SENSe]:CONFigure:MODE:SYSTem:DOWNconv[:STATe]?

Specifies whether or not there is a system downconverter. A system downconverter 
reduces high frequencies that are beyond the range of the N8201A to a lower frequency 
which the N8201A can measure.

ON or 1 - you are using a system downconverter.

OFF or 0 - you are not using a system downconverter.

Factory Preset: OFF

Remarks: 

You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Your DUT must be set to type AMPLifier. Use [:SENSe]:CONFigure:MODE:DUT 
to set the DUT type.

Front Panel Access: Mode Setup, DUT Setup, System Downconverter On/Off
System Fixed LO Frequency 
[:SENSe]:CONFigure:MODE:SYSTem:LOSCillator:FREQuency <value>

[:SENSe]:CONFigure:MODE:SYSTem:LOSCillator:FREQuency?

Sets the system fixed LO frequency.

This noise figure application (Option 219) can only measure fixed LO devices.

Factory Preset: 30 GHz

Range: 1 Hz to 325 GHz 

Default Unit: Hz

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Mode Setup, DUT Setup, DUT, Amplifier, System 
Downconverter On, Ext LO Freq
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[:SENSe]:CONFigure:MODE:SYSTem:FREQuency:CONText RF|IF

[:SENSe]:CONFigure:MODE:SYSTem:FREQuency:CONText?

Determines whether the frequencies are displayed before any conversion has taken place 
(RF), or after any conversion (IF). It is only when the frequency context is set to IF that 
the displayed frequencies represent the actual frequencies that the N8201A is measuring.

RF - Frequencies are displayed as they are when they enter the DUT, that is, before 
any frequency conversion by the system downconverter has taken place.

IF - Frequencies are displayed as they are when they leave the DUT, that is, after any 
frequency conversion has taken place. These are therefore the frequencies entering 
the N8201A.

Factory Preset: RF

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Mode Setup, DUT Setup, DUT, Amplifier, System 
Downconverter On, Frequency Context
System LO Offset 
[:SENSe]:CONFigure:MODE:SYSTem:LOSCillator:OFFSet LSB|USB|DSB

[:SENSe]:CONFigure:MODE:SYSTem:LOSCillator:OFFSet?

Sets the type of offset for the system.

LSB - Lower Sideband (Signal frequency < LO frequency).

USB - Upper Sideband (Signal frequency > LO frequency)

DSB - Double sideband (no offset).

Factory Preset: LSB

Remarks: 

You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Double Sideband (DSB) is only available when the System Downconverter is On.

Front Panel Access: Mode Setup, DUT Setup, Sideband
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Upconverter Fixed LO Frequency 
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[:SENSe]:CONFigure:MODE:UPConv:LOSCillator:FREQuency <value>

[:SENSe]:CONFigure:MODE:UPConv:LOSCillator:FREQuency?

Sets the upconverter fixed LO frequency.

This noise figure application (Option 219) can only measure fixed LO devices.

Factory Preset: 30 GHz

Range: 1 Hz to 325 GHz 

Default Unit: Hz

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Mode Setup, DUT Setup, DUT, Upconverter, Ext LO Freq
Upconverter Frequency Context 
[:SENSe]:CONFigure:MODE:UPConv:FREQuency:CONText RF|IF

[:SENSe]:CONFigure:MODE:UPConv:FREQuency:CONText?

Determines whether the frequencies are displayed before any up conversion has taken 
place (RF), or after any up conversion (IF). It is only when the frequency context is set to 
IF that the displayed frequencies represent the actual frequencies that the N8201A is 
measuring.

RF - Frequencies are displayed as they are when they enter the DUT, that is, before 
any frequency conversion by the upconverter has taken place.

IF - Frequencies are displayed as they are when they leave the DUT, that is, after any 
frequency conversion has taken place. These are therefore the frequencies entering 
the N8201A.

Factory Preset: IF

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Mode Setup, DUT Setup, DUT, Upconverter, Freq Context
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Upconverter LO Offset 
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[:SENSe]:CONFigure:MODE:UPConv:LOSCillator:OFFSet LSB|USB

[:SENSe]:CONFigure:MODE:UPConv:LOSCillator:OFFSet?

Sets the type of offset for the system.

LSB - Lower Sideband (Signal frequency < LO frequency).

USB - Upper Sideband (Signal frequency > LO frequency)

Factory Preset: LSB

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFigure to set the mode.

Front Panel Access: Mode Setup, DUT Setup, Sideband
Default Reset 
[:SENSe]:DEFaults

Restores personality Mode Setup defaults.

Front Panel Access: 

Remarks: This command sets all the SENSe defaults but has no effect on the 
MEASure default settings. Use the CONFigure:<measurement> command to set 
measurement defaults
Monitor Spectrum Measurement 
Commands for querying the Monitor Spectrum measurement results and for setting to 
the default values are found in the “MEASure Group of Commands" on page 189. The 
equivalent front panel keys for the parameters described in the following commands, are 
found under the Meas Setup key, after the Monitor Spectrum measurement has been 
selected from the MEASURE key menu.
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Monitor Spectrum—Average Count 
214
[:SENSe]:MONitor:AVERage:COUNt <integer>

[:SENSe]:MONitor:AVERage:COUNt?

Sets the number of data acquisitions that will be averaged. After the specified number of 
average counts, the averaging mode (terminal control) setting determines the averaging 
action.

Factory Preset: 10

Range: 1 to 1,000

Remarks: You must be in the Phase Noise or Noise Figure mode to use this command. 
Use INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Meas Setup, Avg Number
Monitor Spectrum—Averaging State 
[:SENSe]:MONitor:AVERage[:STATe] OFF|ON|0|1

[:SENSe]:MONitor:AVERage[:STATe]?

Turns averaging on or off.

Factory Preset: 

On for GSM, Bluetooth

Off for Phase Noise and Noise Figure.

Remarks: You must be in the Phase Noise or Noise Figure mode to use this command. 
Use INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Meas Setup, Avg Number
Monitor Spectrum—Averaging Termination Control 
[:SENSe]:MONitor:AVERage:TCONtrol EXPonential|REPeat

[:SENSe]:MONitor:AVERage:TCONtrol?

Selects the type of termination control used for the averaging function. This determines 
the averaging action after the specified number of data acquisitions (average count) is 
reached.
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Exponential - After the average count is reached, each successive data acquisition is 
exponentially weighted and combined with the existing average.

Repeat - After reaching the average count, the averaging is reset and a new average is 
started.

Factory Preset: Exponential

Remarks: You must be in the Phase Noise or Noise Figure mode to use this command. 
Use INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Meas Setup, Avg Mode
Monitor Spectrum—Resolution Bandwidth 
[:SENSe]:MONitor:BANDwidth|BWIDth[:RESolution] <freq>

[:SENSe]:MONitor:BANDwidth|BWIDth[:RESolution]?

Enables you to select the 3.01 dB resolution bandwidth (RBW) of the N8201A in 10% 
steps from 1 Hz to 3 MHz, plus bandwidths of 4, 5, 6, or 8 MHz. 

If an unavailable bandwidth is specified, the closest available bandwidth is selected.

Sweep time is coupled to RBW. As the RBW changes, the sweep time (if set to Auto) is 
changed to maintain amplitude calibration. 

Factory Preset: 1 MHz

Range: 1 Hz to 8 MHz

Default Unit: Hz

Front Panel Access: BW/Avg
Monitor Spectrum—Resolution Bandwidth Automatic 
[:SENSe]:MONitor:BANDwidth|BWIDth[:RESolution]:AUTO OFF|ON|0|1

[:SENSe]:MONitor:BANDwidth|BWIDth[:RESolution]:AUTO?

Couples the resolution bandwidth to the frequency span.

When set to Auto, resolution bandwidth is auto coupled to span. The ratio of span to 
RBW is set by Span/RBW. The factory default for this ratio is approximately 106:1 
when auto coupled. When Res BW is set to Man, bandwidths are entered by the user, and 
these bandwidths are used regardless of other N8201A settings.

Factory Preset: ON
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Front Panel Access: BW/Avg
Monitor Spectrum—Video Bandwidth 
[:SENSe]:MONitor:BANDwidth|BWIDth:VIDeo <freq>

[:SENSe]:MONitor:BANDwidth|BWIDth:VIDeo?

Specifies the video bandwidth.

You can change the N8201A post-detection filter from 1 Hz to 8 MHz in approximately 
10% steps. In addition, a wide-open video filter bandwidth (VBW) may be chosen by 
selecting 50 MHz.

Factory Preset: 3 MHz

Range: 1 Hz to 8 MHz, plus 50 MHz

Default Unit: Hz

Front Panel Access: BW/Avg 
Monitor Spectrum—Video Bandwidth Automatic 
[:SENSe]:MONitor:BANDwidth|BWIDth:VIDeo:AUTO OFF|ON|0|1

[:SENSe]:MONitor:BANDwidth|BWIDth:VIDeo:AUTO?

Couples the video bandwidth to the resolution bandwidth, using the VBW/RBW ratio 
that you have set. 

Factory Preset: ON

Front Panel Access: BW/Avg
Monitor Spectrum—Video to Resolution Bandwidth Ratio 
[:SENSe]:MONitor:BANDwidth|BWIDth:VIDeo:RATio <numeric>

[:SENSe]:MONitor:BANDwidth|BWIDth:VIDeo:RATio?

Specifies the ratio of the video bandwidth to the resolution bandwidth.

Factory Preset: 1.00000

Range: 0.00001 to 10
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Front Panel Access: BW/Avg
Monitor Spectrum—Type of Detection 
[:SENSe]:MONitor:DETector[:FUNCtion] NORMal |POSitive|NEGative|AVERage

[:SENSe]:MONitor:DETector[:FUNCtion]?

Specifies the detection mode.

Normal detection displays the peak of CW-like signals and maximums and 
minimums of noise-like signals.

Positive peak detection displays the highest sample level measured during each 
sampling period.

Negative peak detection displays the lowest sample level measured during each 
sampling period.

Average detection displays the average of the samples taken during each sampling 
period. The averaging method depends upon AVG Type selection (voltage, power or 
log scales).

Factory Preset: AVERage

Range: NORM | POS | NEG | AVER 

Front Panel Access: Det/Demod, Detector
Monitor Spectrum—Center Frequency 
[:SENSe]:MONitor:FREQuency[:CENTer] <freq>

[:SENSe]:MONitor:FREQuency[:CENTer]?

Sets the center frequency.

Factory Preset: 1.5 GHz 

Range: 0 Hz to 26.5 GHz

Remarks: The center frequency range shifts up or down depending on the Frequency 
Offset settings.

Default Unit: Hz

Front Panel Access: FREQUENCY/Channel, Center Freq
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Monitor Spectrum—Frequency Offset 
218
[:SENSe]:MONitor:FREQuency:OFFSet <freq>

[:SENSe]:MONitor:FREQuency:OFFSet?

Enables you to input a frequency offset value to account for frequency conversions 
external to the N8201A. This value is added to the display readout of the marker 
frequency, center frequency, start frequency, stop frequency and all other absolute 
frequency settings in the N8201A. When a frequency offset is entered, the value appears 
below the center of the graticule. To eliminate an offset, perform a Factory Preset or set 
the frequency offset to 0 Hz.

This command does not affect any bandwidths or the settings of relative frequency 
parameters such as delta markers or span. It does not affect the current hardware settings 
of the N8201A, but only the displayed frequency values. Offsets are not added to the 
frequency count readouts. Entering an offset does not affect the trace display.

Factory Preset: 0 Hz

Range: –325 GHz to +325 GHz

Default Unit: Hz

Front Panel Access: FREQUENCY/Channel, Freq Offset
Monitor Spectrum—Frequency Offset Auto
[:SENSe]:MONitor:FREQuency:OFFSet:AUTO ON|OFF|1|0

[:SENSe]:MONitor:FREQuency:OFFSet:AUTO?

Allows you to specify whether the N8201A compensates automatically for a frequency 
changing device, or whether you wish to set the compensation manually. Setting a value 
on ‘ON’ or ‘1’ makes the compensation automatic, and setting to ‘OFF’ or ‘0’ set the 
compensation to manual.

Manually setting the Frequency Offset to 0 Hz is equivalent to disabling the feature.

Factory Preset: On

Front Panel Access: FREQUENCY/Channel, Freq Offset
Monitor Spectrum—Frequency Span 
[:SENSe]:MONitor:FREQuency:SPAN <freq>

[:SENSe]:MONitor:FREQuency:SPAN?
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Sets the frequency span. Setting the span to 0 Hz puts the N8201A into zero span. 

Factory Preset: 2.9900 GHz 

Range: 10 Hz to 26.5 GHz

Default Unit: Hz

Front Panel Access: 

SPAN/X Scale, Span

or 

SPAN/X Scale, Zero Span
Monitor Spectrum—Automatic Frequency Span to RBW Ratio 
[:SENSe]:FREQuency:SPAN:BANDwidth[:RESolution]:RATio:AUTO OFF|ON|0|1

[:SENSe]:FREQuency:SPAN:BANDwidth[:RESolution]:RATio:AUTO?

Selects between automatic and manual coupling of the span to the resolution BW ratio 
that will be used for displaying signals.

Factory Preset: On (Auto)

Range: Off|On|0|1

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: BW/Avg, Span/RBW
Monitor Spectrum—Ratio of Frequency Span to RBW
[:SENSe]:FREQuency:SPAN:BANDwidth|BWIDth[:RESolution]:RATio <val>

[:SENSe]:FREQuency:SPAN:BANDwidth|BWIDth[:RESolution] :RATIO?

Sets the automatic coupling of the span to the resolution BW to be used for displaying 
signals. The value is entered as the ratio of span:RBW.

Factory Preset: 106

Range: 2 to 1000
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Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: BW/Avg, Span/RBW
Monitor Spectrum—Full Frequency Span 
[:SENSe]:MONitor:FREQuency:SPAN:FULL

Sets the frequency span to full scale. 

Factory Preset: 26.49 GHz

Front Panel Access: SPAN/X Scale, Full Span
Monitor Spectrum—Zero Frequency Span 
[:SENSe]:MONitor:FREQuency:SPAN:ZERO

Sets the frequency span to zero. 

Front Panel Access: SPAN/X Scale, Zero Span
Monitor Spectrum—Start Frequency 
[:SENSe]:MONitor:FREQuency:STARt <freq>

[:SENSe]:MONitor:FREQuency:STARt?

Sets the start frequency.

Factory Preset: 10 MHz

Range: –100 MHz to 26.49 GHz

The valid range of Frequency Start settings (above) applies when Frequency Offset is set 
to 0 Hz. Frequency Offset settings greater than 0 Hz have the effect of shifting the entire 
range up by the Frequency Offset.

Default Unit: Hz

Front Panel Access: FREQUENCY/Channel, Start Freq
Monitor Spectrum—Stop Frequency 
[:SENSe]:MONitor:FREQuency:STOP <freq>
N8201A Noise Figure Measurement Personality Guide



Language Reference 6

N8201A Noise Figure
[:SENSe]:MONitor:FREQuency:STOP?

Set the stop frequency.

Factory Preset: 3.0 GHz

Range: –99.99999 MHz to 26.49 GHz

The valid range of Frequency Start settings (above) applies when Frequency Offset is set 
to 0 Hz. Frequency Offset settings greater than 0 Hz have the effect of shifting the entire 
range up by the Frequency Offset.

Default Unit: Hz

Front Panel Access: FREQUENCY/Channel, Stop Freq
Monitor Spectrum—RF Port Input Attenuation 
[:SENSe]:MONitor:POWer[:RF]:ATTenuation <rel_power>

[:SENSe]:MONitor:POWer[:RF]:ATTenuation?

Sets the RF input attenuator. This value is set at its auto value if RF input attenuation is 
set to auto.

Factory Preset: 10 dB

Range: 0 to 70 dB

Default Unit: dB

Front Panel Access: AMPLITUDE/Y Scale, Attenuation
Monitor Spectrum—RF Port Input Attenuator Auto
[:SENSe]:MONitor:POWer[:RF]:ATTenuation:AUTO ON|OFF|1|0

[:SENSe]:MONitor:POWer[:RF]:ATTenuation:AUTO?

Selects the RF input attenuator range to be set either automatically or manually.

ON - Input attenuation is automatically set as determined by the reference level 
setting.

OFF - Input attenuation is manually set.

Factory Preset: ON (auto)

Front Panel Access: AMPLITUDE/Y Scale, Attenuation
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Monitor Spectrum—Internal Preamp 
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[:SENSe]:MONitor:POWer[:RF]:GAIN[:STATe] ON|OFF|1|0

[:SENSe]:MONitor:POWer[:RF]:GAIN:[:STATe]?

Turns the internal preamp on or off. This requires you to have Option 1DS or Option 110 
installed.

Factory Preset: ON (if available)

Front Panel Access: Meas Setup, Int Preamp
Monitor Spectrum—Optimize Reference Level 
[:SENSe]:MONitor:POWer[:RF]:RANGe:AUTO

Optimizes the reference level and the attenuator settings for the current signal in the 
current span. To prevent possible damage to the N8201A, the values are set with the 
noise source turned ON. 

The Reference Level is set so that the signal is kept as close as possible to the top of the 
display. Attenuation is set to a level such that the mixer input never exceeds –20 dBm. 
All attenuation settings are allowed, including 0 dB.

Factory Preset: 

Front Panel Access: Amplitude, Optimize Ref Level
Monitor Spectrum—Trace Points 
[:SENSe]:MONitor:SWEep:POINts?

Queries the number of trace points.

Factory Preset: 601

Range: 101 to 8192 

Front Panel Access: Sweep
Monitor Spectrum—Sweep Time 
[:SENSe]:MONitor:SWEep:TIME <value>

[:SENSe]:MONitor:SWEep:TIME?
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Specifies the sweep time of the measurement.

Factory Preset: Automatically calculated

Range: 

1 μs to 2 ksecs in zero span 

1 ms to 2 ksecs in swept mode 

Front Panel Access: Sweep
Monitor Spectrum—Time Mode 
[:SENSe]:MONitor:SWEep:TIME:AUTO OFF|ON|0|1

[:SENSe]:MONitor:SWEep:TIME:AUTO?

Specifies whether the sweep time is set automatically or manually.

Factory Preset: ON (Auto)

Remarks: If set to AUTO, the sweep time will be affected by the RBW setting.

Front Panel Access: Sweep
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Noise Figure Measurement 
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Commands for querying the noise figure measurement results and for setting to the 
default values are found in the MEASure group of commands. The equivalent front 
panel keys for the parameters described in the following commands are found under the 
Meas Setup key, after the Noise Figure measurement has been selected from the 
MEASURE key menu.
Noise Figure—Average Count 
[:SENSe][:NFIGure]:AVERage:COUNt <integer>

[:SENSe][:NFIGure]:AVERage:COUNt?

Sets the number of data acquisitions that will be averaged. After the specified number of 
average counts, the averaging mode (terminal control) setting determines the averaging 
action.

Factory Preset: 10

Range: 1 to 1000

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Meas Setup, Avg Number
Noise Figure—Averaging State 
[:SENSe][:NFIGure]:AVERage[:STATe] OFF|ON|0|1

[:SENSe][:NFIGure]:AVERage[:STATe]?

Turns averaging on or off.

Factory Preset: OFF

Remarks: 

You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

The SCPI command :CONFigure:NFIGure does not switch averaging ON, but rather 
sets averaging to the factory default of OFF.

Front Panel Access: Meas Setup, Avg Number
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[:SENSe][:NFIGure]:AVERage:TCONtrol?

Queries the type of termination control used for the averaging function. This determines 
the averaging action after the specified number of data acquisitions (average count) is 
reached.

REPeat - After reaching the average count, the averaging is reset and a new average is 
started.

Factory Preset: REPeat

Range: REPeat only

Remarks: 

You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

It is not possible to perform exponential averaging on noise figure measurements, so 
repeat averaging is always used.

Front Panel Access: Front Panel access is disabled (grayed out) as REPeat is the only 
option.
Noise Figure—Resolution Bandwidth 
[:SENSe][:NFIGure]:BANDwidth|BWIDth[:RESolution] <freq>

[:SENSe][:NFIGure]:BANDwidth|BWIDth[:RESolution]?

Enables you to select the 3.01 dB resolution bandwidth (RBW) of the N8201A in 10% 
steps from 1 Hz to 3 MHz, plus bandwidths of 4, 5, 6, or 8 MHz. 

If an unavailable bandwidth is specified, the closest available bandwidth is selected.

Sweep time is coupled to RBW. As the RBW changes, the sweep time (if set to Auto) is 
changed to maintain amplitude calibration. 

Factory Preset: 1 MHz

Range: 1 Hz to 8 MHz

Default Unit: Hz

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.
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Front Panel Access: BW/Avg
Noise Figure—Resolution Bandwidth Automatic
[:SENSe][:NFIGure]:BANDwidth|BWIDth[:RESolution]:AUTO OFF|ON|0|1

[:SENSe][:NFIGure]:BANDwidth|BWIDth[:RESolution]:AUTO?

Couples the resolution bandwidth to the frequency span.

When set to Auto, the RBW is set to a value that gives you the best results. The actual 
RBW settings used for various frequencies is shown in the table below.

When set to Auto, resolution bandwidth is auto coupled to span. The ratio of span to 
RBW is set by Span/RBW. The factory default for this ratio is approximately 106:1 
when auto coupled.

When Res BW is set to Man, bandwidths are entered by the user, and these bandwidths 
are used regardless of other N8201A settings.

Factory Preset: ON (Auto)

Range: ON (Auto) | OFF (Manual)| 1 | 0

Remarks: 

You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

For valid results below 10 MHz, the N8201A must be DC coupled. 

Instrument damage can occur if there is a DC component present at the RF INPUT 
and DC coupling is selected.

Table 11 RBW Auto Settings

Measurement Frequency Resolution Bandwidth

< 3 MHz Measurement Frequency / 10

3 MHz or higher 1 MHz
Noise Figure—Calibrate
[:SENSe][:NFIGure]:CORRection:COLLect[:ACQuire] STANdard 

Calibrates your measurement for use with a specific noise source. When issuing this 
command, the ENR (Excess Noise Ratio) data must already have been entered into the 
ENR table, or into the Calibration Table if Common Table has been switched off.
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Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Example: CORR:COLL STAN

Front Panel Access: Meas Setup, Calibrate
Noise Figure—Number of Entries in Calibration ENR Table
[:SENSe][:NFIGure]:CORRection:ENR:CALibration:TABLe:COUNt?

Returns the number of pairs of entries (that is, frequency and amplitude pairs) in the 
calibration ENR (Excess Noise Ratio) table.

Factory Preset: Not applicable

Range: 1 to 401 frequency/amplitude point pairs.

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Meas Setup, ENR, Cal Table...
Noise Figure—Calibration ENR Table Data 
[:SENSe][:NFIGure]:CORRection:ENR:CALibration:TABLe:DATA <frequency, 
<amplitude>[,<frequency>, <amplitude>]

[:SENSe][:NFIGure]:CORRection:ENR:CALibration:TABLe:DATA?

Enters data into the current calibration ENR table. Once entered the table can be stored 
in a file.

It is not possible to specify units with this command and values are taken to be in Hz and 
dB. The query returns values in Hz and dB.

Factory Preset: Not applicable

Range: 1 to 401 pairs of frequency and amplitude figures.

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Meas Setup, ENR, Cal Table...
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Noise Figure—Noise Source ID for Calibration ENR Table 
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[:SENSe][:NFIGure]:CORRection:ENR:CALibration:TABLe:ID :DATA <string>

[:SENSe][:NFIGure]:CORRection:ENR:CALibration:TABLe:ID :DATA?

Enters the ID of the noise source associated with the ENR table used for calibration. The 
ID is stored with the ENR table when saving it to file.

Factory Preset: Not applicable

Range: Quoted string of up to 12 characters (for example, ’346B’).

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Meas Setup, ENR, Cal Table...
Noise Figure—Noise Source Serial Number for Calibration ENR Table
[:SENSe][:NFIGure]:CORRection:ENR:CALibration:TABLe:SERial :DATA <string>

[:SENSe][:NFIGure]:CORRection:ENR:CALibration:TABLe:SERial :DATA?

Enters the serial number of your noise source into the calibration table. This uniquely 
identifies the specific noise source associated with this calibration data.

Factory Preset: Not applicable

Range: Quoted string of up to 20 characters (for example, ’2037A00729’).

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Meas Setup, ENR, Cal Table...
Noise Figure—Common ENR Table Control 
[:SENSe][:NFIGure]:CORRection:ENR:COMMon[:STATe] ON|OFF|1|0

[:SENSe][:NFIGure]:CORRection:ENR:COMMon[:STATe]?

Enables and disables the common ENR table. When enabled, the measurement ENR 
table is used for both calibration and measurement. When disabled, calibration uses its 
own table.

Factory Preset: ON
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Range: ON|OFF|1|0

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Meas Setup, ENR, Common Table
Noise Figure—Number of Entries in Measurement ENR Table
[:SENSe][:NFIGure]:CORRection:ENR[:MEASurement]:TABLe:COUNt?

Queries the number of entries in the measurement ENR (Excess Noise Ratio) table.

Factory Preset: Not applicable

Range: 0 to 401 frequency/amplitude point pairs.

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Meas Setup, ENR, Meas Table...
Noise Figure—Noise Source ID for Measurement ENR Table
[:SENSe][:NFIGure]:CORRection:ENR[:MEASurement]:TABLe:ID :DATA <string>

[:SENSe][:NFIGure]:CORRection:ENR[:MEASurement]:TABLe:ID :DATA?

Enters the ID of the noise source associated with the ENR table used for measurement. 
The ID is stored with the ENR table when saving it to file.

Factory Preset: Not applicable

Range: Quoted string of up to 12 characters (for example, ’346B’).

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Meas Setup, ENR, Meas Table...
Noise Figure—Noise Source Serial Number for Measurement ENR Table 
[:SENSe][:NFIGure]:CORRection:ENR[:MEASurement]:TABLe :SERial:DATA <string>

[:SENSe][:NFIGure]:CORRection:ENR[:MEASurement]:TABLe :SERial:DATA?
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Enters the serial number of the noise source associated with the ENR table used for 
measurement. The serial number is stored with the ENR table when saving it to file.

Factory Preset: Not applicable

Range: Quoted string of up to 20 characters (for example, ’2037A00729’).

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Meas Setup, ENR, Meas Table...
Noise Figure—Measurement ENR Table Data 
[:SENSe][:NFIGure]:CORRection:ENR[:MEASurement]:TABLe:DATA <frequency, 
<amplitude>[,<frequency>, <amplitude>]

[:SENSe][:NFIGure]:CORRection:ENR[:MEASurement]:TABLe:DATA?

Enters data into the current measurement ENR table. Once entered the table can be 
stored in a file.

It is not possible to specify units with this command and values are taken to be in Hz and 
dB. The query returns values in Hz and dB.

Factory Preset: Not applicable

Range: 0 to 401 frequency/amplitude point pairs

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Meas Setup, ENR, Meas Table...
Noise Figure—ENR Mode 
[:SENSe][:NFIGure]:CORRection:ENR:MODE TABLe|SPOT

[:SENSe][:NFIGure]:CORRection:ENR:MODE?

Selects between table and spot ENR operation.

TABLe – ENR values are taken from the ENR table.

SPOT – A single ENR value is applied at all frequencies.

Factory Preset: TABLe
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Range: TABLE or SPOT

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Meas Setup, ENR, ENR Mode
Noise Figure—ENR Spot Value 
[:SENSe][:NFIGure]:CORRection:ENR:SPOT <value>

[:SENSe][:NFIGure]:CORRection:ENR:SPOT?

Sets the ENR value used when spot ENR is enabled.

The ENR data can be entered in units of dB, Kelvin (K), degrees Celsius (CEL) or 
degrees Fahrenheit (FAR). The default unit is dB.

For Thot values below 290 K see the commands in “Noise Figure—ENR Spot Value" on 
page 231 and “Noise Figure—ENR THot Value" on page 231.

Factory Preset: 15.2 dB

Default Unit: dB

Range: –7.0 dB to 50 dB

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Meas Setup, ENR, Spot
Noise Figure—ENR THot Value
[:SENSe][:NFIGure]:CORRection:ENR:THOT <value>

[:SENSe][:NFIGure]:CORRection:ENR:THOT?

Sets the ENR value used when spot ENR is enabled.

The ENR data can be entered in units of Kelvin (K), degrees Celsius (CEL) or degrees 
Fahrenheit (FAR). The default unit is Kelvin.

This command would normally be used to enter ENR values below 290 K. See the 
commands under “Noise Figure—ENR Spot Value” on page 353 and “Noise 
Figure—ENR Spot Value” on page 353.

Factory Preset: 9892.8 K (equivalent to the Spot ENR default of 15.2 dB)
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Default Unit: K

Range: 0 K to 29,650,000 K

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Meas Setup, ENR, Spot T Hot
Noise Figure—After DUT Loss Compensation Mode 
[:SENSe][:NFIGure]:CORRection:LOSS:AFTer:MODE FIXed|TABLe

[:SENSe][:NFIGure]:CORRection:LOSS:AFTer:MODE?

Sets the mode of operation for the After DUT Loss Compensation.

TABLe – the After DUT Loss Compensation table is used.

FIXed – a single, fixed After DUT Loss Compensation value is used for all 
frequencies.

Factory Preset: FIXed

Range: FIXed or TABLe

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Input/Output, Loss Comp, After DUT Table...
Noise Figure—After DUT Loss Compensation State
[:SENSe][:NFIGure]:CORRection:LOSS:AFTer[:STATe] ON|OFF|1|0

[:SENSe][:NFIGure]:CORRection:LOSS:AFTer[:STATe]?

Enables or disables the After DUT Loss Compensation.

Factory Preset: OFF

Range: ON|OFF|1|0

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Input/Output, Loss Comp, Setup...
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[:SENSe][:NFIGure]:CORRection:LOSS:AFTer:TABLe:COUNt?

Returns the number of frequency/amplitude pairs of entries in the After DUT Loss 
Compensation table.

Factory Preset: 0

Range: 0 to 401 frequency/amplitude point pairs

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Input/Output, Loss Comp, After DUT Table...
Noise Figure—After DUT Loss Compensation Table Data 
[:SENSe][:NFIGure]:CORRection:LOSS:AFTer:TABLe:DATA <frequency>, 
<amplitude>[,<frequency>, <amplitude>]

[:SENSe][:NFIGure]:CORRection:LOSS:AFTer:TABLe:DATA?

Enters frequency/loss pairs into the After DUT loss table. This can be up to a maximum 
of 401 pairs.

You cannot specify units with this command. Frequencies are assumed to be in Hz and 
loss values are in dB.

Factory Preset: None

Range: Frequency: 10 Hz to upper frequency limit of the N8201A

Amplitude: –200 dB to 200 dB

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Input/Output, Loss Comp, After DUT Table...
Noise Figure—After DUT Loss Compensation Fixed Value 
[:SENSe][:NFIGure]:CORRection:LOSS:AFTer:VALue <value>

[:SENSe][:NFIGure]:CORRection:LOSS:AFTer:VALue?
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Specifies the single After DUT Loss Compensation value that is applied at all 
frequencies. You cannot specify units with this command. All loss values are given in 
dB. 

This compensation loss value will only be applied if the Compensation After DUT State 
is set to On, and if the Compensation After DUT is set to Fixed.

Factory Preset: 0 dB

Range: –100 dB to +100 dB

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Input/Output, Loss Comp, Setup..., Fixed
Noise Figure—Before DUT Loss Compensation Mode
[:SENSe][:NFIGure]:CORRection:LOSS:BEFore:MODE FIXed|TABLe

[:SENSe][:NFIGure]:CORRection:LOSS:BEFore:MODE?

Sets the mode of operation for the Before DUT Loss Compensation.

TABLe – the Before DUT Loss Compensation table is used.

FIXed – a single, fixed Before DUT Loss Compensation value is used for all 
frequencies.

Factory Preset: FIXed

Range: FIXed or TABLe

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Input/Output, Loss Comp, Before DUT Table...
Noise Figure—Before DUT Loss Compensation State
[:SENSe][:NFIGure]:CORRection:LOSS:BEFore[:STATe] ON|OFF|1|0

[:SENSe][:NFIGure]:CORRection:LOSS:BEFore[:STATe]?

Enables or disables the Before DUT Loss Compensation.

Factory Preset: OFF
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Range: ON|OFF|1|0

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Input/Output, Loss Comp, Setup...
Noise Figure—Number of Entries in Before DUT Loss Compensation Table
[:SENSe][:NFIGure]:CORRection:LOSS:BEFore:TABLe:COUNt?

Returns the number of frequency/amplitude pairs of entries in the Before DUT Loss 
Compensation table.

Factory Preset: 0

Range: 0 to 401 frequency/amplitude point pairs

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Input/Output, Loss Comp, Before DUT Table...
Noise Figure—Before DUT Loss Compensation Table Data 
[:SENSe][:NFIGure]:CORRection:LOSS:BEFore:TABLe:DATA <frequency>, 
<amplitude>[,<frequency>, <amplitude>]

[:SENSe][:NFIGure]:CORRection:LOSS:BEFore:TABLe:DATA?

Enters frequency/loss pairs into the Before DUT loss table. This can be up to a 
maximum of 401 pairs.

You cannot specify units with this command. Frequencies are assumed to be in Hz and 
loss values are in dB.

Factory Preset: None

Range: 

Frequency: 10 Hz to upper frequency limit of the N8201A

Amplitude: –200 dB to 200 dB

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Input/Output, Loss Comp, Before DUT Table...
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[:SENSe][:NFIGure]:CORRection:LOSS:BEFore:VALue <value>

[:SENSe][:NFIGure]:CORRection:LOSS:BEFore:VALue?

Specifies the single Before DUT Loss Compensation value that is applied at all 
frequencies. You cannot specify units with this command. All loss values are given in 
dB. 

This compensation loss value will only be applied if the Compensation Before DUT 
State is set to On, and if the Compensation Before DUT is set to Fixed.

Factory Preset: 0 dB

Range: –100 dB to +100 dB

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Input/Output, Loss Comp, Setup..., Fixed
Noise Figure—Spot ENR Mode
[:SENSe][:NFIGure]:CORRection:SPOT:MODE ENR|THOT

[:SENSe][:NFIGure]:CORRection:SPOT:MODE?

The command “Noise Figure—ENR Spot Value" on page 231 cannot be used to enter 
values below 290 K. The command “Noise Figure—ENR THot Value" on page 231 can 
enter temperature values below 290 K. This command selects which value is used in 
making measurements.

Factory Preset: ENR

Range: ENR or THOT

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Meas Setup, ENR, Spot, Spot State
Noise Figure—User Tcold Control 
[:SENSe][:NFIGure]:CORRection:TCOLd:USER[:STATe] ON|OFF|1|0

[:SENSe][:NFIGure]:CORRection:TCOLd:USER[:STATe]?
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Turns manual control of the TCold value On or Off. When set to Off, the default value of 
296.5 K is used.

Factory Preset: Off

Range: ON|OFF|1|0

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Meas Setup, ENR, T cold
Noise Figure—User Tcold Value
[:SENSe][:NFIGure]:CORRection:TCOLd:USER:VALue <temperature>

[:SENSe][:NFIGure]:CORRection:TCOLd:USER:VALue?

Sets the Tcold value in units of Kelvin (K), degrees Celsius (CEL) or degrees Fahrenheit 
(FAR). This is the applied value when User Tcold is enabled.

Factory Preset: 296.5 K

Range: 0 K to 29,650,000 K

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Meas Setup, ENR, T cold
Noise Figure—Correction After DUT Temperature
[:SENSe][:NFIGure]:CORRection:TEMPerature:AFTer <temperature>

[:SENSe][:NFIGure]:CORRection:TEMPerature:AFTer?

Sets the after DUT temperature in units of Kelvin (K), degrees Celsius (CEL) or degrees 
Fahrenheit (FAR).

Factory Preset: 0 K

Range: 0 K to 29,650,000 K

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Meas Setup, ENR, T cold
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Noise Figure—Correction Before DUT Temperature
238
[:SENSe][:NFIGure]:CORRection:TEMPerature:BEFore <temperature>

[:SENSe][:NFIGure]:CORRection:TEMPerature:BEFore?

Sets the before DUT temperature in units of Kelvin (K), degrees Celsius (CEL) or 
degrees Fahrenheit (FAR).

Factory Preset: 0 K

Range: 0 K to 29,650,000 K

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Meas Setup, ENR, T cold
Noise Figure—Detector 
[:SENSe][:NFIGure]:DETector[:FUNCtion] AVERage

[:SENSe][:NFIGure]:DETector[:FUNCtion]?

Sets and returns the current Detector mode settings.

AVERage is the only valid setting for this command.

Factory Preset: AVERage

Range: AVERage

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Det/Demod
Noise Figure—Center Frequency Value
[:SENSe][:NFIGure]:FREQuency:CENTer <frequency>

[:SENSe][:NFIGure]:FREQuency:CENTer?

Sets the center frequency when Frequency Mode is set to Sweep.

The frequency can be entered in units of Hz, kHz, MHz or GHz. The query always 
returns the value in Hz.
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Factory Preset: 1.505 GHz

Range: 10 kHz to 325 GHz

Remarks: 

You will need to use a frequency downconverter to reach the N8201A’s maximum 
center frequency of 325 GHz. Without a frequency downconverter, your center 
frequency will be limited to 10 kHz to 26.49 GHz

You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Frequency/Channel
Noise Figure—Fixed Frequency Value 
[:SENSe][:NFIGure]:FREQuency:FIXed <frequency>

[:SENSe][:NFIGure]:FREQuency:FIXed?

Sets the frequency used when fixed frequency mode is enabled.

The frequency can be entered in units of Hz, kHz, MHz or GHz. The query always 
returns the value in Hz.

Factory Preset: 1.505 GHz

Range: 0 Hz to 325 GHz

Remarks: 

You will need to use a frequency downconverter to reach the N8201A’s maximum 
fixed frequency of 325 GHz. Without a frequency downconverter, your maximum 
fixed frequency will be 0 Hz to 26.49 GHz. 

You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Frequency/Channel
Noise Figure—Frequency List Data
[:SENSe][:NFIGure]:FREQuency:LIST:DATA <frequency>[,<frequency>]

[:SENSe][:NFIGure]:FREQuency:LIST:DATA?
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Enters frequency values into the frequency table. These values represent the frequencies 
at which the noise figure will be measured. The frequency table can hold up to 401 
values. Once loaded, the table can be stored in a file.

You cannot specify units with this command and values are assumed to be Hz. The query 
returns values in Hz.

Factory Preset: Not applicable

Range: 1 to 401 frequencies (in Hz)

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode, and your Frequency Mode must be set 
to List.

Front Panel Access: Frequency/Channel
Noise Figure—Number of Entries in the Frequency List 
[:SENSe][:NFIGure]:FREQuency:LIST:COUNt?

Returns an integer representing the number of frequency values in the frequency table.

Factory Preset: Not applicable

Range: 1 to 401

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Frequency/Channel, Freq List
Noise Figure—Frequency Mode 
[:SENSe][:NFIGure]:FREQuency:MODE SWEep|FIXed|LIST

[:SENSe][:NFIGure]:FREQuency:MODE SWEep?

Selects the method by which measurement frequencies are generated.

SWEep - frequency values are generated from the start frequency, the stop frequency, 
and the number of points parameters

FIXed - the fixed frequency value is used

LIST - frequencies are taken from a User defined frequency list

Factory Preset: SWEep
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Range: SWEep, FIXed or LIST

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Frequency/Channel
Noise Figure—Frequency Span
[:SENSe][:NFIGure]:FREQuency:SPAN <span>

[:SENSe][:NFIGure]:FREQuency:SPAN?

Selects the frequency span.

The frequency can be entered in units of Hz, kHz, MHz or GHz. The query always 
returns the value in Hz.

Factory Preset: 2.990000 GHz

Range: 100 Hz to 325 GHz

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Span/X Scale
Noise Figure—Start Frequency Value 
[:SENSe][:NFIGure]:FREQuency:STARt <start frequency>

[:SENSe][:NFIGure]:FREQuency:STARt?

Selects the start frequency that is used when the Frequency Mode has been set to 
SWEep, or when you are using the Fill... option in the Frequency List Form.

The frequency can be entered in units of Hz, kHz, MHz or GHz. The query always 
returns the value in Hz.

Factory Preset: 10 MHz

Range: 10 kHz to (325 GHz minus the minimum span setting)

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Frequency/Channel
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Noise Figure—Stop Frequency Value 
242
[:SENSe][:NFIGure]:FREQuency:STOP <stop frequency>

[:SENSe][:NFIGure]:FREQuency:STOP?

Selects the stop frequency that is used when the Frequency Mode has been set to 
SWEep, or when you are using the Fill... option in the Frequency List Form.

The frequency can be entered in units of Hz, kHz, MHz or GHz. The query always 
returns the value in Hz.

Factory Preset: 3 GHz

Range: (10 Hz plus the minimum span setting) to 325 GHz

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Frequency/Channel
Noise Figure—Internal Preamp Control 
[:SENSe][:NFIGure]:POWer[:RF]:GAIN[:STATe] ON|OFF|1|0

[:SENSe][:NFIGure]:POWer[:RF]:GAIN[:STATe]?

Turns the internal preamp On or Off.

If the preamp is switched On, a correction is applied to compensate for the gain of the 
preamp so that the results still show the value at the INPUT connector. If you are using 
Option 1DS, the preamp is removed from the circuit, and the correction is not applied. If 
you are using Option 110, the correction is applied at all frequencies from 100 kHz up to 
the maximum frequency of your N8201A.

Using your internal preamp (if available) dramatically improves the noise figure over the 
100 kHz to 3 GHz frequency range (Option 1DS), or at all frequencies above 100 kHz 
(Option 110). If you are measuring within the range of your preamp, you should always 
have the internal preamp switched On unless either you are using an external preamp, or 
your DUT has sufficient gain.

If the internal preamp is On, this is indicated by “PA” being displayed on the left side of 
the screen. The internal preamp is not available if Input Mixer (Int) has been selected 
(Option AYZ). 

Factory Preset: ON (if available)

Range: ON or OFF, 1 or 0
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Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Meas Setup
Noise Figure—Number of Points in a Sweep 
[:SENSe][:NFIGure]:SWEep:POINts <integer>

[:SENSe]:SWEep:POINts?

Sets the number of points in a sweep.

Factory Preset: 11

Range: 2 to 401

Default Unit: Points

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Frequency
Noise Figure—Microwave Attenuation 
[:SENSe][:NFIGure]:MANual:MWAVe:FIXed <attenuation>

[:SENSe][:NFIGure]:MANual:MWAVe:FIXed?

Sets the attenuation to be used. The attenuation can be set in 4 dB increments.

Factory Preset: 0 dB

Range: 0 dB to 40 dB, but within the minimum and maximum attenuation range.

Default Unit: dB

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Input/Output

This command has the same effect as

:INPut[:NFIGure]:ATTenuation:VALue <power>. See “RF Attenuation 
Setting" on page 184.
 Measurement Personality Guide 243



6 Language Reference
Noise Figure—RF Attenuation 
244
[:SENSe][:NFIGure]:MANual:RF:FIXed <attenuation>

[:SENSe][:NFIGure]:MANual:RF:FIXed?

Sets the attenuation to be used. The attenuation can be set in 4 dB increments.

Factory Preset: 0 dB

Range: 0 dB to 40 dB, but within the minimum and maximum attenuation range.

Default Unit: dB

Remarks: You must be in the Noise Figure mode to use this command. Use 
INSTrument:SELect NFIGURE to set the mode.

Front Panel Access: Input/Output

This command has the same effect as

:INPut[:NFIGure]:ATTenuation:VALue <power>. See “RF Attenuation 
Setting" on page 184.
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SOURce Subsystem
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The SOURce subsystem controls the signal characteristics of the source.
Noise Source Preference
:SOURce[:NFIGure]:NOISe[:PREFerence] NORMal

:SOURce[:NFIGure]:NOISe[:PREFerence]?

Sets the noise source to be NORMal type 

Factory Preset: NORMal

Range: NORMal

Front Panel Access: No front panel access
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TRACe Subsystem
246
TRACe subsystem controls access to the instruments internal trace memory.

Refer also to  :CALCulate and  :MMEMory subsystems for more trace and limit line 
commands.
Query Trace Maximum Amplitude 
:TRACe[:NFIGure][:DATA]:CORRected|:UNCorrected:AMPLitude:MAXimum? <trace>

Returns the maximum amplitude of the given trace and the frequency at which it occurs. 
The returned values are comma separated and the amplitude value precedes the 
frequency.

When corrected results are requested, <trace> can be one of:

• GAIN, returning results in dB

• NFACtor, returning linear results

• NFIGure, returning results in dB

• PCOLd, returning results in dB

• PHOT, returning results in dB

• TEFFective, returning results in degrees K

When uncorrected results are requested, <trace> can be one of:

• NFACtor, returning linear results

• NFIGure, returning results in dB

• PCOLd, returning results in dB

• PHOT, returning results in dB

• TEFFective, returning results in degrees K

• YFACor, returning results in dB

You must be in Noise Figure mode to use this command.

Front Panel Access: Not available
Query Trace Minimum Amplitude 
:TRACe[:NFIGure][:DATA]:CORRected|:UNCorrected:AMPLitude:MINimum? <trace>

Returns the minimum amplitude of the given trace and the frequency at which it occurs. 
The returned values are comma separated and the amplitude value precedes the 
frequency.

When corrected results are requested, <trace> can be one of:
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• GAIN, returning results in dB

• NFACtor, returning linear results

• NFIGure, returning results in dB

• PCOLd, returning results in dB

• PHOT, returning results in dB

• TEFFective, returning results in degrees K

When uncorrected results are requested, <trace> can be one of:

• NFACtor, returning linear results

• NFIGure, returning results in dB

• PCOLd, returning results in dB

• PHOT, returning results in dB

• TEFFective, returning results in degrees K

• YFACor, returning results in dB

You must be in Noise Figure mode to use this command.

Front Panel Access: Not available
Query Trace Amplitude 
:TRACe[:NFIGure][:DATA]:CORRected|:UNCorrected:AMPLitude [:VALue]? 
<trace>,<freq> 

Returns the amplitude value of the given trace at the specified frequency.

When corrected results are requested, <trace> can be one of:

• GAIN, returning results in dB

• NFACtor, returning linear results

• NFIGure, returning results in dB

• PCOLd, returning results in dB

• PHOT, returning results in dB

• TEFFective, returning results in degrees K

When uncorrected results are requested, <trace> can be one of:

• NFACtor, returning linear results

• NFIGure, returning results in dB

• PCOLd, returning results in dB

• PHOT, returning results in dB

• TEFFective, returning results in degrees K
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• YFACor, returning results in dB

You must be in Noise Figure mode to use this command.

Front Panel Access: Not available
Query Trace Delta 
:TRACe[:NFIGure][:DATA]:CORRected|:UNCorrected:DELTa? <trace>,<freq1>,<freq2>

Returns the value obtained by subtracting the amplitude at frequency1 from that at 
frequency2.

When corrected results are requested, <trace> can be one of:

• GAIN, returning results in dB

• NFACtor, returning linear results

• NFIGure, returning results in dB

• PCOLd, returning results in dB

• PHOT, returning results in dB

• TEFFective, returning results in degrees K

When uncorrected results are requested, <trace> can be one of:

• NFACtor, returning linear results

• NFIGure, returning results in dB

• PCOLd, returning results in dB

• PHOT, returning results in dB

• TEFFective, returning results in degrees K

• YFACor, returning results in dB

You must be in Noise Figure mode to use this command.

Front Panel Access: Not available
Query Trace Peak to Peak 
:TRACe[:NFIGure][:DATA]:CORRected|:UNCorrected:PTPeak? <trace>

Returns the difference between the maximum and minimum amplitude values on the 
given trace and the frequency difference between the two frequency points where the 
maximum and minimum occur. The returned values are comma separated and the 
amplitude value precedes the frequency.

When corrected results are requested, <trace> can be one of:

• GAIN, returning results in dB
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• NFACtor, returning linear results

• NFIGure, returning results in dB

• PCOLd, returning results in dB

• PHOT, returning results in dB

• TEFFective, returning results in degrees K

When uncorrected results are requested, <trace> can be one of:

• NFACtor, returning linear results

• NFIGure, returning results in dB

• PCOLd, returning results in dB

• PHOT, returning results in dB

• TEFFective, returning results in degrees K

• YFACtor, returning results in dB

You must be in Noise Figure mode to use this command.

Front Panel Access: Not available
 Measurement Personality Guide 249
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Common Problems and their Resolution
252
Below is a list of some of the more common problems associated with making noise 
figure measurements, and hints on their resolution.

Results are wrong at low frequencies

The AC/DC coupling needs to be set to DC Coupling. DC Coupling is required for 
greatest accuracy when measuring frequencies below 20 MHz.

When changing to DC Coupling, make sure there is no DC component being fed into the 
N8201A’s input port as this could seriously damage the hardware.

When changing to DC Coupling, make sure there is no DC component being fed into the 
analyzer’s input port as this could seriously damage the hardware.

Spurs in the Frequency Band you are Measuring

If there are any spurs in the frequency band that you are measuring, these can affect the 
measurement. Signals as low as –60 dBm can affect your noise figure measurement. Use 
the Monitor Spectrum measurement with Preamp switched On and Attenuation set to 
0 dB to look for spurs. The Agilent Technologies application note 57-2 Noise Figure 
Measurement Accuracy - the Y-Factor Method has more information in the Preventing 
Interfering Signals section. This application note is available from the Agilent website at 
http://www.agilent.com.

DSB Measurement on a Downconverter - Measurement are too Low

If you are making a DSB measurement on a down converting DUT, you must enter a 
Loss Compensation of –3 dB at a Temperature of 290 K. This is because both double 
sidebands fold down to the same IF frequency, thus doubling the measured power.

This does not apply if you are using the System Downconverter because both sidebands 
are present in the calibration and in the measurement.

Does the LO Signal Contain Broadband Noise at the IF?

When testing Frequency Converters, make sure that the LO signal does not contain 
broadband noise at the IF frequency. To eliminate broadband noise at the LO, insert a 
high-pass filter on the LO port when measuring a downconverter. When measuring an 
upconverter, insert a low-pass filter on the LO port. These filters must pass signals at the 
LO frequency, but not at the IF frequency.

My Results are too High or too Low

When you are using Loss Compensation, it is important to set the correct DUT 
temperature. Setting the Temperature to 290 K will compensate for the noise as well as 
the gain. Leaving the DUT Temperature at 0 K will result in only the gain being 
compensated.
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What Sort of Tolerances Should I Expect in my Measurement?

If you are not sure what level of tolerance to expect in your results, you can use the 
Uncertainty Calculator (See “Noise Figure Uncertainty Calculator" on page 63.) to 
calculate the expected result tolerances. This will give you a guide to your expected 
measurement accuracy.

The Measurement Accuracy is not what I Expected

For maximum accuracy, it is advisable not to attempt to measure noise figures greater 
than 10 dB above the relevant ENR value of the noise source.

‘Check that the DUT is not overdriving the analyzer. “Power Detection and Ranging" on 
page 33 gives some guidance on the levels required. 

To check for overdriving of the analyzer, that is, compression occurring at the preamp 
stage, set the attenuation to 0 dB and note the noise figure of your DUT. Now increase 
the attenuation by one step (either 4 dB or 5 dB, depending on your analyzer) by 
pressing the up-arrow key. If your noise figure changes by more than 0.5 dB, attenuation 
is required. Repeat this process until you have found the lowest level of attenuation that 
gives you a stable noise figure result, and use this attenuation level for your 
measurements.

When using external pre-amps or high-gain DUTs, ensure that neither the external 
pre-amp (or the high-gain DUT) nor the internal pre-amp go into compression as this 
will affect the accuracy of your measurements. If you suspect that one or other of the 
pre-amps is going into compression, use attenuation prior to that pre-amp to prevent 
compression. Note that the analyzer’s internal attenuator will only affect compression 
occurring in the internal pre-amp. It will not have any effect on any compression 
occurring in the external pre-amp.

Measurements are Taking too Long

If your measurements are taking too long, you can reduce the time taken by switching 
Averaging to Off, by increasing the Resolution Bandwidth, and by reducing the Number of 
Points on a swept measurement.

If the measurement is taking longer than about 8 minutes, it is advisable to switch 
Alignments to Off because the measurement will restart itself every time the analyzer 
realigns itself.

Calibration is Taking too Long

If you find that your calibration is taking too long, you can reduce the calibration time by 
reducing the frequency span or the attenuation range. This reduces the number of 
frequency points at which the analyzer is calibrated. Either increase the minimum 
frequency in the calibration range, or decrease the maximum frequency.
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Calibration Data > 3 GHz is not what I Expected

Measurement performance > 3 GHz is not specified. If you do not have a preamp and 
you are calibrating above 3 GHz, the calibration data will vary significantly. 
Measurements made with this calibration data might be valid, but only if the device you 
are testing has a high enough gain and noise figure, such that the sum of these is about 
35 dB or more. The measurement accuracy will be poor. See “Problems Measuring 
Above 3 GHz" on page 255.
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Problems Measuring Above 3 GHz 
N8201A Noise Figure
A preamp is needed for measurements > 3 GHz. Agilent Option 110 (100 kHz to 50 GHz 
Internal Preamp) is ideal for this purpose. While it is possible to make valid 
measurements without a preamp, measurement accuracy is usually poor. The following 
curves describe the noise figure measurement error for DUTs with various gains and 
noise figures.
N8201A Frequency Range: >3 GHz (Non-Warranted) 
Assumptions: Measurement Frequency 12 GHz, Instrument NF = 26.5 dB, 
Instrument VSWR = 1.4, Instrument Gain Uncertainty = 2.2 dB, Instrument NF 
Uncertainty = 0.05 dB, Agilent 346B Source with Uncertainty = 0.2 dB, Source 
VSWR = 1.25, DUT input/output VSWR = 1.5

 
Curves for Positive Error Ranges for DUT NFs of 5, 10, and 15 dB

Measurement NF Uncertainty @ 12GHz  vs. DUT Gain, no Preamp
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Figure 41 Without Preamp - Nominal NF Error vs. DUT Gain

To use these curves you must be able to estimate the NF and Gain performance of the 
device that you want to test. Use these values to estimate the amount of measurement 
error.

For Example, if your DUT has NF = ~5 dB and gain = 20 dB. Plotting these values on 
the curves will give you an estimated error between ±3 dB. This amount of measurement 
uncertainty is probably too large for the your measurement needs. 
 M
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Now add a preamp to the measurement system. Assume this external preamp has NF = 
6dB and gain = 23 dB.

Assume that the measurement is being made at 12 GHz where the NF = 26.5 dB. Then 
the combined NF of the preamp + N8201A is ~8 dB. The following curves describe the 
noise figure measurement error for various DUTs, when the preamp is being used with 
the N8201A

Note that the Friss equation can be used to figure out what level of preamp performance 
is needed for the N8201A desired frequency range. See also Figure 43 on page 257 
below for nominal N8201A noise figure values.
Measurement NF Uncertainty @ 12GHz vs. DUT Gain, 
using 83006A as Preamp. PSA
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N8201A Frequency Range: >3 GHz (Non-Warranted) 
Assumptions: Same as above, with the addition of an external pre-amp. With an 
external pre-amp, the pre-amp/analyzer combination NF is 7.93 dB; the external 
pre-amp alone has a gain of 23 dB and an NF of 6 dB. Instrument VSWR is now 
that of the external pre-amp; VSWR = 2.6

Curves for Positive Error Ranges for DUT NFs of 5, 10, and 15 dB
Figure 42 Computed Noise Figure Uncertainty versus DUT Gain, Non-warranted 
Frequency Range

Now suppose you have the same DUT with NF = ~5 dB and gain = 20 dB. Plotting these 
values on the curves will give you an estimated error that is very small, so the N8201A 
can be used for this measurement. 
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Suppose you measure a different DUT that has no gain and has NF = 5 dB. Plotting these 
DUT values on the above curves gives about 4 dB measurement error. So this second 
DUT’s measurement results would have an unacceptable measurement error.
Figure 43 No Preamp - Nominal Noise Figure*
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Contacting Agilent

Agilent on the Web 
260
You can find information about technical and professional services, product support, and 
equipment repair and service on the Web: http://www.agilent.com.

1 Click on the Test & Measurement link then click on Select a Country. 

2 Click on the Contact Us link for contact information. 
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